Jump to content
Fórum Script Brasil
  • 0
Sign in to follow this  
RenatoMejias

Soma Condicional

Question

Nesta dica estarei mostrando como usar a soma condicional no Excel; imagine a seguinte situação, temos dois vendedores (Marcelo e Gabriel) e cada um ganha de acordo com o que vende, suponha que você tenha a seguinte planilha:

1tabelayf7.jpg

Agora eu quero saber como somarei apenas a comissão de cada um de forma independente. Para isso usaremos a função Soma Condicional, caso você ainda não tenha instalado o suplemtento para Assistente de soma condicional, consulte este tópico.

A opção de Soma condicional está na seguinte localização:

suplementoswv9.jpg

Aparecerá a seguinte janela:

proc1tm3.jpg

Aqui selecionaremos a matriz que estamos utilizando, inclusive os cabeçalhos. Avançar.

A seguir aparecerá a seguinte janela:

proc2bi9.jpg

Veja que já adicionei a seguinte condição Vendedor=Gabriel, ou seja, o que for Gabriel na coluna Vendedor será somado o seu respectivo valor em Comissão. Avançar.

A seguir aparecerá a seguinte janela:

proc3vc8.jpg

Ai nós temos a opção de obter apenas o valor, ou obter o valor e o nome do vendedor, no caso vou pegar apenas o valor. Avançar.

A seguir aparecerá a seguinte janela:

proc4xk7.jpg

Aqui selecionamos a célula onde queremos que apareça o valor da soma condional. Concluir.

E assim obtemos a comissão do Gabriel, para fazer a do Marcelo é seguir os procedimentos acima e só alterar a condição para que seja Vendedor=Marcelo.

Veja como ficará depois de pronto:

finaleu9.jpg

Qualquer dúvida é só postar...

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0
Guest --flavia --

Olá

eu tenho o seguinte caso

coluna D coluna g

br 12 10

br 14 2

ven 20 3

ecu 30 4

br 15 14

quero fazer uma formula que some a coluna g se o item da coluna d começar com "br"

no caso o resultado seria 28

não consegui por somase

tentei fazer por vetor mas não consegui, acho que não estou fazendo certo.

Alguém pode me ajudar?

Obrigada

Share this post


Link to post
Share on other sites
  • 0
Guest --Master --

estou com seguinte problema, quero inserir uma formula a onde o excel somase 2 coluna ou seja sempre que o Excel localiza "1484" no intervalo C3:C900, ele verifica o texto "mecanica" na mesma linha na coluna C (o intervalo C3:C900). O Excel calcula, então, o número de linhas que contêm os dois.

estou tentado a seguinte formula:

=SOMA(SE(B5:B25="1484"; SE(C5:C25="mecanica";1;0)))

mas esta tanto resultado ''0'' na celular resultado.

Eu li seu tutorial cuidadosamente, e percebi que você realizo o office 2003, estou tentado reealiza este calculo no office 2000.

Acho que seu tutorial não se aplica a formula que esta tentado realiza, mas você poderia me da um ajuda?

Share this post


Link to post
Share on other sites
  • 0

Envie essa planilha no meu e-mail, quando possível darei uma olhada.

Share this post


Link to post
Share on other sites
  • 0

Veja se a função cont.ses serve para você. Veja uma descrição que retirei da ajuda do Office:

CONT.SES

Conta o número de células dentro de um intervalo que satisfazem múltiplos critérios.

Sintaxe

CONT.SES(intervalo1, critérios1,intervalo2, critérios2…)

Intervalo1, intervalo2, … são 1 a 127 mais intervalos para avaliar os critérios associados. As células devem ser números ou nomes, matrizes ou referências que contenham números. Os valores em branco e de texto são ignorados.

Critérios1, critérios2, ... são 1 a 127 critérios na forma de um número, uma expressão, uma referência de célula ou um texto que define quais células serão contadas. Por exemplo, os critérios podem ser expressos como 32, "32", ">32", "maçãs" ou B4.

Comentários

Cada célula em um intervalo é contada apenas se todos os critérios correspondentes especificados são verdadeiros para aquela célula.

Se os critérios estiverem em uma célula vazia, CONT.SES a tratará como um valor igual a 0.

Você pode utilizar caracteres curinga, como ponto de interrogação (?) e asterisco (*), nos critérios. Um ponto de interrogação corresponde a qualquer caractere; um asterisco corresponde a qualquer seqüência de caracteres. Se você quiser localizar um ponto de interrogação ou asterisco real, digite um til (~) antes do caractere.

Exemplo

Talvez seja mais fácil entender o exemplo se você copiá-lo em uma planilha em branco.

Como copiar um exemplo

Crie uma pasta de trabalho ou planilha em branco.

Selecione o exemplo no tópico da Ajuda.

Observação Não selecione os cabeçalhos de linha ou de coluna.

Selecionando um exemplo na Ajuda

Pressionar CTRL+C.

Na planilha, selecione a célula A1 e pressione CTRL+V.

Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.

1

2

3

4

5

6

7

8

9

10

A B C D

Vendedor Quota de Acessórios Ultrapassada Quota de Dispositivos Ultrapassada Quota de Apetrechos Ultrapassada

Ribeiro Sim Não Não

Cardoso Sim Sim Não

Ruivo Sim Sim Sim

Bento Não Sim Sim

Fórmula Descrição (resultado)

=CONT.SES(B2:D2,"=Sim") Conta quantas vezes Ribeiro ultrapassou uma quota de vendas de Acessórios, Dispositivos e Apetrechos (1)

=CONT.SES(B2:B5,"=Sim",C2:C5,"=Sim") Conta quantas pessoas ultrapassaram suas Quotas de Acessórios e Dispositivos (2)

=CONT.SES(B5:D5,"=Sim",B3:D3,"=Sim") Conta quantas vezes Bento e Cardoso ultrapassaram a mesma quota de Acessórios, Dispositivos e Apetrechos (1)

Share this post


Link to post
Share on other sites
  • 0
Guest --marco --

Olá renato estou com a mesma duvida que o 'master', queria fazer uma soma, digamos 'bicondicional', ou seja na parte de critrios da formula ele precisaria satisfazer duas condições, isso é possivel?

Share this post


Link to post
Share on other sites
  • 0
Guest --marco --

Consegui já! Como o que eu precisava era muito parecido com o CONT.SES eu deduzi que existia uma formula SOMA.SES e ela existe e fez o que eu precisava! Grato!

Share this post


Link to post
Share on other sites
  • 0

Renato:

No meu caso é um pouco diferente do que consta de seu tutorial. Veja bem! Eu não busco apenas um subtotal. Na verdade, cada mês do período será um subtotal. Para ficar mais claro: no mês de jan/01 de plan3 eu tenho que somar os valores relativos aos meses de jan de plan1, plan2 e outras planilhas caso existam. No mês de jan/01 de plan3 somo os valores relativos aos meses de fev de plan1, plan2 e outras planilhas caso existam e assim ocorre para todos os meses, inclusive dez/01. Nas planilhas exemplos que enviei: plan1 e plan2 que seriam somadas em plan3, plan2 só possui valores em dezembro de cada ano do período. Por isto, não vejo como urilizar soma condicional neste caso.

Share this post


Link to post
Share on other sites
  • 0
estou com seguinte problema, quero inserir uma formula a onde o excel somase 2 coluna ou seja sempre que o Excel localiza "1484" no intervalo C3:C900, ele verifica o texto "mecanica" na mesma linha na coluna C (o intervalo C3:C900). O Excel calcula, então, o número de linhas que contêm os dois.

estou tentado a seguinte formula:

=SOMA(SE(B5:B25="1484"; SE(C5:C25="mecanica";1;0)))

mas esta tanto resultado ''0'' na celular resultado.

Eu li seu tutorial cuidadosamente, e percebi que você realizo o office 2003, estou tentado reealiza este calculo no office 2000.

Acho que seu tutorial não se aplica a formula que esta tentado realiza, mas você poderia me da um ajuda?

Amigo,

acabei de testar a sua fórmula e creio que sei o que aconteceu...

Se o campo numério que você possui com o nº "1484" estiver formatado como geral ou número, a sua fórmula não poderá ter "" no número, ou seja, ela deverá ficar assim: =SOMA(SE(B5:B25=1484;SE(C5:C25="mecanica";1;0))), pois "aspas" só é usado para texto.

Ahh.. mas lembre-se que para utilizar essa fórmula, é necessário que ao final da fórmula você digite <Shift> + <CTRL> + <ENTER>, pois isso é uma regra para utilizar esse tipo de calculo. Com isso, se você colocar o cursor sobre a célula estará escrito assim: {=SOMA(SE(B5:B25="1484"; SE(C5:C25="mecanica";1;0)))}

acho que é isso.

Share this post


Link to post
Share on other sites
  • 0

tengo dudas con el formato condicional de excel Quiero que me rellene: - rojo <= 80 -amarillo >80 y <100 -verde >=100 Alguien me puede ayudar por favor? Gracias

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



  • Forum Statistics

    • Total Topics
      148405
    • Total Posts
      643812
×
×
  • Create New...