Jump to content
Fórum Script Brasil
  • 0

Time


Jakim José

Question

contrui uma página em html e outra de resposta em asp. (configurei o servermodel no testing server "VBScript"

isto tudo, atrávés do dwmx2004.

na html, na action da form coloquei a página de resposta em asp e com o method "get", e um botão submit lá dentro,

na página de resposta coloquei <% = Time %>

pretendia com isto que me fosse indicada a hora na página de resposta.

quando pressionei "F12" para testar, apareceu-me a hora correcta"

no entanto,...

... quando publiquei o site e entrei nele...

ao pressionar o botão submit, em vez de me aparecer a hora apareceu-me um número esquisito "1071197410".

posto isto, a minha pergunta só pode ser:

- Mas afinal o quê que fiz de errado para não aparecer a hora correctamente?

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

apareceu o seguinte erro ao entrar no site, após a publicação:

Errors Output

error compiling hora.asp: Unterminated <> operator at /home/pages/public_html/rv/hora.asp line 19. , /usr/lib/perl5/site_perl/5.8.0/Apache/ASP.pm line 1432

Debug Output

Bareword found where operator expected at /home/pages/public_html/rv/hora.asp line 13, near ") sMes"

(Missing operator before sMes?)

Bareword found where operator expected at /home/pages/public_html/rv/hora.asp line 14, near ") sDia"

(Missing operator before sDia?)

Bareword found where operator expected at /home/pages/public_html/rv/hora.asp line 15, near ") sHoras"

(Missing operator before sHoras?)

Bareword found where operator expected at /home/pages/public_html/rv/hora.asp line 16, near ") sMinutos"

(Missing operator before sMinutos?)

Bareword found where operator expected at /home/pages/public_html/rv/hora.asp line 17, near ") sSegundos"

(Missing operator before sSegundos?)

Bareword found where operator expected at /home/pages/public_html/rv/hora.asp line 19, near ") If"

(Missing operator before If?)

error compiling hora.asp: Unterminated <> operator at /home/pages/public_html/rv/hora.asp line 19. , /usr/lib/perl5/site_perl/5.8.0/Apache/ASP.pm line 1432

Compiled Data with Error

-: package My::Bookmarks; ;; sub My::Bookmarks::__ASP__home_pages_public_html_rv_hora_aspxd6d639181ad3b1a78e090ab420b34f41xINC { ;; package My::Bookmarks; ;; no strict;;use vars qw($Application $Session $Response $Server $Request);;

-: #line 1 /home/pages/public_html/rv/hora.asp

1: ;; ; ; &Apache::ASP::WriteRef($main::Response, \('

2: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

3: <html>

4: <head>

5: <title>Untitled Document</title>

6: <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

7: </head>

8:

9: <body>

10: '));

11: Function Data(sData)

12:

13: sMes = Month( sData )

14: sDia = Day( sData )

15: sHoras = Hour( sData )

16: sMinutos = Minute( sData )

17: sSegundos = Second( sData )

18:

19: If sMes <= 9 Then sMes = "0" & sMes

20: If sDia <= 9 Then sDia = "0" & sDia

21: If sHoras <= 9 Then sHoras = "0" & sHoras

22: If sMinutos <= 9 Then sMinutos = "0" & sMinutos

23: If sSegundos <= 9 Then sSegundos = "0" & sSegundos

24:

25: Data = Year(sData) & "-" & sMes & "-" & sDia & " " & sHoras & ":" & sMinutos & ":" & sSegundos

26:

27: End Function

28: ; &Apache::ASP::WriteRef($main::Response, \('

29: '.(Data(Now)).'

30: </body>

31: </html>')); ;; }

--------------------------------------------------------------------------------

An error has occured with the Apache::ASP script just run. If you are the developer working on this script, and cannot work through this problem, please try researching it at the Apache::ASP web site, specifically the FAQ section. Failing that, check out your support options, and if necessary include this debug output with any query.

o quê k será?

Link to comment
Share on other sites

  • 0

mas eu instalei o apache há já algum tempo!

desinstalei-o, formatei o disco e instalei o iis.

isto é, o que eu tenho instalado é o iis e não o apache.

nota: li num artigo que «A Microsoft recomenda, por motivos de segurança, que antes da sua instalação, você formate todas as unidades onde o IIS será utilizado com o sistema de arquivos NTFS»

eu formatei em "fat32 normal"

será que é esse o problema?

porque qd ponho a visualizar no dwmx2004, através do "F12" aparece tudo bem!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      152.1k
    • Total Posts
      652k
×
×
  • Create New...