Jump to content
Fórum Script Brasil
  • 0

Problema Com Document Type


UDE
 Share

Question

Falai, pessoal... estou com um probleminha no meu site e preciso da ajuda de vocês. É o velho problema do site que abre em IE e não abre no FireFox.

www.meiadoisA.com/TESTE05 quem puder dar uma ohada e abrir nos dois navegadores vai ver exatamente o que acontece.

O código que estou usando no meu HTML é o seguinte:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

<meta http-equiv="pragma" content="no-cache">

<meta name="Description" content="Meia Dois A -labdesign- &eacute; um est&uacute;dio de cria&ccedil;&atilde;o especializado em web, design gr&aacute;fico e multim&iacute;dia. Esse laborat&oacute;rio sensorial, situado no cora&ccedil;&atilde;o de S&atilde;o Paulo, tem como principal objetivo a produ&ccedil;&atilde;o de uma arte que supere as expectativas e desperte no p&uacute;blico algo a mais que o simples desejo pelo objeto.">

<meta name="Keywords" content="62A, MEIADOISA, MEIA DOIS A, EST&Uacute;DIO DE CRIA&Ccedil;&Atilde;O, WEB, WEBDESIGN, DESIGN GR&Aacute;FICO, LOGOTIPIA, PRINT, IMPRESS&Atilde;O, FLASH, ACTIONSCRIPT, MULTIM&Iacute;DIA, EDUARDO SOARES DE OLIVEIRA, FABIOLA CARVALHO">

<meta name="copyright" content="&copy; 2004 - 2007 Meia Dois A Comunica&ccedil;&atilde;o Visual Produ&ccedil;&atilde;o de Foto e V&iacute;deo LTDA. Todos os direitos reservados.">

<meta name="Reply-to" content="[email protected]">

<meta name="generator" content="Adobe Flash Professional 8">

<meta name="ROBOTS" content="ALL">

<link rel="shortcut icon" type="image/ico" href="imgs/logo.ico">

<title>meiadoisA.com = meiadoisA.com.br</title>

<style type="text/css">

<!--

body {

margin-left: 0px;

margin-top: 0px;

margin-right: 0px;

margin-bottom: 0px;

left: auto;

top: auto;

right: auto;

bottom: auto;

width: 1420px;

}

-->

</style>

<script src="Scripts/AC_RunActiveContent.js" type="text/javascript"></script>

</head>

<body bgcolor="#ffffff">

<!--url's used in the movie-->

<!-- btext used in the movie-->

<!-- saved from url=(0013)about:internet -->

<script type="text/javascript">

AC_FL_RunContent( 'codebase','http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0','width','100%','height','100%','id','index','align','left','src','index','quality','high','scale','noscale','salign','l','bgcolor','#ffffff','name','index','allowscriptaccess','sameDomain','pluginspage','http://www.macromedia.com/go/getflashplayer','movie','index' ); //end AC code

</script><noscript><object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="100%" height="100%" id="index" align="left">

<param name="allowScriptAccess" value="sameDomain">

<param name="movie" value="index.swf">

<param name="quality" value="high">

<param name="scale" value="noscale">

<param name="salign" value="l">

<param name="bgcolor" value="#ffffff">

<embed src="index.swf" quality="high" scale="noscale" salign="l" bgcolor="#ffffff" width="100%" height="100%" name="index" align="left" allowscriptaccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" /></embed>

</object></noscript>

</body>

</html>

O que percebi é que quando eu tiro a primeira linha do código (Document type) ele funciona normalmente no FireFox, porém eu perco a barra de rolagem no IE.

O que eu preciso é de um código que sirva para os dois navegadores ou em último caso um comando que identifique qual é o navegador que esta acessando meu site e jogar para a index que abra corretamente, uma para cada navegador.

Espero ter conseguido me fazer entender e espero a ajuda de vocês.

Abraços.

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      150.1k
    • Total Posts
      647.1k
×
×
  • Create New...