Jump to content
Fórum Script Brasil
  • 0

(Resolvido) função excel: procurar dados com condição


mia

Question

oi. é o meu primeiro post e não sou muito entendida em excel, por isso espero conseguir explicar-me bem.

Tenho que preencher todos os dias uma lista (excel) onde coloco informações dos clientes (contactos, empresa...)

Essas informações vou buscá-las a outro separador excel (plan2), copio e colo. Isto demora.

Descobri a função ProcV (vlookup) e agora, ao inserir o nome na coluna A, automaticamente aparece o telefone e a empresa nas colunas B e C.

Só que tenho um problema: alguns clientes têm o mesmo nome, e colocar uma nota qualquer no nome para que o procv os distinga - por exemplo "jose silvaa" e "jose silvab" - vai voltar a dificultar o trabalho (imaginem lembrar de cada nota para cada um dos mais de 200 clientes).

Queria descobrir uma função ou conjunto de funções que procurasse os dados atendendo a uma condição:

Ao escrever o nome do cliente na coluna A e o nome da empresa na coluna B da plan1, procurasse o contacto na plan2 atendendo à condição: jose silva (plan2!colunaA) a que corresponde a empresa BRA (colunaB) tem o contacto 123 (colunaC correspondente).

isto é possível?

Muito obrigado.

Edited by mia
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Consegui!!! :D

(não fui bem eu, mas...consegui!!!)

A solução que me deram foi a seguinte:

Criar uma coluna A na plan2 (folha de contactos) com a fórmula =CONCATENAR(B2:C2)

Com isto, cria-se uma coluna que junta os dados da coluna B e C (nomes e empresa), ou seja Jose SilvaBRA, Jose SilvaBANCO, etc (automático)

Fico então com uma coluna fantasma que será a referência a procurar na plan1 (lista diária)

Na plan1, insiro uma coluna fantasma - por exemplo, na coluna C - (pode ficar escondida) com a fórmula concatenar =CONCATENAR(A2:B2)

Com isto, crio uma nova coluna que também me vai juntar o nome que escrevi na lista com a empresa que também escrevi.

Aqui já não é B2:C2, porque na lista (plan1) a coluna do nome é a A e a coluna da empresa é a B.

Finalmente, na coluna "contacto" insiro a fórmula do procv onde lhe digo que procure na plan2 o contacto correspondente à referência indicada na célula C.

O que acontece?

Vai procurar Jose SilvaBRA (da coluna C da plan1) e encontrá-lo na coluna A da plan2, associando o contacto da célula C2 da plan2.

Confuso? O exemplo é mais fácil:

plan1: Lista Diária

__A__________B__________C__________________D

1_nome_______empresa____fantasma____________contacto

2_Jose Silva____BRA_______=concatenar(A2;B2)___=PROCV(D2;plan2!A1:C2;4;FALSO)

3_Jose Silva____BANCO_____=concatenar(A3;B3)____=PROCV(D3;plan2!A1:C2;4;FALSO)

Plan2: Contactos

__A___________________B__________C__________D

1_fantasma____________nome_______empresa____contacto

2_=concatenar(B2;C2)___Jose Silva_____BRA______123

3_=concatenar(B3;C3)___Jose Silva_____BANCO____456

A indicação FALSO é imprescindível para que ele procure a informação exacta, senão retorna o valor mais alto.

As células fantasma podem ficar ocultas

Agora basta escrever o nome e a empresa na plan1 e aparece automaticamente o contacto na célula da frente.

Nota: não sei qual será a tradução para português da função CONCATENATE...será a fx JUNTAR ou Concatenar?

BOA!!! :D

Edited by mia
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      152k
    • Total Posts
      651.5k
×
×
  • Create New...