Jump to content
Fórum Script Brasil
  • 0
Sign in to follow this  
Guest wilene (lene)

Ajuda com dois algoritmos em portugol

Question

Guest wilene (lene)

olá pessoal studo engenharia, gostaria de uma ajuda com dois algoritmos em portugol :

1) faça um algoritmo que leia 2 valores (A,B), o algoritmo deve verificar se estes valores "são multiplos ou não são multiplos"

informar estas mensagens qo usuário.

2)faça um algoritmo que leia 4 variaveis A,B,C e D . A seguir , se B for maior do que C e se D for maior do que A e a soma de C com D for maior que a soma de A,B e se C e D ambos forem positivos e se a variavel A for par escreva a mensagem " valores aceitos " , se não escrever "valores não aceitos".

desde já fico muito grata por esta ajuda. um abraço a todos.

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

1) faça um algoritmo que leia 2 valores (A,cool.gif, o algoritmo deve verificar se estes valores "são multiplos ou não são multiplos"

informar estas mensagens qo usuário.

ps: Se alguém achar algum erro, por favor, posta aí!

ps2: Eu ACHO que funciona ;D

ps3: mod = modulo (resto da divisão)

Início
      Inteiros: numero1,numero2,multiplos=0;
      Escreva ("Digite os numeros");
      Leia (numero1,numero2);
      se (numero1>numero2) então
         Início
               se (numero1 mod numero2 = 0 )então
                  multiplos=1;
               fimse;
         fim;
      senão se (numero2>numero1) então
               Início
                     se (numero2 mod numero1 = 0 )então
                        multiplos=1;
                     fimse;
               Fim;
      senão
           multiplos=1;
      fimse;
      se (multiplos=1)então
         Escreve ("Multiplos");
      senão
           Escreve ("Não multiplos");
      fimse;
Fim

Edited by p4t0X

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Cloud Computing


  • Forum Statistics

    • Total Topics
      148586
    • Total Posts
      644292
×
×
  • Create New...