Jump to content
Fórum Script Brasil
  • 0

Like em Excel


Leo Mota
 Share

Question

Srs.,

Boa tarde!

Em SQL temos a função "LIKE", alguém sabé a mesma função em excel?

Tenho o seguinte caso, tenho 4 concatenações e na frente valores, porém preciso somar apenas quando a primeira coluna conter o nome desejado.

Ex:

Coluna A__________Coluna B

40817Joao____________10

40842Mariana_________20

40835Pedro___________30

40827Joao____________20

Preciso somar a segunda coluna apenas quando na primeira conter o nome "joao", independente do número que venha antes.

Abs.,

Leonardo.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0
Srs.,

Boa tarde!

Em SQL temos a função "LIKE", alguém sabé a mesma função em excel?

Tenho o seguinte caso, tenho 4 concatenações e na frente valores, porém preciso somar apenas quando a primeira coluna conter o nome desejado.

Ex:

Coluna A__________Coluna B

40817Joao____________10

40842Mariana_________20

40835Pedro___________30

40827Joao____________20

Preciso somar a segunda coluna apenas quando na primeira conter o nome "joao", independente do número que venha antes.

Abs.,

Leonardo.

=SE(éerro(LOCALIZAR("joao";A1));"não tem joao";SOMA(B1:B4))

tradução .... localizar o nome joao no texto da célula A1 , se der erro escreva NÃO TEM JOÃO, c tiver joao some o intervalo B1:B4

Edited by maureucio
Link to comment
Share on other sites

  • 0

It's no secret that Excel is a powerful tool. It's also no secret that not everyone knows how to use it to its full potential. So you can check  https://masterbundles.com/templates/presentations/powerpoint/proposal/ to learn more new things about template. Masterbundle offers students a chance to experience some of the best courses and training available. If you want to learn more about Excel, but are looking for a user-friendly approach without feeling bogged down by too much jargon, then Like em Excel is the training manual for you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      151k
    • Total Posts
      649.1k
×
×
  • Create New...