• 0
Sign in to follow this  
Fernando Vaz

mostrar vezes que o numero repetiu

Question

preciso criar um algoritmo que crie um vetor de 36 posiçoes com valores randomicos encontre o valor menor e maior e indique suas posiçoes... precisa também encontrar os valores repetidos e mostrar quantas vezes repetiou

consegui fazer ate encontrar os valores repetidos. e d tanto mexer até consegui uma hora contar certinho... mas na hora de mostrar na tela ele mostra repetindo os valores repetidos (acho q da pra entender hehehe)

tipo se o 10 repetiu 3 vezes ele mostra

10 3 vezes

10 3 vezes

10 3 vezes

+/- isso

aqui vai o que eu já fiz até empaca nessa parte

var

vet: vetor[1..36] de inteiro

i, j, r, f: inteiro

maior, p_maior, p_menor, menor: inteiro

repet, n_repet: vetor[1..36] de inteiro

seed: inteiro

inicio

seed <- 101

maior <- 0

menor <- seed

escreval("entre com os valores do vetor: ")

para i de 1 ate 36 faca

vet <- randi(seed)

se (vet < menor) então

menor <- vet

p_menor <- i

fimse

se (vet > maior) então

maior <- vet

p_maior <- i

fimse

fimpara

limpatela

escreval(" vetor ")

para i de 1 ate 36 faca

escreva(vet)

fimpara

escreval()

escreval()

escreval("menor valor e:", menor, " na posicao:", p_menor)

escreval()

escreval("maior valor e:", maior, " na posicao:", p_maior)

escreval()

escreval(" numeros repetidos ")

para i de 1 ate 36 passo 1 faca

para j de 1 ate 36 passo 1 faca

se (vet = vet[j]) e (i <> j) então

repet <- vet

n_repet <- n_repet + 1

escreval("o numero",repet," repetiu", n_repet," vez(s)")

fimse

fimpara

fimpara

fimalgoritmo

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this