Jump to content
Fórum Script Brasil
  • 0

Campo Calculado Tabela Dinamica


Raphael Pinho
 Share

Question

Pessoal,

Estou buscando uma solução para somar os últimos 3 meses de forma móvel em uma tabela dinâmica por meio de um campo calculado

Por exemplo:

O resultado exibido na coluna de junho seria igual à soma dos meses de junho/maio/abril, o de maio seria a soma de maio/abril/março, o de abril a soma de abril/março/fevereiro, etc...

http://www.sendspace.com/file/mv8rq6

Por exemplo, na segunda tabela o resultado desejado a ser exibido em maio-12 para a questão Cel.A seria 631 (179 de maio + 229 de abril + 223 de março) o de abril-12 para a mesma questão seria 727

Tentei usar a formula desloc como campo calculado mas não é aceito

Alguém saberia como fazer?

Obrigado

Edited by Raphael Pinho
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Seria um pouco complicado você usar as ferramentas nativas de tabela dinâmica para obter o efeito que deseja.

Tenho uma sugestão. Na célula J42, entre com a fórmula:

="Acum. " & TEXTO(D42;"mmm-aa")

Arraste essa fórmula (copie) até a célula N42.

Na célula J43, entre com a fórmula:

=SOMA(B43:D43)

Copie essa fórmula para o intervalo J43:N76.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      150.2k
    • Total Posts
      647.4k
×
×
  • Create New...