Jump to content
Fórum Script Brasil
  • 0

Crie um algoritmo com o Visualg


guigo10x

Question

Baseado no cenário proposto crie um diagrama de classe onde temos uma classe livro e editora, com as seguintes informações.

Classe livro:

* atributos: nome do livro, isbn do livro, autor do livro e ano.

* metodos: cadastrar, alterar, excluir e pesquisar editora

Para o relacionamento destas clases temos as seguintes informações:

* uma editora pode ter nenhum ou muito livros

* um livro terá somente uma editora.

crie um diagrama entidade relacionamento, aplicado o processo de MRN. ultilizando a ferramenta BrModelo.

___________________________________________________________________________________________________

A parte de codigos será feita com o Visualg.

O programa deverá permitir a inclusão até que ocorra um erro de execesso de dados, OVERFLOW - Erro de excesso de dados, sua pilha está completa!!!

Caso a inserção seja realizada mostrar a seguinte mensagem,.. "inclusão bem sucesida"

Na exclusão deverá dar mensagem de erro quando ocorrer ausencia de dados UNDERFLOW- erro de ausencia de dados.

O programa devera ser implrementado sem erros de copilação.

segue o escopo. Falta só a implementação

< algoritmo Inclusão de pilha>

var

topo. n aux, posição : inteiro

vet : vetor [1...5] de caracter

y, opcao : caracter

k: inteiro

inicio

n <- 5

topo <- 0

repita

//imprimindo vetor original

limpatela

escreval ("------------------------ pilha na alocação sequencial- ")

escreval (" ")

escreval (" ")

para K de n ate 1 passo -1 faca

escreval (k, "...........", vet [k])

fimpara

escreval (" ")

escreval ("comeco .... 1 ")

escreval ("n ..............", topo)

escreval (" ")

escreval ("............................................")

escreval (" ")

escreval (" ")

// menu do sistema

escreval ("+------------------+ ")

escreval ("l menu operacoes l ")

escreval ("+------------------+ ")

escreval (" l 0 - sair l")

escreval (" l 1 - incluir l")

escreval (" l 2 - excluir l")

escreval (" +------------------+")

escreval (" ")

escreval (" Escolha uma opcao...")

leia (opcao)

se opcao = "1" então

escreva (" informe um valor para incluir" )

leia (y)

// inclua aqui o codigo de inclusão

fimse

se opcao = "2" então

// inclua aui o codigo de exclusão

finse

ate apcao="0"

fimalgoritmo

<>poderá mandar por email para mim avaliar tamém,..<Guigorodrigues10@<>gmail.com>

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      152k
    • Total Posts
      651.5k
×
×
  • Create New...