Jump to content
Fórum Script Brasil
  • 0

Exercícios de Algoritmo e Fluxograma


Cris Sousa
 Share

Question

Tou terminado o semestre e meu professor passou cinco questões valendo 10 pontos de algoritmo.Fazemos os códigos com Visualg.

1. Crie um algoritmo que some dois valores e mostre na tela: A média, qual o valor maior e qual é o par.

Respondi parcialmente esse primeiro mas ta dando erro.

Aqui o código

algoritmo "semnome"
// Função :
// Autor :
// Data :
// Seção de Declarações
var
a, b, soma, med, maior, par: real
inicio
a <- 10
b <- 5
soma <- a + b
med <- soma / 2
escreva ("O valor da soma é :) " (soma)
escreva "O valor da média é: " (med)
se (a > B) então
maior <- a
senao
maior <- b
fimse
escreva "O valor de maior é: " (maior)
se (a % 2 == 0) então
par <- a
fimse
se (b % 2 == 0) então
par <- b
fimse
escreva "O numéro par é: " (par)
fimalgoritmo

2. Crie um fluxograma que leia do usuário o valor de um ingresso e no final mostre: o total da arrecadação e quantos ingressos foram vendidos. O fluxograma só deve parar ao digitar zero no valor do ingresso.

3. Faça um algoritmo que leia um número e mostre na tela se ele é ou não um número primo.

4. Explique com suas palavras o que é um Loop em algoritmos.

5. Faça abaixo uma questão que envolva controle de fluxo e apresente a resposta da sua questão.

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      150.1k
    • Total Posts
      647k
×
×
  • Create New...