• 0
Sign in to follow this  
Paula Argon

Porcentagem algoritmo.

Question

Queria fazer a porcentagens dos grupos, tipo, 7 alunos, q todos tiraram 4 como nota, eles estariam no grupo C, então essa turma seria 100% grupo C. E o resto 0%..
Queria q o programa calculasse essa porcentagem. Mas estou enrolada com isso. Estou inciando ainda.

 


Var
   n: inteiro

   nota:real
   porcen:inteiro
   grupo:real


Inicio

   Escreval(" Quantidades de alunos?" )
   leia (n)

   Para nota de 1 ate n faca
      escreval( "Digite a nota")
      leia (nota)


      se (0.0 <=nota) e (nota<=2.5)então
         grupo<-nota

         escreval("Grupo D")
      senao
         se (nota>2.5) e (nota <= 5.0)então
            grupo<-nota
            escreval ("Grupo C")
         senao
            se (nota >5.0) e (nota <=7.5)então
               grupo<-nota
               escreval(" Grupo B")
            senao
               se (nota>7.5) e (nota<=10.0)então
                  grupo<-nota
                  escreval ("grupo A")
               senao

               fimse
            fimse
         fimse
      fimse
   fimpara
   

Fimalgoritmo

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this