• 0
Sign in to follow this  
Rafael Herrera

Problema com acentos

Question

Boa noite

Estou tentando migrar meu sistema para o banco de dados PostgreSQL (10.4).

Fiz o backup utilizando:

pg_dump --dbname <nome banco> --format plain  --inserts --username postgres --verbose --file <local backup> 2> <arquivo log>

Estou tentando restaurar o aquivo em outro banco usando:

psql -h localhost -U postgres -W -d <nome banco> < <local backup>

Tudo acontece normalmente, porém quando vou verificar os dados restaurados, estão todos com acentuação bagunçada. Editando o arquivo do backup noto que a acentuação está correta.

Já tentei mudar o banco para LATIN1.

O início do backup está:

SET statement_timeout = 0;
SET lock_timeout = 0;
SET idle_in_transaction_session_timeout = 0;
SET client_encoding = 'LATIN1';
SET standard_conforming_strings = on;
SELECT pg_catalog.set_config('search_path', '', false);
SET check_function_bodies = false;
SET client_min_messages = warning;
SET row_security = off;

 

Alguma ideia do que posso fazer para resolver?

Obrigado

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this