Jump to content
Fórum Script Brasil
  • 0

Echo não funciona no <head>


Question

Olá galera,

Não sou muito experiente, mas bobo também não sou. estou com um problema que já me fez mudar de ideia muitas vezes, mas chegou a hora de resolvê-lo:

- se eu citar a palavra "echo" em qualquer local da área <head><script> nenhum function é executado, não faz mas nada, nem formatação de números.

Por exemplo: document.getElementById('campo').value="<?php echo $variavel; ?> ";

Basta isso para nada que estiver dentro do <head> funcionar.

O que pode estar ocorrendo? Alguém sabe onde está o erro?

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Olá!
Comece seguindo a recomendação dos grandes! Eles recomendam colocar o javascript antes da tag de fechamento do body.

image.png.7faa4afb5dae0e31adfc42e7e09537e8.png

Como o sr. pode conferir aqui: https://developer.yahoo.com/performance/rules.html?guccounter=1#js_bottom

e aqui: https://developer.mozilla.org/pt-BR/docs/Aprender/Getting_started_with_the_web/JavaScript_basico

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      148692
    • Total Posts
      644524
×
×
  • Create New...