Jump to content
Fórum Script Brasil
  • 0

alguém sabe porque esse programa não faz o q se pede?


Question

Se trata desse questao, 

Ler um vetor W de 10 elementos, depois ler um valor V. Contar e escrever quantas vezes o valor V ocorre no vetor W e escrever também em que posições (índices) do vetor W o valor V aparece. Caso o valor V não ocorra nenhuma vez no vetor W, escreva uma mensagem informando isso. , se alguém souber o que esta dando errado e como resolver me ajude pfvvv

 

Algoritmo "pradps"
// Disciplina   : [Linguagem e Lógica de Programação]
// Professor   : Antonio Carlos Nicolodi 
// Descrição   : Aqui você descreve o que o programa faz! (função)
// Autor(a)    : Ricardo
// Data atual  : 17/12/2020
Var
// Seção de Declarações das variáveis 
W: vetor[1..10] de inteiro
V: vetor[1..10] de inteiro
i: inteiro

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
para i de 1 ate 10 faca
    escreval("Digite o [",i,"]° numero")
        leia(W[i])
     fimpara

escreva("--------------------------------")

para i de 1 ate 10 faca
    escreval("Digite [",i,"]° numero")
        leia(V[i])
     fimpara


para i de 1 ate 10 passo 1 faca
   V[i]<- W[i]
        escreval("V[i]", V[i])
   fimse
fimpara

Fimalgoritmo

Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      149190
    • Total Posts
      645445
×
×
  • Create New...