Jump to content
Fórum Script Brasil
  • 0

Multiplicação Condicional no excel


dtss

Question

Olá,

 

Preciso fazer uma multiplicação condicional no excel, porém os valores irão aumentando gradativamente. Por exemplo:

Tenho um total de 25h para calcular os valores a serem pagos, da seguinte forma:

De 0 à 10h - Não são cobrados

De 10:01 a 20h - São cobrados R$690,00 por hora

De 20:01 a 30:01 - São cobrados R$600,00 por hora

 

Então entre 10:01 e 20h o nº de horas deve ser multiplicado por R$690,00. De 20:01 a 25h o valor deve ser multiplicado por R$600,00. O total seria R$9.900,00 (10h isentas, 10h multiplicadas por R$690,00 e 5h multiplicadas por R$600,00). 

Alguém consegue me ajudar? Tentei a fórmula SE mas não consegui chegar ao resultado.

 

Obrigada!

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Este post é um pouco antigo e espero que o usuário tenha encontrado a solução para o seu problema.

No entanto, como não houve nenhuma resposta, deixarei aqui uma possível solução, pois poderá ajudar outras pessoas que tiverem a mesma dúvida.

Neste caso, recomendo utilizar as funções SE, E e VALOR.

As funções SE e E vão verificar as condições para retornar o resultado.

Já a função VALOR, ficará responsável por transformar as horas que estão no formato de texto, para o formato de números de série utilizado pelo Excel.

Para este exemplo, a fórmula ficará:

=SE(E(A2>VALOR("00:00");A2<=VALOR("10:00"));"Sem cobrança";SE(E(A2>=VALOR("10:01");A2<=VALOR("20:00"));"R$690,00";SE(E(A2>=VALOR("20:01");A2<=VALOR("30:01"));"R$600,00")))

Para mais detalhes de uso das funções SE e E juntas, recomendo a leitura deste post:

Função SE com E: Como usar as Duas Juntas?

 

 

 

 

Edited by HermesSantos
erro de digitação
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      152.1k
    • Total Posts
      651.9k
×
×
  • Create New...