• 0
Sign in to follow this  
Kogima

Texto Todo Errado

Question

Ae pessoal, to tentando fazer um sitema de notícias so que tem um problema, eu estava usando um editor de texto para paginas e o texto saia ok, mais para recuperar o valor caso eu quisece alterar ele não abria, então coloquei outro editor e fiz mais 2 campos, titulo e tema, o problema é o titulo ou tema pois quando eu digito por exemplo

Não

ele sai assim

Não

existe algum comando ou função que arruma isso:?? e se alguém souber algum editor de texto para sites me avisem beleza...

e a respeito para o campo notícia, existe alguma função para eu recuperar o código html sem nenhum erro pois algumas notícias ele recupera normal e outras ele nem consegue abrir, agradeço a quem ajudar pois estou tentando aprender sozinho...

valeu....

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Ae mestre!!!

Véio, configura o charset no seu HTML se não funcionar, verifica o que está na sua base de dados.

Quanto a retornar o HTML não entendi o que tu queres. Mas na dúvida analiza as funções htmlentities() e htmlspecialchars() no www.php.net e verifica qual lhe serve.

Abraço!

Share this post


Link to post
Share on other sites
  • 0

Onde eu configuro esse charset???

Novato é foda hehe.....

A respeito de retornar o HTML o editor as vezes não consegue retornar o codigo html, exemplo, se eu colo um texto que peguei em um site qualquer, ele até grava de boa no banco de dados, mais na hora de recuperar ele não consegue remontar o codigo perfeitamente, chegando ao ponto de não abrir o editor de texto que estou usando...

eu estou usando a função stripslashes para ajudar na gracação do codigo no banco.

Outra coisa, eu estou gravando o codigo em um campo no banco de dados com o valor text, esta correto????

Share this post


Link to post
Share on other sites
  • 0

E ae!!!

Desculpa a demora.

Cara, para "configurar" o charset podes testar direto no HTML:

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

Buenas, agora to disse que estás usando stripslashes pra adicionar ao bd???

Troca por addslashes na hora de adicionar e stripslashes na hora de recuperar.

Quanto à ser do tipo text n tem problema.

Testa ae... verifica também na sua base de dados se os dados estão completos.

Abraço!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this