• 0
Sign in to follow this  
Guest - Francisco -

Inno Setup

Question

Guest - Francisco -

oi pessoal tou usando o inno setup pa gerar setups para uma aplicação.consigo gerar o seu setup mas kuando dou duplo clike pa correr o programa, ele detecta um erro e fexa o programa!no relatorio d erro refere-se a um .dll. o meu executavel funciona mt bem mas dp d instalar c o setup gerado pelo inno setup ele dá esse erro!alguém sabe pk será ? obrigado

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0
Guest - Francisco -

A mensagem de erro é: A Aplicação (nome d meu .exe) encontrou um problema e vai ser encerrada. Lamanetamos qualquer inconveniente que isto lhe possa causar. é apenas isso; dá-me o mesmo erro de quando eu tentava correr o .exe quando o .exe não estava na mesma directoria do .mdb.mas iss já percebi k o .mdb tem d estar junto com o .exe; agor este problema não csg resolver! ajuda por favor

Share this post


Link to post
Share on other sites
  • 0

Ah, então o problema não é com o setup gerado pelo Inno e sim com sua aplicação ou com o computador em que ela está sendo instalada, ou ainda a falta de determinados arquivos no pacote. Recomendo que você gere o setup com Package and Deployment Wizard (com a opção Dependency) e veja quais são arquivos necessários (os nomes estarão em um arquivo .dep), daí coloque todos eles no seu script do Inno.

Abraços,

Graymalkin

Share this post


Link to post
Share on other sites
  • 0
Guest - Francisco -

Graymalkin, eu j tentei c o Package & Deplyment a partir do Vb, vou ao add-ins, add-in manager etc etc, mas tentei c o Package Type em:Standard; ele dá um erro: Out of date dependency information Crystl32.ocx mesmo assim ele deixa eu fazer "next" depois me aparece uma lista de files, disseram ai pa eu adicionar meu banco de dados é o k faço, m tenho uma duvida depois as imagens k tenho na minha aplicação tenho de adicionar uma por uma?e os .rpt tb um por um?eu no code d meu programa tenho varias vezes App.Path \Imagens\nomeimagem.ico e para os relatorios tb,iss terá algo a ver c meu problema?tb não sei s preencho as checkbox's na parte k diz "Shared Files".Depois no fim ele cria umas pasta package, k dentro tem uma k s chama support mas não t~eem nada dentro!Ajuda por favor! obrigado!

Share this post


Link to post
Share on other sites
  • 0

Sim, realmente você tem que incluir imagem por imagem, rpt por rpt e assim vai... um por um. Por isso é que eu lhe recomendo criar só o arquivo de depedências (Dependency) e depois ver neste arquivo quais são os arquivos necessários à sua aplicação e colocá-los (além das imagens, bds e rpts) no seu script do InnoSetup. Existe um programa chamado ISTool que cria o script do Inno baseado no arquivo gerado pelo Package & Deployment Wizard (não o de dependência, mas o normal).

Abraços,

Graymalkin

Share this post


Link to post
Share on other sites
  • 0
Guest - Francisco -

mas sendo assim, então faço o Package deployment no mode dependency, depois ele cria um arquivo .dep, depois vejo os files k aparecem nesse documento, de seguida começo o inno setup e adiciono todos esses files vistos no arquivo .dep certo ? mas agor pergunto eu, para quê fazer isso se no innosetup eu posso adicionar por expo a directoria d imagens as d relatorios e o file.mdb. pelo que eu percebi você tá dizendo pa eu por file por file no Inno Setup (os files criados no .dep) é isso ?

Share this post


Link to post
Share on other sites
  • 0
Guest - Francisco -

Graymalkin não posso usar o IsTool pk o package deployment não me xega a criar nenhum arquivo!não tou vendo como sair desta ?!!!

Share this post


Link to post
Share on other sites
  • 0
Guest - Francisco -

j encontrei uns sites k me dizem as dll necessárias, mas se voce tiver agradeço também, o meu crystal reports é o 8.5!

eu aind não tinha tentado iss k voce me disse k é no inno set up adicionar os files um por um, o que eu fazia era adicionar a directorias das imagens a directoria dos reports e não adicionava nenhuma dll pois pensava k ia buscar sozinho,assim dá mais trabalho m deve funcionar vams ver, faço add file a todos os files k vou precisar inclusivé as dll certo ?

mt obrigado pela ajuda!agor vou dar uma saida pk tnh d ir buscar mnha irmã até mais logo!kker coisa k voce s lembre ponha aki! Obrigado mais uma vez!

Share this post


Link to post
Share on other sites
  • 0
Guest - Francisco -

ponham aki outras hipoteses p eu resolver meu problema!agradecia!obrigado!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this