nego drama

Membros
  • Content Count

    54
  • Joined

  • Last visited

Community Reputation

0 Neutro

2 Followers

About nego drama

  • Birthday 08/05/1985

Perfil

  • Gender
    Male
  • Location
    camamu bahia
  1. você vai fazer o seguinte: crie 3 variavel (x, y , soma) depois do inicio entre com o comando leia (variaveis) como a variavel soma cauculo as outras 2 variavel e exiba o resultado
  2. lene, esse exercicio não é tão complicado de fazer (como se parece) ele é bem pequeno basta você separa por etapa exemplo primeiro ele pede pra declarar e ler 4 variaveis então você faz var a, b, c ,d: inteiro inicio ///////////////////////////////////////// //////////////////////////////////// ai so é fazendo por etapa se (b > c) e ( > ) e (( ) > ( )) e ( > ) e ( > ) e (a mod 2 = 0) então /////////////////////////////// senao ///////////////////////////// fimse fimalgoritmo tomo martigado so basta pensar um pouquinho
  3. muito obrigado Micheus so um observação pra quem tiver essa mesma dulvida, talvez tenha q declarar o n como inteiro pois como real no visualig da erro. abraço
  4. rivelino parceiro, crie um novo tópico e poste sua dulva assim o forum fica organizado e mais facil pra todos localizar o tópico com essa mesma dulvida um abraço
  5. crie um novo tópico e coloque sua dulvida, pra organizar o forum, cada dulvida em um tópico diferente um abraço
  6. p4t0X eu consegui entender alguma coisa mas não o bastante pra completar o meu algoritmo, pode me ajudar ai var h, n, FatParc: real cont, cont1 : inteiro inicio h := 0 para cont de 1 ate n faca FatParc := 1 para cont1 de 1 ate cont faca FatParc := FatParc * contl fimpara h := h + 1 / FatParc fimpara fimalgoritmo abraço
  7. ola, tambem estou precisando dessa resposta, tentei traduzir pra portugues o algoritmo mas nem assim conseguir ententer podem me explicar melhor como funciona esse algoritmo principal mente na parte onde n := x obrigado var h, n, FatParc: real cont, cont1 : inteiro inicio h := 0 para cont de 1 ate n faca FatParc := 1 para cont1 de 1 ate cont faca FatParc := FatParc * contl fimpara h := h + 1 / FatParc fimpara fimalgoritmo
  8. velho fiz a primeira parte da progreção geométrica faça o restante var a1, q, n, aux : inteiro inicio escreva ("entre com o valor de termos: ") leia (n) escreva("entre com o valor do primeiro termo: ") leia (a1) escreva ("entre com a razão: ") leia (q) para aux de 1 ate n faca a1:= a1 * q escreva (a1) fimpara fimalgoritmo um abraço
  9. Charles G. P. no seu primeiro para fazer a aprezentação fará o seguinte como você atribuiu 0 a variavel cont e totalnota, cont := 0 totalnota := 0 maior_nota := 0 menor_nota := 100 /// // /// / // /// se (maior_nota < nota ) então maior_nota := nota fimse se (menor_nota > nota) então menor_nota := nota fimse // / / / /
  10. shadow007 tem u erro no 5º analisando a pergunta percebi q pra indetificar o pais ele precisa esta entre dois valos e isto não esta acontecendo no nesse algoritmo // // // // // // se (codigo >= 1) e (codigo <= 20) então escreva ("europa") senao se (codigo >= 21) e (codigo <= 40) então escreva ("asia") // // // // // // observe q ele tem o valor inicial e o valor final. do seu geito qualquer numero q colocar ele vai mostrar todos os paises abraço
  11. velho eu não achei bom não quando você modificar analise primeiro se ficou bom, tente observar antes de mandar pro forum o seu algoritmo esta calculando normal esta mostrando saida ta ok mas como disse os racionais msc "meio certo não existe" você colocou o fimse abaixo do contador que é um erro outra coisa seria onde você colocou o fim enquanto abaixo da linhas escreval ou seja ele vai ta mostrado o resultado a todo momento no seria legal se ele mostrase o resultado no final da operação, não ficaria mais organizado? então eu te aconcelho reforça o seu base de logica, e tentar facilitar o seu trabalho var Prim_bimestre:vetor [1..35] de inteiro seg_bimestre : vetor [1..35] de inteiro media: vetor [1..35] de real media_turma, soma: real cont,aluno_acima_media : inteiro inicio cont<- 1 enquanto cont<= 10 faca escreva ("entre com a nota do primeiro bimestre: ") leia (Prim_bimestre [cont]) escreva ("entre com a nota do segundo bimestre: ") leia (seg_bimestre [cont]) media [cont] <- (Prim_bimestre [cont]+ seg_bimestre [cont])/2 soma:= soma + Prim_bimestre [cont]+ seg_bimestre [cont] se (media [cont] > 7 ) então aluno_acima_media <- aluno_acima_media + 1 fimse cont <- cont + 1 fimenquanto media_turma <- soma / 10 escreval ("O número de alunos aprovado foi de: ",aluno_acima_media) escreval ("A média obtida entre todos os alunos foi de: ",media_turma," alunos") fimalgoritmo
  12. shadow007 é pouca coisa q estou vendo você disse q seu algoritmo esta infinito, logo eu observei q você não colocou o contado pra conta cont := cont + 1 isso um pouco acima do ate cont = 5 var num, cont, multiplo_10,multiplo_3, soma_impar,produto_par: inteiro incio \\ Seção de Comandos multiplo_10 <- 0 multiplo_3 <- 0 produto_par <- 1 soma_impar <- 0 repita escreva ("entre com o numero: ") leia (num) se (num mod 2 <> 0) então soma_impar <- soma_impar + 1 fimse se (num mod 2 = 0) então produto_par <- produto_par * num fimse se (nuim mod 10 = 0) então {nessa linha você colocou nuim onde deveria ser num} multiplo_10 <-multiplo_10 + 1 fimse se (num mod 3 = 1) então multiplo_3 <- multiplo_3 + 1 fimse ate cont = 5 {acima dessa linha falta você colocar o contador : cont := cont + 1 se (produto_par = 1) então produto_par <- 0 fimse escreva ("soma dos numeros impares", soma_impar, " ") escreva ("quantidade de produtos pares", produto_par, " ") escreva ("numero multiplo de dez", multiplo_10, " ") escreva ("numero multiplo de trez", multiplo_3, " ") outra coisa pra facilitar você poderia trocar a linha escreva por escreval, ai fica um em baixo do outro, não fica na mesma linha escreval ("soma dos numeros impares: ", soma_impar) escreval ("quantidade de produtos pares: ", produto_par) escreval ("numero multiplo de dez: ", multiplo_10) escreval ("numero multiplo de trez: ", multiplo_3) tente e depois poste novamente já vi outras coisa o primeiro é pra achar os numero multiplo de 3 o conciente tem q cer 0 e não 1 se (num mod 3 = 1) então {no lugar de 1 coloque o 0} multiplo_3 <- multiplo_3 + 1 fimse pra achar somar os numeros impares se (num mod 2 <> 0) então soma_impar <- soma_impar + 1 {no lugar de 1 coloque num, ai então ele vai calcular todos os numeros impares e não conta quantos numeros impares tem} fimse
  13. e sobre declar todas a variaveis como inteiro não vejo problema uma vez q os calculos não vao resultar com casas decimal então pode deixalo como inteiro
  14. tire ou = coloque dessa forma se (num mod 2 <> 0)