• 0
Sign in to follow this  
Pirambu!

(Resolvido) Transferencia de dados

Question

Estou tentando fazer uma transferencia de dados de uma tabela do Paradox para uma tabela do Acess

o problema é que um dos campo da tabela do Paradox estar como "F" e quando passa para a tabela do

Acess aparece desta forma

" {\rtf1\ansi\deff0{\fonttbl{\f0\fnil\fcharset0 MS Sans Serif;}}

\viewkind4\uc1\pard\lang1046\f0\fs16 trabalha com muita aten\'e7\'e3o

\par }"

A forma da transferencia é assim

TabelaAcess.append;
TabelaAcessCampo.value:= tabelaParadoxCampo.value;
TabelaParadox.next;

Obs.: Apenas os campos no formato "F" apresentaram este problema.

Eu poderia fazer assim Paradox --> TXT --> Acess - mas tem alguns campos de Fotos, por isso não fiz assim.

alguém sabe como eu posso resolver este problema?

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Este tipo "F" é de Formated Memo e o conteúdo que você mostra, trata-se de conteúdo RTF (Rich Text Format).

Acredito que você tenha definido o campo a receber este conteúdo, no MSAccess, como sendo do tipo Memorando. Então, experimente a atribuição de outro modo:

TabelaAcessCampo.Assign(tabelaParadoxCampo);

Veja como fica.

Abraços

Share this post


Link to post
Share on other sites
  • 0
MSAccess, como sendo do tipo Memorando
isso mesmo estou usando Memorando.

TabelaAcessCampo.Assign(tabelaParadoxCampo);

Micheus eu tentei mas não mudou, ficou da mesma forma.

Share this post


Link to post
Share on other sites
  • 0
TabelaAcessCampo.Assign(tabelaParadoxCampo);

Micheus eu tentei mas não mudou, ficou da mesma forma.

Pirambu!, você está visualizando este texto em que lugar? Em um programa Delphi? No MSAcess?

Se for no MSAcess, você verificou se a visualização fica correta, caso você associar este campo a um RichTextBox no form (em um form do acess)?

Share this post


Link to post
Share on other sites
  • 0
Pirambu!, você está visualizando este texto em que lugar?
Micheus Estou usando o mesmo programa em Delphi, apenas estou mudando o banco de dados de Paradox para Access para evitar alguns erros que as tabelas do paradox apresenta quando trabalha em rede com muitos acessos.

só que tinha visualizado as informações apenas no banco de dados Access, não tinha visualizado no Delphi pois tinha que fazer as configurações dos Forms, mas quando você perguntou onde eu estava visualizando, fui verificar pelo Delphi e estar normal, as duas formas estão corretas

tabelaAccessCampo.Assign(tabelaParadoxCampo)
TabelaAccessCampo.Value:=TabelaParadoxCampo.value;

Micheus obrigado, Até a próxima.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this