Jump to content
Fórum Script Brasil
  • 0

Ordem Crescente em C....


enginner
 Share

Question

Código feito em Visualg

algoritmo "OrdemCrescente"
// Escrever um algoritmo que leia três valores inteiros distintos e os escreva em ordem crescente.
var
vet: vetor[1..3] de inteiro
c, b, aux: inteiro
inicio
Para c <- 1 ate 3 faca
Escreva("Digite um valor: ")
Leia(vet[c])
FimPara
Para c <- 1 ate 2 faca
Para b <- c+1 ate 3 faca
Se (vet[c] > vet) então
aux <- vet[c]
vet[c] <- vet
vet <- aux
FimSe
FimPara
FimPara
Para c <- 1 ate 3 faca
Escreva(vet[c])
FimPARA
fimalgoritmo
Como seria esse código em C usando vetores para que desse o mesmo resultado?
Se alguém souber e postar eu agradeço !!!
Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Forum Statistics

    • Total Topics
      149.8k
    • Total Posts
      646.6k
×
×
  • Create New...