Jump to content
Fórum Script Brasil
  • 0

Comparar as posições da linha da matriz


Question

Onde estou errando na verificação da matriz.

Procurar na linha da matriz, números iguais em suas respectivas posições e remover da matriz   

 

algoritmo "matriz"
// Função :
// Autor : joelson
// Data : 22/02/2021
// Seção de Declarações
var
vetA: vetor[1..3]de inteiro
vetBimpar: vetor[1..3]de inteiro
j,i,x,k,linha,coluna,repetido,contImpar,cont,total:inteiro
matriz: vetor[1..10,1..3]de inteiro

inicio
// Seção de Comandos

total:=0

enquanto total < 10 faca
   total:=total+1

   escreval("Digite o Vetor de um total de 10:,[",total,"]")
   para j de 1 ate 3 faca
     escreva("Vetor:[",j,"]")
     leia(vetA[j])
   fimpara
   escreval()

//achar numeros impares
  para i de 1 ate 3 faca
    se(vetA[i] mod 2 = 1)então
      vetBimpar[i]:= vetA[i]
    fimse
  fimpara

 
  PARA k DE 1 ATE CONT FACA
   repetido:=0
    PARA linha DE 1 ATE 3 FACA
      PARA coluna DE 1 ATE 3 FACA
        SE(vetBimpar[linha] = matriz[K,coluna])então
           repetido:=repetido+1
        fimse
      FIMPARA
    FIMPARA

 fimenquanto

   //escrever a matriz depois dos cinco valores digitados
   escrevaL(" exibir Matriz")
   escrevaL("__________________")
   
   PARA linha DE 1 ATE 3 FACA
      PARA coluna DE 1 ATE 3 FACA
      escreva(matriz[linha,coluna])
   FIMPARA
      escreval()
   FIMPARA

  contImpar:=0
  vetBimpar[1]:=0
  vetBimpar[2]:=0
  vetBimpar[3]:=0

escreval("Total digitados: ", total)
fimalgoritmo

Edited by Joelson Silva
Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Cloud Computing


  • Forum Statistics

    • Total Topics
      149288
    • Total Posts
      645685
×
×
  • Create New...