Jump to content
Fórum Script Brasil
  • 0

Controlar o ciclo do for


Joelson Silva

Question

pessoal tenho uma duvida de como fazer para controlar o ciclo do "for", desde já agradeço.

passo 1: o primeiro procedimento1 vai até chegar na sequencia 1 2 4 e exibe, chamar o segundo procedimento2.

passo2: o segundo procedimento2, vai até chegar na sequencia 1 4 e exibe,

passo3: chamar o primeiro  procedimento1, que parou na sequencia 1 2 4, gerar a sequencia 1 2 5, 1 3 4 exibe, chamar o passo 2 

passo2: chamar o segundo  procedimento2, que parou na sequencia 1 4, gerar a sequencia 1 5, 2 3, 2  4 exibe ate teminar as sequencias. 

algoritmo "semnome"
// Função :
// Autor :
// Data : 15/11/2022
// Seção de Declarações 
var
vetA: vetor[1..3]de inteiro
vetB: vetor[1..2]de inteiro

procedimento procediment1
var
i,j,x,p1,p2,p3:inteiro
inicio
// Seção de Comandos

para i de 1 ate 5 faca
 vetA[1]:= i
para j de i+1 ate 5 faca
 vetA[2]:= j
para x de j+1 ate 5 faca
 vetA[3]:= x
  escreval(vetA[1],vetA[2],vetA[3])
  
fimpara
fimpara
fimpara
fimprocedimento

procedimento procediment2
var
i,j:inteiro
inicio
// Seção de Comandos 
para i de 1 ate 5 faca
  vetB[1]:= i
para j de i+1 ate 5 faca
  vetB[2]:= j
  escreval(vetB[1],vetB[2])
  combinar1
fimpara
fimpara
fimprocedimento


inicio
combinar1
combinar

fimalgoritmo

 

Edited by Joelson Silva
Correção
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

O procedimento 1 está errado. Para chegar na sequencia 1, 2 e 4, o algorítimo é:

vetorA[1]:=1

vetorA[2]:=2

vetorA[3]:=4

mas você usou um laço que vai de 1 até 5 no vetorA[1], logo o valor final dele será 5 e não 1.

Você usou o laço que vai de i+1 até 5 no vetorA[2], só que i é do ciclo anterior e vale em teoria 5, logo, esse ciclo nunca será repetido, e o valor final do vetorA[2] é nulo.

No próximo ciclo você chama de x, onde x é igual a $j+1, ou seja x=6. E você pede para fazer o ciclo até x=5. Isso nunca ocorrerá, logo o valor final do vetorA[3] é nulo.

Não há como falar do procedimento2 se o procedimento1 não funciona.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      152.1k
    • Total Posts
      651.9k
×
×
  • Create New...