Jump to content
Fórum Script Brasil
  • 0
Sign in to follow this  
jdnet2

Sound

Question

Galera gente fina!!! É só mais uma pequena dúvida.

Como faço para colocar um som no botão. Por exemplo: eu clico em um botão e ao mesmo tempo já executa automaticamente um som.

Eu sei que é simples, mais faz muito tempo que eu não fico direto no flash, e eu me esqueci.

falou!!!

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
Guest - Roberto -

Clica duas vezes no botão. Abrirá a edição do botão. Crie uma layer chamada sons e insira um keyframe na Down. Agora é só arrastar o som que você quer colocar da biblioteca para o palco.

Share this post


Link to post
Share on other sites
  • 0
Galera gente fina!!! É só mais uma pequena dúvida.

Como faço para colocar um som no botão. Por exemplo: eu clico em um botão e ao mesmo tempo já executa automaticamente um som.

Eu sei que é simples, mais faz muito tempo que eu não fico direto no flash, e eu me esqueci.

falou!!!

primeiro c precisa aprender a postar no forum!!

pra que criar 20 topicos perguntandoa mesma coisa???

Share this post


Link to post
Share on other sites
  • 0

desculpe... mais eu não tenho tanta experiência assim no flash e muito menos no fórum... Por mais que eu tenha esse login faz um certo tempinho, é muito difícil eu conseguir um tempo pra mim me dedicar no flash... Por exemplo, agora eu preciso fazer esse site pra amanha no máximo (15/03/2006) e eu to me quebrando todo, por mais que o cliente queira bem simples. Na verdade eu já procurei esse tópico antes, mais dava um monte de erro na busca!

Share this post


Link to post
Share on other sites
  • 0

mais voltando a minha dificuldade....

eu tentei fazer aquilo que o Roberto me ensinou mais também não deu certo.... Talvez seja porque eu uso o flash 8. Pelo menos quando eu tinha o MX fazia da mesma forma e dava certinho. Se tiver alguma outra forma de fazer, gostaria de saber!!!!

falou!!

Share this post


Link to post
Share on other sites
  • 0

ok.. mas não faça mais isso! menino malvado! ¬¬

seu som na biblioteca..

clica com botao direito.. vai em propriedades

depois escolhe "exportar pra actionscript"

dai vai ativar a caixa do "identifier"

coloque "som" (sem aspas)

tenta assim no seu botao

on (press){
var meu_sound:Sound = new Sound();
my_sound.attachSound("Som");
my_sound.start();
}

deve dar certo c n me engano!

Share this post


Link to post
Share on other sites
  • 0

Valeu mesmo.... Deu certo... Mais depois eu colei o código nos outros botoes e nesses outros não funcionou!!! O que será que faltou!!

Share this post


Link to post
Share on other sites
  • 0

1- coloquei o codigo errado.. hehe

copiei no help e alterei uams coisas q esqueci de refazer o resto..

olha o codigo certo:

on (press){
var meu_sound:Sound = new Sound();
meu_sound.attachSound("Som");
meu_sound.start();
}

2- você fez tudo errado no arquivo da biblioteca...

eu falei campo IDENTIFIER... e você colocou o nome no AS2.0 CLASS >.<'

3- so funcionou o 1.. porque a maneira q o - Roberto - falow ali em cima ... você tinha feito no 1 botao!! e tinha FUNCIONADO!

acho q c ta precisando de masi calma hehehe

ler tudo certinhu e tal! ^^

boa sorte ae!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  



  • Forum Statistics

    • Total Topics
      148128
    • Total Posts
      643430
×
×
  • Create New...