Jump to content
Fórum Script Brasil

MPR

Membros
  • Content Count

    18
  • Joined

  • Last visited

Community Reputation

0 Neutro

About MPR

Contatos

  • Website URL
    http://www.mprinformatica.com.br

Perfil

  • Location
    São Paulo - Saúde - SP
  1. Olá, Esse problema é só uma questão de organizar os dados, há várias soluções. Por exemplo, na planilha Plan1 podemos ter: A B C D E 1 Teste 2 C GGG 3 C GGG 4 A AAA 5 B DDD 6 X 7 Y 8 Z Na planilha Plan2 A B 1 Outra Coluna 2 A AAA 3 B DDD 4 C GGG 5 D CCC 6 E RRR 7 F TTT 8 G OOO A fórmula na célula B2 da planilha Plan1 é: =PROCV(A2; plan2!$A$2:$B$8; 2; Falso) que deve ser copiada para as células que estão abaixo dela (B3, B4 ...) Boa sorte, Carlos César Tanaka MPR Informática Cu
  2. Olá Cinovaldo, Essa fórmula está incorreta. Se você observar, o primeiro abre parênteses casa com o fecha parênteses que está imediatamente antes do segundo SE. Portanto do segundo SE em diante nada está valendo, em outras palavras, metade da fórmula não serve para nada. Sobre o caractere estranho, muito provavelmente, a segunda metade da fórmula realiza uma procura (procv) em um arquivo e localiza uma célula com esse contéudo, que coincidentemente o Excel ignora e não dá erro no resultado da fórmula toda. Use somente a primeira metade da fórmula (até o fecha parênteses que está antes do seg
  3. Olá Catarina, Inicialmente, esse seu código é de VBA para Excel e não Visual Basic. Vamos à resposta: A matriz que você declarou só tem 4 elementos, então a primeira correção está no loop que tem que ir de 0 até 3 (4 elementos) e não de 0 até 4 (5 elementos). O seu código está funcionando, porém quando você acha a resposta deve sair do loop (exit for). Caso contrário o loop continuará e testará os outros valores, mudando a resposta. Veja como mudou pouco: times = Array("cxl", "ixt", "ixt", "txi") teste1 = "c" teste2 = "l" juntar = teste1 & "x" & teste2 For p = 0 To 3 If juntar
  4. Na célual B1 a fórmula é: =NÚMSEMANA(A1;1) Se a semana começa no domingo o segundo parâmentro é 1, se começa na segunda, o segundo parâmetro é 2. Carlos César Tanaka Curso de Excel MPR Informática
  5. Olá, Tudo estará em português estruturado. Deve ser adaptado dependendo da linguagem de programação. Pode-se resolver o problema da equação 3x + 2y + 7z = 5 através da "força bruta", com 3 loops: Para x variando de 0 a 100 Para y variando de 0 a 100 Para z variando de 0 a 100 se (3*x + 2*y + 7*z) = 5 então mostra uma solução da equação: x, y, z Incrementa z em uma unidade (x = x +1) Laço da variável z Incrementa y em uma unidade (y = y +1) Laço da variável y Incrementa x em uma unidade (x = x +1) Laço da variável z Para o outro problema:
  6. MPR

    Dúvida em Fórmula

    Entendi que a solução procurada é diferente, ou seja, o conteúdo da célula A1 pode estar em qualquer célula do intervalo C1:C4. Nesse caso a solução será: =SE(OU(C1=A1; C2=A1; C3=A1; C4=A1); 3; 0) Carlos César Tanaka Curso de Excel
  7. Nos exemplos que você listou, os métodos são "inclui", que adiciona uma elemento em uma lista, e "estaCheia", que verifica se a lista está cheia. O primeiro método executa uma ação (a de incluir um elemento na lista) e não retorna nenhum valor (void). O segundo método retorna um valor do tipo boolean (falso ou verdadeiro), é que se cham a de função. Carlos César Tanaka MPR Informática
  8. Olá! Quando utilizo essa ferramenta, para corrigir pequenos defeitos na seleção, eu utilizo o recurso Quick Mask, botão que está na barra de ferramentas do Photoshop, bem embaixo dos quadrados que mostram as cores de Foreground e Background. Ativado esse botão, selecione a ferramenta Brush Tool, onde, você poderá efetuar a correção do excesso de seleção e até poderá adicionar áreas. Observe que os quadrados que mostram as cores Foregrond e Background mostram as cores Preto e Branco. Quando estiver na cor preta e você utilizar a ferramenta pincel em sua imagem, você estará Adicionando a áre
  9. Salve-a com outro nome e depois salve-a novamente com o nome original. Carlos César Tanaka Cursos de Excel/VBA MPR Informática
  10. Prezado colega, Estou considerando que os dados estão a partir da célula A1. A B 1 Frota Km 2 100 100000 3 100 100250 4 100 100500 5 200 950 6 200 1052 7 200 2562 Selecione da célula B2 até o final, por exemplo, B65536 Vá até ao Menu > Dados > Validação > Configurações > "Critério de validação" > Permitir -> Personalizado e coloque a Função =OU((B2>B1); (A2<>A1)). E coloque um alerta de erro od jeito que você precisar. Carlos César Tanaka Cursos de Excel/VBA
  11. OK Michelle, Se funcionou está bom. A resposta que está aqui foi copiada do outro fórum que eu respondi. :rolleyes:
  12. Michelle, Eu respondi algo bem parecido para outra pessoa em outro fórum. Vou repetir aqui: Estou considerando que os dados que você postou começam a partir da célula A2 e não há linhas em branco no intervalo de dados. Se for diferente altere os endereços. A B C 2 10/03/09 DINHEIRO R$ 45,00 3 11/03/09 CHEQUE R$ 69,00 4 15/03/09 CHEQUE R$ 35,00 O código que vai no formulário é o seguinte: Dim criterios As Range Dim intsoma As Range Sheets("Relsan").select 'Intervalo com o tipo de pagamento Range("B2").Select Set cri
  13. Olá! Encontrei um post, talvez seja o que você precise: http://forum.wmonline.com.br/index.php?sho...mp;#entry945320 Espero que ajude! Márcia Cadecaua MPR Informática
  14. O que você quer pode ser feito da seguinte forma: Crie um módulo em VBA e digite (ou cole) o código abaixo: Sub DestacaDados() ' A partir da última linha da coluna A, seleciona a última linha que contém dados ' No Excel 2003 ou anteriror, usar o endereço A65536 Range("A1048576").End(xlUp).Select ' Faz o loop até a primeira linha ' Se houver um cabeçalho, troque o número 1 pelo valor da primeira linha de dados Do While ActiveCell.Row > 1 If ActiveCell.Value <> "" And ActiveCell.Offset(-1, 0).Value = "" Then Call Linha End If ActiveCell.Offset(-1, 0).Select Loop End Su
  15. Olá! Coloquei a resposta da sua dúvida passo-a-passo no link abaixo: http://blog.mprinformatica.com.br/2009/04/...ulario-no-word/ Espero que ajude. Márcia Cadecaua MPR Informática
×
×
  • Create New...