Jump to content
Fórum Script Brasil

Search the Community

Showing results for tags 'sos'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Programação & Desenvolvimento
    • ASP
    • PHP
    • .NET
    • Java
    • C, C++
    • Delphi, Kylix
    • Lógica de Programação
    • Mobile
    • Visual Basic
    • Outras Linguagens de Programação
  • WEB
    • HTML, XHTML, CSS
    • Ajax, JavaScript, XML, DOM
    • Editores
  • Arte & Design
    • Corel Draw
    • Fireworks
    • Flash & ActionScript
    • Photoshop
    • Outros Programas de Arte e Design
  • Sistemas Operacionais
    • Microsoft Windows
    • GNU/Linux
    • Outros Sistemas Operacionais
  • Softwares, Hardwares e Redes
    • Microsoft Office
    • Softwares Livres
    • Outros Softwares
    • Hardware
    • Redes
  • Banco de Dados
    • Access
    • MySQL
    • PostgreSQL
    • SQL Server
    • Demais Bancos
  • Segurança e Malwares
    • Segurança
    • Remoção De Malwares
  • Empregos
    • Vagas Efetivas
    • Vagas para Estágios
    • Oportunidades para Freelances
  • Negócios & Oportunidades
    • Classificados & Serviços
    • Eventos
  • Geral
    • Avaliações de Trabalhos
    • Links
    • Outros Assuntos
    • Entretenimento
  • Script Brasil
    • Novidades e Anúncios Script Brasil
    • Mercado Livre / Mercado Sócios
    • Sugestões e Críticas
    • Apresentações

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 4 results

  1. Boa tarde pessoal, desenvolvi esse algoritmo para verificar se uma matriz é inca ou não, ou seja se partindo do extremo superior esquerdo e seguindo em espiral o número seguinte é o sucessor inteiro do número anterior, meu algoritmo está dando que a matriz é errada quando eu não começo com o primeiro termo da matriz [1,1] sendo 1, gostaria de pedir um minuto da atenção e experiência de todos vocês sou grato desde já. algoritmo "Matriz Inca" var i,j,n,inicol,fimcol,inilin,fimlin,degrau:inteiro matriz:vetor[1..20,1..20] de inteiro eh_inca:logico inicio repita escreva("Escolha a dimensão da Matriz:") leia (n) se((n < 1)ou(n > 20))então escreval("A dimensão da matriz precisa estar entre 1 e 20") fimse ate ((n > 0 ) e (n < 21)) escreval("Matriz: ",n ," x ",n) escreval("Digite os numeros da Matriz abaixo:") para i de 1 ate n faca para j de 1 ate n faca escreval("Entre com o valor de matriz[",i,",",j,"]:") leia (matriz[i,j]) fimpara fimpara para i de 1 ate n faca escreval para j de 1 ate n faca escreva (matriz[i,j]) fimpara escreval fimpara inicol <-1 fimcol <-n inilin <-1 fimlin <-n degrau <-0 eh_inca <- verdadeiro enquanto ((eh_inca) e (inicol<fimcol) e (inilin<fimlin)) faca para i de inicol ate fimcol faca se (matriz[inilin,i] = degrau + 1) então degrau <- degrau + 1 senao eh_inca <- falso fimse fimpara inilin <- inilin + 1 para i de inilin ate fimlin faca se (matriz[i,fimcol] = degrau + 1) então degrau <- degrau + 1 senao eh_inca <- falso fimse fimpara fimcol <- fimcol - 1 para i de fimcol ate inicol passo -1 faca se (matriz[fimlin,i] = degrau + 1) então degrau <- degrau + 1 senao eh_inca <- falso fimse fimpara fimlin <- fimlin - 1 para i de fimlin ate inilin passo -1 faca se (matriz[i,inicol] = degrau + 1) então degrau <- degrau + 1 senao eh_inca<-falso fimse fimpara inicol<-inicol + 1 fimenquanto se (eh_inca) então escreval ("Matriz é inca") senao escreval ("Matriz não é inca") fimse
  2. Então pessoal meu segundo tópico neste fórum. Estou fazendo um algoritmo para receber dois números inteiros e retornar na saída para o usuário o quociente da divisão e o resto, aha isso é muito fácil, porém não posso usar qualquer outra operação além de + e - kk, então fiz o código e tudo certinho só que nas linhas finais está dando erro e não estou sabendo arrumar, por favor conto com a experiência de todos vocês e sou grato desde já. #include <stdio.h> #include <stdlib.h> int main(){ int n1,n2,q,r,i,z,k,w; printf("Entre com 2 numeros inteiros.\n\n"); printf("N1-->"); scanf("%d",&n1); printf("N2-->"); scanf("%d",&n2); if(n1<n2){ q=0; } if(n1>n2){ i=0; z=0; while(i<n1){ while(z<n2){ z++; } i=i+z; q=q+1; } } if(i>n1){ q=q-1; } printf("%d \n",q); k=0; w=0; while(k<q){ w=w+n2; k++; } r==(n1-w); printf("%d",r); return 0;
  3. Boa noite pessoal, sou iniciante em C, e estou tendo um erro no meu programa que é uma espécie de calculadora, o erro está ocorrendo somente na divisão, eu serei eternamente grato se alguém puder dedicar um pouco do tempo para analisar esse problema, as 3 operações estão funcionando ok. Desde já agradeço a todos. #include <stdio.h> int main (void){ int n1,n2,k; float res; printf (" |-------------|Operaçoes Matematicas|---------------|\n\n"); printf ("Entre com o primeiro operando:"); scanf("%d",&n1); printf("Entre com o segundo operando:"); scanf("%d",&n2); printf("Escolha:\n\n"); printf("1-Soma\n2-Subtraçao\n3-Multiplicaçao\n4-Divisao\n\n"); printf("Digite aqui:"); scanf("%d",&k); if(k==1){ (res=(n1+n2)); printf("%f",res); } else if(k==2){ (res=(n1-n2)); printf("%f",res); } else if(k==3){ (res=(n1*n2)); printf("%f",res); } else if((k=4) && (n2!=0)){ (res=(n1/n2)); printf("%f",res); } else if((k==4) && (n2==0)){ printf("não e possivel dividir por zero."); } return 0;}
  4. Olá amigos, sou da ETEC Getúlio Vargas, faço técnico em eletrônica, e estou fazendo meu tcc. Estamos com problema para fazer uma temporização para uma lâmpada que iremos utilizar, esse timer precisa dar ao usuário a capacidade de escolher quantas horas a lâmpada fica ligada, e quantas a mesma fica desligada ex.(16h ligada e 8h desligada), temos que fazer isso utilizando qualquer PIC , pois não podemos utilizar arduino, e nem sistemas prontos , como temporizador analógico que possa ser comprado. Abaixo, irei colocar um link de um vídeo no qual ele faz um programa que é exatamente o que precisamos, porém o autor do vídeo não disponibilizou para ninguém o código fonte do PIC , e eu precisava muito disso, urgente.. Se alguém, por obséquio, puder ajudar-me, iria agradecer muuito.. Obrigado Pela atenção, abaixo o vídeo:
×
×
  • Create New...