Search the Community

Showing results for tags 'algoritmo'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Programação & Desenvolvimento
    • ASP
    • PHP
    • .NET
    • Java
    • C, C++
    • Delphi, Kylix
    • Lógica de Programação
    • Mobile
    • Visual Basic
    • Outras Linguagens de Programação
  • WEB
    • HTML, XHTML, CSS
    • Ajax, JavaScript, XML, DOM
    • Editores
  • Arte & Design
    • Corel Draw
    • Fireworks
    • Flash & ActionScript
    • Photoshop
    • Outros Programas de Arte e Design
  • Sistemas Operacionais
    • Microsoft Windows
    • GNU/Linux
    • Outros Sistemas Operacionais
  • Softwares, Hardwares e Redes
    • Microsoft Office
    • Softwares Livres
    • Outros Softwares
    • Hardware
    • Redes
  • Banco de Dados
    • Access
    • MySQL
    • PostgreSQL
    • SQL Server
    • Demais Bancos
  • Segurança e Malwares
    • Segurança
    • Remoção De Malwares
  • Empregos
    • Vagas Efetivas
    • Vagas para Estágios
    • Oportunidades para Freelances
  • Negócios & Oportunidades
    • Classificados & Serviços
    • Eventos
  • Geral
    • Avaliações de Trabalhos
    • Links
    • Outros Assuntos
    • Entretenimento
  • Script Brasil
    • Novidades e Anúncios Script Brasil
    • Mercado Livre / Mercado Sócios
    • Sugestões e Críticas
    • Apresentações

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 45 results

  1. elabore um programa que leia dois numeros decimais inteiros de no maximo 32 bits e determine, bit a bit, quais bits são iguais nos dois numeros, e dos que forem igual se são '' 0 '' ou '' 1''. Por exemplo, os numeros 0 e 255 contem 24 bits iguais (bit8...bit31), em zero, e 8 bits diferente ( bit0...bit7). nesse caso a impressao seria: bits iguais: || valor 7 0 8  0 9 0 . . . 31 0
  2. Me ajudem eu fiz esse algoritmo mas n sei se está correto . Escreva um algoritmo em linguagem C com as seguintes instruções: 1. Declare três variáveis (inteiro, real e char); 2. Declare três ponteiros; 3. Associe as variáveis aos ponteiros; 4. Modifique os valores de cada variável indiretamente usando os ponteiros associados. Para armazenar os valores nas variáveis, armazene na variável char a primeira letra do seu nome, na variável inteira os dois últimos dígitos do seu RU e na variável real os 4 últimos dígitos do seu RU, sendo os 2 últimos os valores com virgula; 5. Imprima na tela os valores das variáveis antes e após a modificação. #include <stdio.h> int main(void){ int x; x= 04; float y; y = 49.04; char z; z = 'm'; int *ponteiro1; ponteiro1 = &x; float *ponteiro2; ponteiro2 = &y; char *ponteiro3; ponteiro3 = &z; printf("\nValor antes: %i\n", *ponteiro1); printf("Valor depois: %i\n\n", &x); printf("Valor antes: %f\n", *ponteiro2); printf("Valor depois: %f\n\n", ponteiro2); printf("Valor antes: %c\n", *ponteiro3); printf("Valor depois: %c", *ponteiro3); }
  3. Preciso de uma ajuda com esse exercício.. Não sei como faze-lo. Se alguém puder me ajudar, e explicar, ficaria muito agradecido!
  4. Fiz um programa com o seguinte comando: "Ler nome, sexo e idade. Se sexo for feminino e idade menor que 25, imprime o nome dapessoa e a palavra “ACEITA”, caso contrario imprimir “NÃO ACEITA”.". Fiz o programa porém quando digito sexo 'feminino' e idade abaixo de 25 ele retorna "Não aceito" ao invés de "Aceito". O que pode tá errado no meu código?Código:#include <stdio.h>#include <stdlib.h>#include <locale.h>#include <string.h>int main(){setlocale(LC_ALL, "Portuguese_Brazil");char nome[200];int idade;char sexo[50];setbuf(stdin, NULL);printf("Digite seu nome: ");gets(nome);printf("Digite seu sexo: ");gets(sexo);printf("Digite sua idade: ");scanf("%d",&idade);if(sexo=="feminino" && idade<25){printf("\\n%s\\n",nome);printf("Situação: Aceita.\\n");}else{printf("\\n%s\\n",nome);printf("Situação: Não aceita.\\n");}return 0;}OBS: Não quero apenas outra forma de escrever o programa(mas se quiser pode colocar), quero saber porque esse código está dando errado!
  5. Uma questão simples, mas que estou tendo dificuldades: inserir o tempo de corrida de 5 participantes e imprimir os 3 primeiros lugares [Portugol; favor, preferencialmente utilizar condicionais]
  6. 1 - Deixe sua reposta para que outras pessoas posam ver 2 - Pode-se responder em qualquer linguagem, mas se puder deixar só o algoritmo escrito (Portugol) por exemplo, seria ótimo. Vamos ao desafio: Criar um algoritmo que multiplique dois números inteiros positivos maiores que zero SEM usar o operador de multiplicação (*) Boa sorte!
  7. /* * ----------Valid PassWord---------- * PassWord must contain: * At least SIX characters * At least ONE character Caps lock * At least ONE character lowerCase * At least ONE number * And Can not contain SPACE */ let password = "Doctor_Who_98" var contain_space = 0 var contain_latters_lowerCase = 0 var contain_latters_capsLock = 0 var contain_number = 0 var number_character = 0 // up all the counters zeroed let latters_lowerCase = "abcdefghijklmnopqrstyvxzy" let latters_capsLock = "ABCDEFGHIJKLMNOPQRSTUVXZY" let numbers = "0123456789" for check_password in password { //will scroll through all the characters of the password number_character += 1 //Count the amount of character if check_password == " " { contain_space += 1 //check if there is any space } for check_latters_lowerCase in latters_lowerCase { if check_password == check_latters_lowerCase { contain_latters_lowerCase += 1 //Count the lowercase letters } } for check_latters_capsLock in latters_capsLock { if check_password == check_latters_capsLock { contain_latters_capsLock += 1 //Count the capslock letters } } for check_numbers in numbers { if check_password == check_numbers { contain_number += 1 //Count the number of numbers } } } if contain_space == 0 && contain_number > 0 && contain_latters_lowerCase > 0 && contain_latters_capsLock > 0 && number_character >= 6{ print("Password OK") } else { print("Invalid Password") } // Twitter: @thiagoandreqi // Instagram: alfacexburger
  8. Olá, como eu poderia fazer o seguinte: Tenho um Array conforme abaixo que pode variar de tamanho (mas sempre terá um tamanho par) e tenho um intervalo de duas datas. Preciso juntar estas informações para criar uma lista conforme abaixo(o retorno pode ser um System.out....): Resultado final que eu preciso: "01/01/2017 08:00" "01/01/2017 17:00" "02/01/2017 09:00" "02/01/2017 18:00" "03/01/2017 08:00" "03/01/2017 17:00" "04/01/2017 09:00" "04/01/2017 18:00" Valores que tenho: public void gerarEscala(){ String [] horarios = new String [4]; horarios[0] = "08:00"; horarios[1] = "17:00"; horarios[2] = "09:00"; horarios[3] = "18:00"; Date inicio; // 01/01/2017 Date fim;//04/01/2017 Date ref = inicio; while( ref < fim){ //gera datas dentro de um intervalo definido, e preciso unir essas datas com os horários do array ref = inicio + 1; //preciso que aqui forme uma String que fique por exemplo "01/01/2017 08:00" //depois 01/01/2017 17:00" //depois 02/01/2017 09:00" //depois 02/01/2017 18:00" // e assim por diante até finalizar o intervalo de datas, sempre utilizando o array de horários como referencia para inicio e fim(seria inicio e fim do trabalho, por exemplo ) ...não sei como seguir aqui... } }
  9. Faça um procedimento recursivo determinístico para imprimir, dados dois inteiros positivos n, k todas as combinaçoes possíveis de k elementos contidas no conjunto dos inteiros no intervalo [1,n]. o procedimento deve imprimir uma combinação por linha, sem repetir combinações. sabe-se que dentro de uma combinação n ordem dos elementos não é importante e não é permitida a repetição dos elementos. problema de localização: Entrada: dois inteiros positivos, n e k, comm n>0 saída: a listagem das combinações, conforme o enunciado
  10. Um versão "pi "do problema da mochila é definida da seguinte forma: dada uma mochila M com capacidade W e n objetos a.i distintos, como i pertence a [1,n] existe uma carga com valor maior ou iguala k que a mochila é capaz de carregar?cada objeto a.i tem peso p1 e valor v1 a) apresenta um algoritmo NP que exibe um certificado para o problema pi b)apresente um algoritmo P que reconhece um certificado para o problema pi
  11. Ainda tratando do problema SAT, considere o seguinte: (a) é sabido que 3-SAT está na classe NP-Completo; (b) é fácil provar que k-SAT alfa x-SAT se x=k-1 (c) é facil prvar que 2-SAT está na classe P. Explique porque esses argumentos não são admitidos como prova para P=NP
  12. bebetoss

    SAT

    Seja SAT o problema da satisfabilidade em sua versaode decisao. Esse problema consiste em determinar, dada uma expressao lógica E na forma normal conjuntiva, se existe uma distribuição de valores booleanos para as variáveis que tornem a expressão E válida.Quando o número de variáveis nos blocos(clausulas com "ou) é constante e vale K temos casos particulares do problema SAT que são chamados de K-SAT a) mostre que 2-SAT alfa 3-sat b) mostre 4-sat alfa 3-sat
  13. "Os dados de uma turma de N alunos (nomes, sexos e notas em três disciplinas regulares) serão armazenados em vários vetores, sendo que para uma mesma posição i, acessando os diferentes vetores teremos os dados do aluno i. Construir um algoritmo que (cada opção dentro de um método): 1.Efetue a leitura destes dados. 2.Calcule e visualize a média das notas da turma (considerando as três disciplinas e todos os alunos). 3.Calcule e visualize a média das notas de cada aluno. 4.Visualize o nome, sexo e média das notas do aluno com a maior média. 5.Calcule e visualize a média das notas das mulheres da turma na segunda disciplina. 6.Visualize os nomes dos alunos reprovados na primeira disciplina (com nota menor que 6,0 pontos). 7.Visualize os alunos que ficaram abaixo da média da turma (na terceira disciplina). " Estou na duvida, como posso desenvolver esse código? Sou novata em python e nunca vi misturar vetor com metodo e.e Me ajudem, por favor. ALGORITMO DADO PELO ENUNCIADO (como tranformá-lo em python?): Algoritmo TurmaNotas real disc1[200], disc2[200], disc3[200]caractere nome[200] ,sexo[200]inteiro n início leituraDeDados() calcularMediaGeral() mediaDeCadaAluno() alunoComMaiorMedia() mediaDasMulheresNaSegundaDisciplina() ... fim void leituraDeDados() inteiro i início inteiro i escreva ("Digite a quantidade de alunos da turma: ") leia (n) para(i=0; i<n; i++) escreva ("Digite o nome do aluno " + (i+1) + ": " ) leia (nome[i]) escreva ("Digite o sexo deste aluno (m ou f): ") leia (sexo[i]) escreva ("Digite a nota na 1ª disciplina: ") leia (disc1[i]) escreva ("Digite a nota na 2ª disciplina: ") leia (disc2[i]) escreva ("Digite a nota na 3ª disciplina: ") leia (disc3[i]) fim_para fim void calcularMediaGeral() inteiro i real soma, media início soma = 0 para(i=0; i<n; i++) soma += disc1[i] + disc2[i] + disc3[i] fim_para media = soma / (3 * n) escreva ("A média geral das notas da turma é " + media) fim void mediaDeCadaAluno() inteiro i real media início para(i=0; i<n; i++) media = (disc1[i] + disc2[i] + disc3[i]) / 3 escreva ("O aluno " + nome[i] + " tem média: " + media) fim_para fim void alunoComMaiorMedia() inteiro i, pos real media, maior início maior = (disc1[0] + disc2[0] + disc3[0]) / 3 pos = 0 para(i=1; i<n; i++) media = (disc1[i] + disc2[i] + disc3[i]) / 3 se (media > maior) então maior = media pos = i fim_se fim_para escreva ("O aluno com maior média é " + nome[pos] + ", sexo: " + sexo[pos] + ", com média " + maior) fim void mediaDasMulheresNaSegundaDisciplina() inteiro i, quantMulh real soma, media início soma = 0 quantMulh = 0 para(i=0; i<n; i++) se (sexo[i] == "F" ou sexo[i] == "f") então soma += disc2[i] // nota na 2ª disc. quantMulh++ fim_se fim_para se (quantMulh >0) então media = soma / quantMulh escreva ("A média das notas das mulheres na 2ª disciplina é " + media) senão escreva ("Esta turma não tem mulheres!" ) fim_se fim
  14. mkz301

    Dúvida!!!

    Galera estou com uma dúvida! Gostaria de saber porque não posso chamar o método scanf() como parâmetro da chamada de uma função. Ex: funcao(scanf("%d",&n)); Ao fazer isso ele sempre passa o valor 1 como parâmetro. Alguém poderia me explicar? Desde já agradeço!
  15. Olá pessoal, O algoritmo abaixo deve informar a soma das matrizes A e B porém não está funcionando. Já alterei variáveis, renomeei, mas não consegui resolver porque a matriz C imprime zerada. programa { funcao inicio() { const inteiro LIN = 3, COL = 4 //declara duas constantes inteiro A[LIN][COL] //cria a matriz A inteiro B[LIN][COL] //cria a matriz B inteiro C[LIN][COL] //cria a matriz C escreva ("Digite os elementos da Matriz A: \n") Leitura_Matriz (A, LIN, COL) escreva ("Digite os elementos da Matriz B: \n") Leitura_Matriz (B, LIN, COL) Soma_Matriz (A, B, C, LIN, COL) escreva ("Os elementos da Matriz C são: \n") Imprime_Matriz (C, LIN, COL) } funcao Leitura_Matriz (inteiro &Mat[][], inteiro qlin, inteiro qcol) { inteiro l, c para (l = 0; l < qlin; l++) { para (c = 0; c < qcol; c++) { escreva ("Digite o elemento ", l, ",", c, ": ") leia (Mat[l][c]) } } } funcao Soma_Matriz (inteiro M1[][], inteiro M2[][], inteiro M3[][], inteiro qlin, inteiro qcol) { inteiro l, c para (l = 0; l < qlin; l++) { para (c = 0; c < qcol; c++) { M3[l][c] = M1[l][c] + M2[l][c] } } } funcao Imprime_Matriz (inteiro Mat[][], inteiro qlin, inteiro qcol) { inteiro l, c para (l = 0; l < qlin; l++) { para (c = 0; c < qcol; c++) { escreva (Mat[l][c], "; ") } escreva ("\n") } } }
  16. Boa tarde pessoal, desenvolvi esse algoritmo para verificar se uma matriz é inca ou não, ou seja se partindo do extremo superior esquerdo e seguindo em espiral o número seguinte é o sucessor inteiro do número anterior, meu algoritmo está dando que a matriz é errada quando eu não começo com o primeiro termo da matriz [1,1] sendo 1, gostaria de pedir um minuto da atenção e experiência de todos vocês sou grato desde já. algoritmo "Matriz Inca" var i,j,n,inicol,fimcol,inilin,fimlin,degrau:inteiro matriz:vetor[1..20,1..20] de inteiro eh_inca:logico inicio repita escreva("Escolha a dimensão da Matriz:") leia (n) se((n < 1)ou(n > 20))então escreval("A dimensão da matriz precisa estar entre 1 e 20") fimse ate ((n > 0 ) e (n < 21)) escreval("Matriz: ",n ," x ",n) escreval("Digite os numeros da Matriz abaixo:") para i de 1 ate n faca para j de 1 ate n faca escreval("Entre com o valor de matriz[",i,",",j,"]:") leia (matriz[i,j]) fimpara fimpara para i de 1 ate n faca escreval para j de 1 ate n faca escreva (matriz[i,j]) fimpara escreval fimpara inicol <-1 fimcol <-n inilin <-1 fimlin <-n degrau <-0 eh_inca <- verdadeiro enquanto ((eh_inca) e (inicol<fimcol) e (inilin<fimlin)) faca para i de inicol ate fimcol faca se (matriz[inilin,i] = degrau + 1) então degrau <- degrau + 1 senao eh_inca <- falso fimse fimpara inilin <- inilin + 1 para i de inilin ate fimlin faca se (matriz[i,fimcol] = degrau + 1) então degrau <- degrau + 1 senao eh_inca <- falso fimse fimpara fimcol <- fimcol - 1 para i de fimcol ate inicol passo -1 faca se (matriz[fimlin,i] = degrau + 1) então degrau <- degrau + 1 senao eh_inca <- falso fimse fimpara fimlin <- fimlin - 1 para i de fimlin ate inilin passo -1 faca se (matriz[i,inicol] = degrau + 1) então degrau <- degrau + 1 senao eh_inca<-falso fimse fimpara inicol<-inicol + 1 fimenquanto se (eh_inca) então escreval ("Matriz é inca") senao escreval ("Matriz não é inca") fimse
  17. Olá pessoal, estou fazendo uma lista de exercícios de programação em C, e estou tendo dificuldades em uma das últimas questões: Faça um algoritmo para com base no nome, sexo ("M"=Masculino e "F"=Feminino), três notas e o número de faltas dos alunos de uma turma, onde o Flag será um nome igual a "fim", escrever: a. A situação final de cada aluno; b. A média das notas dos homens e a média das notas das mulheres; c. O percentual de homens e o percentual de mulheres reprovados por média; d. O percentual de homens e o percentual de mulheres reprovados por falta; e. O percentual geral de reprovação da turma. Obs.: As situações possíveis são: Aprovado, Reprovado por Falta ou Reprovado por Média. A média mínima para obter aprovação é 7,00 e o limite de faltas é 15. A reprovação por falta sobrepõe a reprovação por Média. Fiz o seguinte algoritmo: #include <stdio.h> #include <stdlib.h> int main(void){ char nome[100]; char sexo; double nota1; double nota2; double nota3; double media; double mediaM = 0; double mediaM2 = 0; double mediaF2 = 0; double mediaF = 0; double porcM = 0; double porcF = 0; double porcR = 0; int faltas; int contM = 0; int contF = 0; int contPorcM = 0; int contPorcF = 0; scanf("%s",nome); while (nome!=("fim")) { printf("Digite o Sexo: "); scanf("%c",&sexo); printf("1ª Nota:"); scanf("%lf",&nota1); printf("2ª Nota:"); scanf("%lf",&nota2); printf("3ª Nota:"); scanf("%lf",nota3); media = (nota1 + nota2 + nota3)/3; printf("Quantidade de faltas: "); scanf("%d",faltas); if ((media>=7) && (faltas<=15)){ printf("Nome:%s,Sexo:%c,Media:%ln,Faltas:%d Aprovado(a)",nome,sexo,media,faltas); }else{ printf("Nome:%s,Sexo:%c,Media:%ln,Faltas:%d Reprovado(a)",nome,sexo,media,faltas); } if (sexo=='M'|| sexo=='m'){ contM = contM +1; mediaM = (mediaM + media); } if (sexo =='F'|| sexo=='f'){ contF = contF +1; mediaF = (mediaF + media); } if ( (sexo == 'M' || sexo == 'm') && (media<7 || faltas>15)){ contPorcM = contPorcM + 1; porcM = (contPorcM*100)/contM; } if ((sexo == 'F' || sexo == 'f') && (media<7 || faltas>15)){ contPorcF = contPorcF + 1; porcF = (contPorcF*100)/contF; } if ((media<7) || (faltas>15)){ porcR = ((contPorcM + contPorcF)*100)/(contM + contF); } mediaM2 = (mediaM/contM); mediaF2 = (mediaF/contF); printf("Digite o nome: "); scanf("%s",nome); } printf("Média das notas dos homens:%ln\n ",mediaM2); printf("Média das notas das mulheres:%ln\n ",mediaF2); printf("Percentual de Homens Reprovados:%ln\n ",porcM); printf("Percentual de Mulheres Reprovados:%ln\n ",porcF); printf("Percentual Geral de Reprovação da Turma:%ln\n ",porcR); return 0; } Uso o gcc para compilar e está dando diversos erros, agradeço se alguém mais experiente puder analisar e apontar os erros. Obrigado a todos.
  18. Olá pessoal, mais uma das questões difíceis para iniciante, estou tendo dificuldades para encontrar os erros no algoritmo que desenvolvi, conto com a colaboração de todos, e serei grato a toda dica construtiva de vocês que são mais experientes. #include <stdio.h> #include <stdlib.h> int main(){ int logico,i,j,n,inicol,fimcol,inilin,fimlin,degrau; int matriz[20][20]; do{ printf("Escreva a dimensao da matriz:"); scanf("%d",&n); if((n<1)||(n>20)){ printf("A dimensao da matriz precisa estar entre 1 e 20\n"); } }while((n<1) || (n>20)); printf("A matriz informada e do tipo %dX%d\n",n,n); printf("Digite os numeros da matriz abaixo:\n"); for(i=1;i<=n;i++){ for(j=1;j<=n;j++){ printf("Entre com o valor de matriz["); printf("%d,",i); printf("%d]:",j); scanf("%d",&matriz[i][j]); } } for(i=1;i<=n;i++){ printf("\n"); for(j=1;j<=n;j++){ printf("%2d",matriz[i][j]); printf(" "); } printf("\n"); } inicol=1; fimcol=n; inilin=1; fimlin=n; degrau=0; logico=1; while((logico=1)&&(inicol<fimcol) && (inilin<fimlin)){ for(i=inicol;i=fimcol;i++){ if(matriz[inilin][i]=(degrau+1)){ degrau=(degrau+1); } else{ logico=0; } } fimcol=(fimcol-1); for(i=fimcol;i=inicol;i--){ if(matriz[fimlin][i]=(degrau+1)){ degrau=(degrau+1); } else{ logico=0; } } fimlin=(fimlin-1); for(i=fimlin;i=inilin;i--){ if(matriz[i][inicol]=(degrau+1)){ degrau=(degrau+1); } else{ logico=0; } inicol=(inicol+1); } if(logico=1){ printf("A matriz e inca"); } else{ printf("A matriz não e inca"); } return 0; } Até essa parte abaixo o algoritmo está executando ok. #include <stdio.h> #include <stdlib.h> int main(){ int logico,i,j,n,inicol,fimcol,inilin,fimlin,degrau; int matriz[20][20]; do{ printf("Escreva a dimensao da matriz:"); scanf("%d",&n); if((n<1)||(n>20)){ printf("A dimensao da matriz precisa estar entre 1 e 20\n"); } }while((n<1) || (n>20)); printf("A matriz informada e do tipo %dX%d\n",n,n); printf("Digite os numeros da matriz abaixo:\n"); for(i=1;i<=n;i++){ for(j=1;j<=n;j++){ printf("Entre com o valor de matriz["); printf("%d,",i); printf("%d]:",j); scanf("%d",&matriz[i][j]); } } for(i=1;i<=n;i++){ printf("\n"); for(j=1;j<=n;j++){ printf("%2d",matriz[i][j]); printf(" "); } printf("\n"); }
  19. estou usando o seguinte algoritmo : #include <stdio.h> #include <stdlib.h> int main() { int num, g=0, fase, horario[2], codigo; //g = gerador de códigos de cada turma char curso[30]; scanf("%i", &num); switch(num){ case 1: codigo=g; fgets(curso,30,stdin);// <<FGETS AQUI>> scanf("%i", &fase); printf("escreva o horario de tal maneira: 13 30, onde 13 são as horas e 30 os minutos."); scanf("%i", &horario[0]); //horas scanf("%i", &horario[1]); //minutos printf("%i %i %i:%i", codigo, fase, horario[0], horario[1]); //fazer scanf do char com um looping g++;// deve ser a ultima linha do case1 EXCLUIR ISSO DEPOIS } return 0; } o programa só funciona quando tiro o fgets, ao coloca-lo ele muda completamente o printf pra lixo, não consigo entender o porque
  20. Estou com dificuldade na logica de um exercício com vetor no visualg, o exercício é o seguinte: Faça um algoritmo que leia um vetor K[30]. Troque a seguir, todos os elementos de ordem ímpar do vetor com os elementos de ordem par imediatamente posteriores Se alguém poder ajudar na logica ajudaria muito, de preferencia não postar o algoritmo pronto e sim ajudar na logica em questão. Obrigado
  21. Boa noite ,galera.Eu tenho que criar uma tabela exibindo os valores do Resto,Quociente, X e Y (para esclarecer ---- O algoritmo Euclidiano Estendido me fornece os valores de X e Y que tornam a igualdade a.X + bY = mdc(a,b) , onde a e b são os valores digitados pelo usuário ) Eu fiz o seguinte:criei 3 pares de variáveis ( e [v] para os valores de X(j-2) e Y(j-2) {X e Y de duas linhas anteriores a atual},respectivamente. e [t] para os valores de X(j-1) e Y(j-1) {X e Y de uma linha anterior a atual},respectivamente. E,por último,[m] e [h] para os valores de Xj e Yj {X e Y da linha atual},respectivamente). Na parte do while(R !=0): ... depois do final do primeiro ciclo,eu começo a ter erro na distribuição das váriáveis. while (R != 0): a = b b = R R = a % b Q = a // b u = m v = h m = s - m*Q h = t - h*Q if (R == 0): print R,Q,"-","-" else: print R,Q,m,h a = b b = R R = a % b Q = a // b s = u t = v m = u - m*Q h = t - h*Q s = m t = h if (R == 0): print R,Q,"-","-" else: print R,Q,m,h print "---" Valores de entrada : a = 294 b = 108 EXEMPLO DE SAÍDA : 78 2 1 -2 30 1 -1 3 18 2 3 -8 12 1 0 0 6 1 3 -8 0 2 - - COMO DEVERIA SER : 78 2 1 -2 30 1 -1 3 18 2 3 -8 12 1 -4 11 6 1 7 -19 mdc(a,b)= mdc(294,108) = 6 0 2 - - Tem algum jeito melhor de fazer esse algoritmo? Com vetores,talvez? Desde já,obrigado!
  22. Olá, estou escrevendo para contar e compartilhar com um projeto que eu só percebi, é chamado de PSEUDOCODE, é uma aplicação Android, destinado a estudantes que frequentam os primeiros ciclos e fazer o curso de algoritmos e programação, eu ter tomado esse curso ea ele precisa fazer uma ferramenta para testar os nossos algoritmos, especialmente a partir do celular no momento em que é essencial para cada aluno, como nem todos andar com um laptop na mochila.I compartilhar o link do meu projeto: https://play.google.com/store/apps/details?id=pe.diegoveloper.pseudocodeEle é baseado no pseudocódigo ferramenta para PC: Visualg https : // visualg30.sourceforge.io/lembranças
  23. Olá. A minha intenção é escrever um algoritmo em que o usuário entre com vários números inteiros e positivos,e imprima o produto dos números ímpare sque o usuário digitou e a soma dos números para que o usuário digitou. Porém,da maneira que eu escrevi este algoritmo(segue a imagem anexada),se eu realizar as operaçõe sem digitar nenhum número impar,o resultado da váriável prod a ser printado na tela será 1(o valor que eu atribuí a ela entes d iniciar a estrutura enquanto,para que no final,o valor a ser printado na tela seja diferente de 0). Como eu faço para redefinir o valor da variável prod nessas condiçoes? Desde já,obrigado
  24. Boa tarde, pessoal, tudo bem? Estou tentando programar um algoritmo simples em c++, que retorna a soma 1/(2*3)+1/(3*4)+....+1/((n+1)*(n+2)). Faz um tempinho que estava sem programar em c++, então estou tendo um pouco de problema. #include <iostream> #include <cmath> #include <cstdlib> #include <iomanip> /* run this program using the console pauser or add your own getch, system("pause") or input loop */ using namespace std; int main(int argc, char** argv) { int n, i; long double soma=0, x; cout << "Insira o valor de termos da serie (n): " << endl; cin >> n; for (i=1;i<=n;i++) { x=1/((i+1)*(i+2)); soma=soma+x; } if (n!=0) cout << "O valor do somatorio dos n termos e: " << soma << endl; else cout << 0; system("PAUSE"); return EXIT_SUCCESS; } Esse é o programa, não sei porque ele me retorna um valor 0. Agradeço desde já a quem puder me ajudar!!
  25. Faça um programa que leia o arquivo tabela.dat1 que contém tempos de queda de bolinhas de vários tipos. Após a leitura, o programa deverá gerar o arquivo desvios.dat, cujo formato interno é igual ao arquivo tabela.dat, exceto que para cada altura, haverá no lugar dos tempos os seguintes valores: média dos tempos de queda, o desvio padrão e o erro padrão da média. dados da tabela.dat: [BOLA TIPO 1] altura;t1;t2;t3;t4;t5 2,12;0,15;0,45;0,40;0,60;0,48 4,03;0,74;0,84;0,66;0,98;1,13 5,53;1,11;1,01;1,19;1,03;1,39 7,09;1,40;1,47;1,49;1,36;1,43 [BOLA TIPO 2] altura;t1;t2;t3;t4;t5 2,12;0,50;0,40;0,45;0,44;0,43 4,03;0,52;0,57;0,59;0,61;0,52 5,53;0,69;0,98;0,91;0,75;0,66 7,09;1,09;1,05;1,06;0,81;0,99 [BOLA TIPO 3] altura;t1;t2;t3;t4;t5 2,12;0,60;0,50;0,55;0,54;0,53 4,03;0,62;0,67;0,69;0,71;0,62 5,53;0,79;1,08;1,01;0,85;0,76 7,09;1,19;1,15;1,16;0,91;1,09 [BOLA TIPO 4] altura;t1;t2;t3;t4;t5 2,12;0,71;0,61;0,66;0,65;0,64 4,03;0,73;0,78;0,80;0,82;0,73 5,53;0,90;1,19;1,22;0,96;0,87 7,09;1,30;1,26;1,27;1,02;1,20 [BOLA TIPO 5] altura;t1;t2;t3;t4;t5 2,12;0,55;0,45;0,50;0,49;0,48 4,03;0,57;0,62;0,64;0,66;0,57 5,53;0,74;1,03;0,96;0,80;0,71 7,09;1,14;1,10;1,11;0,86;1,03