Search the Community

Showing results for tags 'media'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Programação & Desenvolvimento
    • ASP
    • PHP
    • .NET
    • Java
    • C, C++
    • Delphi, Kylix
    • Lógica de Programação
    • Mobile
    • Visual Basic
    • Outras Linguagens de Programação
  • WEB
    • HTML, XHTML, CSS
    • Ajax, JavaScript, XML, DOM
    • Editores
  • Arte & Design
    • Corel Draw
    • Fireworks
    • Flash & ActionScript
    • Photoshop
    • Outros Programas de Arte e Design
  • Sistemas Operacionais
    • Microsoft Windows
    • GNU/Linux
    • Outros Sistemas Operacionais
  • Softwares, Hardwares e Redes
    • Microsoft Office
    • Softwares Livres
    • Outros Softwares
    • Hardware
    • Redes
  • Banco de Dados
    • Access
    • MySQL
    • PostgreSQL
    • SQL Server
    • Demais Bancos
  • Segurança e Malwares
    • Segurança
    • Remoção De Malwares
  • Empregos
    • Vagas Efetivas
    • Vagas para Estágios
    • Oportunidades para Freelances
  • Negócios & Oportunidades
    • Classificados & Serviços
    • Eventos
  • Geral
    • Avaliações de Trabalhos
    • Links
    • Outros Assuntos
    • Entretenimento
  • Script Brasil
    • Novidades e Anúncios Script Brasil
    • Mercado Livre / Mercado Sócios
    • Sugestões e Críticas
    • Apresentações

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 8 results

  1. "Os dados de uma turma de N alunos (nomes, sexos e notas em três disciplinas regulares) serão armazenados em vários vetores, sendo que para uma mesma posição i, acessando os diferentes vetores teremos os dados do aluno i. Construir um algoritmo que (cada opção dentro de um método): 1.Efetue a leitura destes dados. 2.Calcule e visualize a média das notas da turma (considerando as três disciplinas e todos os alunos). 3.Calcule e visualize a média das notas de cada aluno. 4.Visualize o nome, sexo e média das notas do aluno com a maior média. 5.Calcule e visualize a média das notas das mulheres da turma na segunda disciplina. 6.Visualize os nomes dos alunos reprovados na primeira disciplina (com nota menor que 6,0 pontos). 7.Visualize os alunos que ficaram abaixo da média da turma (na terceira disciplina). " Estou na duvida, como posso desenvolver esse código? Sou novata em python e nunca vi misturar vetor com metodo e.e Me ajudem, por favor. ALGORITMO DADO PELO ENUNCIADO (como tranformá-lo em python?): Algoritmo TurmaNotas real disc1[200], disc2[200], disc3[200]caractere nome[200] ,sexo[200]inteiro n início leituraDeDados() calcularMediaGeral() mediaDeCadaAluno() alunoComMaiorMedia() mediaDasMulheresNaSegundaDisciplina() ... fim void leituraDeDados() inteiro i início inteiro i escreva ("Digite a quantidade de alunos da turma: ") leia (n) para(i=0; i<n; i++) escreva ("Digite o nome do aluno " + (i+1) + ": " ) leia (nome[i]) escreva ("Digite o sexo deste aluno (m ou f): ") leia (sexo[i]) escreva ("Digite a nota na 1ª disciplina: ") leia (disc1[i]) escreva ("Digite a nota na 2ª disciplina: ") leia (disc2[i]) escreva ("Digite a nota na 3ª disciplina: ") leia (disc3[i]) fim_para fim void calcularMediaGeral() inteiro i real soma, media início soma = 0 para(i=0; i<n; i++) soma += disc1[i] + disc2[i] + disc3[i] fim_para media = soma / (3 * n) escreva ("A média geral das notas da turma é " + media) fim void mediaDeCadaAluno() inteiro i real media início para(i=0; i<n; i++) media = (disc1[i] + disc2[i] + disc3[i]) / 3 escreva ("O aluno " + nome[i] + " tem média: " + media) fim_para fim void alunoComMaiorMedia() inteiro i, pos real media, maior início maior = (disc1[0] + disc2[0] + disc3[0]) / 3 pos = 0 para(i=1; i<n; i++) media = (disc1[i] + disc2[i] + disc3[i]) / 3 se (media > maior) então maior = media pos = i fim_se fim_para escreva ("O aluno com maior média é " + nome[pos] + ", sexo: " + sexo[pos] + ", com média " + maior) fim void mediaDasMulheresNaSegundaDisciplina() inteiro i, quantMulh real soma, media início soma = 0 quantMulh = 0 para(i=0; i<n; i++) se (sexo[i] == "F" ou sexo[i] == "f") então soma += disc2[i] // nota na 2ª disc. quantMulh++ fim_se fim_para se (quantMulh >0) então media = soma / quantMulh escreva ("A média das notas das mulheres na 2ª disciplina é " + media) senão escreva ("Esta turma não tem mulheres!" ) fim_se fim
  2. Ola, sou iniciante em PHP e estou com dificuldade para usar array em função anonima. tenho seguinte código: <?php $med = function($n1,$n2,$n3,$n4){ $result = ($n1+$n2+$n3+$n4)/4; return $result; } $aluno[0]["nome"] = "Brian Johnson"; $aluno[0]["media"] = $med(3,6,6,8); $aluno[1]["nome"] = "Lenny Kravitz"; $aluno[1]["media"] = $med(1,4,2,5); $aluno[2]["nome"] = "Bruce Dickinson"; $aluno[2]["media"] = $med(4,5,4,4); $aluno[3]["nome"] = "James Hetfield"; $aluno[3]["media"] = $med(7,4,7,7); $aluno[4]["nome"] = "Angus Young"; $aluno[4]["media"] = $med(7,6,6,8); for($i = 0, $n = count($aluno); $i < $n; $i++){ echo "<b>Nome do aluno: </b>" . $aluno[$i]["nome"] . "</b><br>"; echo "<b>Media do aluno: </b>" . $aluno[$i]["media"] . "</b><br><br>"; } ?> Tenho array contendo notas e nomes dos alunos. Porém quando executo desta maneira ele da o seguinte erro " Parse error: syntax error, unexpected '$aluno' (T_VARIABLE) in C:\wamp64\www\PHP\exec_time.php on line 7 ". Quando eu não uso função anonima (function med($n1,$n2,$n3,$n4)) ele roda sem erros, mas quando tento usar função anonima ele apresenta este erro na variavel $aluno. Pesquisei muito mas não consegui resolver este problema. Alguém poderia me auxiliar? Desde já agradeço!
  3. Boa tarde, sou novo por aqui , comecei a fazer sistema da informação a pouco tempo . Na aula de ontem o professor pediu pra fazermos um exercício em portugol que recebe x números , e depois faz a media dos mesmos ( e quando quiser parar e receber a media a pessoa digita -1) Eu fiz praticamente todo , ta tudo correto , só não consigo fazer com q os valores que a pessoa coloca vão se somando... eu tentei colocar: valores <- valores+valores para ele pegar o valor q a pessoa colocou e somar com o valor novo ... mas não sei porque quando coloco isso ele entra em looping e quando digito -1 ele n para , continua pedindo pra digitar os valores... Não sei se entenderam oque quis dizer , mas preciso q o algoritmo receba um valor , guarde esse valor na variável "valores" depois quando for repetir o laço pela segunda vez ele pegue esse valor armazenado e some com o valor novo e assim sucessivamente , o problema e q eu não sei quantos valores a pessoa vai por é infinito ... por isso não posso por simplesmente n1+n2 , é um variável com outra variável... espero que possam me ajudar. meu código ficou assim : Algoritmo "Valores e Média" // Linguagem e Lógica de Programação // // Descrição : Recebe x valores e calcula a média // Autor(a) : Wellington Capoia // Data atual : 20/4/2016 Var // Seção de Declarações das variáveis media, valores, cont, resultado, valoressomados: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... cont <- 0 valores <- 0 escreval ("Algoritmo para receber um numero x de valores e calcular média") escreval ("Para para calcular a média digite -1 a qualquer momento") enquanto valores <> -1 faca escreval ("Digite os valores:") leia (valores) valores <- valores+valores cont <- cont+1 fimenquanto escreval ("valores somados", valoressomados) cont <- cont-1 escreval ("Valores digitados:", cont) resultado <- valoressomados/cont escreval ("A média dos valores é:", resultado) Fimalgoritmo
  4. Boa tarde a todos, Estou tentando elaborar um script em PHP para calcular a média dos valores de uma coluna da minha base de dados SQL, atualmente estou utilizando o seguinte código para tirar a média: $sql = "SELECT `VAL1`, avg(`VAL1`) AS VAL1, `VAL2`, avg(`VAL2`) AS VAL2, `VAL3`, avg(`VAL3`) AS VAL3, `VAL4`, avg(`VAL4`) AS VAL4, `VAL5`, avg(`VAL5`) AS VAL5, `VAL6`, avg(`VAL6`) AS VAL6 FROM `USER`"; $rs = mysql_query($sql) or die(mysql_error()); $row = mysql_fetch_array($rs); $MEDIA1 = $row['VAL1']; $MEDIA2 = $row['VAL2']; $MEDIA3 = $row['VAL3']; $MEDIA4 = $row['VAL4']; $MEDIA5 = $row['VAL5']; $MEDIA6 = $row['VAL6']; Mas com isso ele está pegando a média de todos os valores da coluna, tem como eu selecionar apenas os últimos 100 valores da coluna? Quando vou colocar eles em lista utilizo da seguinte forma: $sql = "SELECT `VAL1`, avg(`VAL1`) AS VAL1, `VAL2`, avg(`VAL2`) AS VAL2, `VAL3`, avg(`VAL3`) AS VAL3, `VAL4`, avg(`VAL4`) AS VAL4, `VAL5`, avg(`VAL5`) AS VAL5, `VAL6`, avg(`VAL6`) AS VAL6 FROM `USER` LIMIT 100"; Com o auxílio do "LIMIT 100", mas não está funcionando com o "avg". Alguém poderia me auxiliar com esse problema? Obrigado, William
  5. por favor me ajudem sou novato , estou tentando fazer esse exercício em python só que ele apenas lê as duas notas e fica esperando na tela , aonde esta o erro? desde já grato aguardo respostas!! nota1 = float(input("Digite a 1°a Nota: ")) nota2 = float(input("Digite a 2°a Nota: ")) media = (nota1 + nota2) / 2 if (media >= 9.0) and (media == 10.0): conceito = "A" else: if (media >= 7.5) and (media < 9.0): conceito = "B" else: if (media >= 6.0) and (media < 7.5): conceito = "C" else: if (media >= 4.0) and (media < 6.0): conceito = "D" else: if (media >= 0) and (media < 4): conceito = "E" else: if conceito == "A" or conceito == "B" or conceito == "C": print("Nota 1 %f , Nota 2 %f %s APROVADO! "%(nota1,nota2,media,conceito)) else: print("Nota 1 %f , Nota 2 %f %s REPROVADO! "%(nota1,nota2,media,conceito))
  6. Daniel_F

    Iniciante em C++

    Olá, estou iniciando meus estudos em C++, e tenho 2 dúvidas que não encontrei resposta em minhas pesquisas. 1° O simbolo & é sempre necessário para todas as variáveis quando pedir para o computador ler alguma ? 2° No meu primeiro programinha em que faço um calculo simples de média, o resultado de saída não é bem um numero real. EX: a média de 5 + 2 seria 3,5 mas o resultado é sempre o inteiro virgula zeros. Onde está meu erro ? Uso o dev c++ para copilar Aqui esta a imagem do meu programinha: http://img104.imagevenue.com/img.php?image=112959498_scriptbrasil_122_213lo.jpg Obrigadão...
  7. Boa tarde gente, sou novo por aqui e na área de programação. Recebi um exercício em javascript e não estou conseguindo resolver, gostaria de uma ajuda de quem entende. Segue a questão: Faça um programa em javascript que leia o nome e o peso dos alunos de uma turma. Você não sabe quantos alunos tem esta turma. Portanto o peso 999 encerra a entrada de dados. Após a entrada de dados, mostre o nome e o peso do aluno mais pesado, e do aluno mais leve, o peso total da turma, e a media do peso da turma. Tentei dessa forma mas não está dando certo: var nome = []; var peso = []; // Loop infinito while (true) { var n = prompt("Informe o Nome da criança"); var p = prompt("Informe o Peso da criança"); // faz teste para ver o peso antes de atribuir ao array if (p == 999) { break; // interrompe o loop quando peso igual 999 } // array recebe o valor nome.push(n); peso.push(p); } // variaveis onde ficaram as alturas maiores, menores e total var maior = 0; var menor = 0; var total = 0; // variais para armazenar pessoas que tem peso igual var maiorIgual = ''; var menorIgual = ''; for(i = 0; i == peso.length; i++){ // verifica se o peso é maior e armazena if (peso < peso[maior]) { maior = i; } else if (peso == peso[maior]){ maiorIgual = (maiorIgual === '' ? nome : nome + ", " + maiorIgual); } // verifica se o peso é menor e armazena if (peso < peso[menor]) { menor = i; } else if (peso == peso[menor]){ menorIgual = (menorIgual === '' ? nome : nome + ", " + menorIgual); } // soma ao total total += peso; } // Exibe o resultado alert('Maior peso: ' + maiorIgual + ' e ' + nome[maior] + ' tem peso igual ' + peso[maior]); alert('Menor peso: ' + maiorIgual + ' e ' + nome[menor] + ' tem peso igual ' + peso[menor]); alert('Peso total: ' + total); alert('Média peso: ' + (total / peso.length));
  8. Boa tarde, gostaria de uma ajuda com esse problema envolvendo laço de repetição no visualg. '' Foram coletados sobre salário de número de filhos em uma cidade. Deseja-se saber - A média do salário da população - A média do numero de filhos - o maior salário - e a percentagem de pessoas com salário até 150 * o final da leitura de dados se com a entrada de um salário negativo '' Eu fiz o seguinte : var sal, ms, maior, perc, mnf :real nf, c, cs : inteiro inicio c <- 1 , cs <-0 // contador do numero de pessoas com salário menor que 150 mnf <- 0 // média de numero de filhos ms <- 0 // média de salário maior <- 0 // maior salário Escreval ("Digite salário ou numero negativo para sair") // para entrar no laço de repetiçao leia(sal) enquanto sal > -1 faca c<-c+1 escreval ("digite numero de filhos") leia(nf) escreval ("Digite salário ou num neg. para sair ") leia (sal) ms <- ms + sal mnf <- mnf + nf se sal > maior então maior <- sal fimse se sal < 150.00 então cs<- cs+ 1 // contador de pessoas com salário maior que 150 perc <- cs * (100/c) fimse fimenquanto escreval ("Média de salário é: ", ms/c) escreval ("Média de filhos é: ", mnf/c) escreval ("maior salário é : ", maior) escreval ("Perc de pessoas com salario maior que 150 é : ", perc) fimalgoritmo Mas quando é digitado um numero negativo para encerrar, esse numero acaba entrando no valor salário e alterando a media de salário. E o primeiro salário ( fora do laço enquanto) não entra na contagem, então caso ele seja o maior salário digitado ele não aparecerá para o usuário e se ele for menor que 150 não entrará no calculo da percentegem. Se alguém puder me da uma dica para resolver isso eu agradeço.