Jump to content
Fórum Script Brasil

Search the Community

Showing results for tags 'visualg'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Programação & Desenvolvimento
    • ASP
    • PHP
    • .NET
    • Java
    • C, C++
    • Delphi, Kylix
    • Lógica de Programação
    • Mobile
    • Visual Basic
    • Outras Linguagens de Programação
  • WEB
    • HTML, XHTML, CSS
    • Ajax, JavaScript, XML, DOM
    • Editores
  • Arte & Design
    • Corel Draw
    • Fireworks
    • Flash & ActionScript
    • Photoshop
    • Outros Programas de Arte e Design
  • Sistemas Operacionais
    • Microsoft Windows
    • GNU/Linux
    • Outros Sistemas Operacionais
  • Softwares, Hardwares e Redes
    • Microsoft Office
    • Softwares Livres
    • Outros Softwares
    • Hardware
    • Redes
  • Banco de Dados
    • Access
    • MySQL
    • PostgreSQL
    • SQL Server
    • Demais Bancos
  • Segurança e Malwares
    • Segurança
    • Remoção De Malwares
  • Empregos
    • Vagas Efetivas
    • Vagas para Estágios
    • Oportunidades para Freelances
  • Negócios & Oportunidades
    • Classificados & Serviços
    • Eventos
  • Geral
    • Avaliações de Trabalhos
    • Links
    • Outros Assuntos
    • Entretenimento
  • Script Brasil
    • Novidades e Anúncios Script Brasil
    • Mercado Livre / Mercado Sócios
    • Sugestões e Críticas
    • Apresentações

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

  1. Estou tentando inverte a posição sem repetir posição, para qualquer tamanho. exemplo: 1 2 3 2 1 3 3 1 2 algoritmo "exericio" // Função : // Autor : // Data : 25/10/2022 // Seção de Declarações var num,valor,cont,i,ultvalor:inteiro inicio // Seção de Comandos escreva("Digite numero:") leia(num) cont:=1 enquanto cont <> num faca para i de cont ate 3 faca ultvalor:=cont se(i = 1)então escreva(i) fimse se(i <> ultvalor)então escreva(i) senao ultvalor:=ultvalor+1 fimse fimpara escreval cont:=cont+1 valor:=ultvalor fimenquanto fimalgoritmo
  2. Tou tendo problema com guarda na caixa er pra grava a quantidade de pessoas co certa idade mais so fica sempre a ultima algoritmo "semnome" var Sexo,C,A,M,F,Homens,h:Caractere Idade,B,B1:Inteiro inicio C <- "S" Repita Escreva("Qual o sexo? [M/F] ") Leia(Sexo) Escreva("Qual a idade? ") Leia(Idade) EscrevaL("Qual a cor do cabelo") EscrevaL("-_-_-_-_-_-_-_-_-_-_") EscrevaL("|[1]Preto|") EscrevaL("|[2]Loiro|") EscrevaL("|[3]Ruivo|") EscrevaL("|[4]Castanho|") Leia(A) Escolha A Caso "1" EscrevaL("Quer continuar? [S/N]") Leia(C) Caso "2" EscrevaL("Quer continuar? [S/N]") Leia(C) Caso "3" EscrevaL("Quer continuar? [S/N]") Leia(C) Caso "4" EscrevaL("Quer continuar? [S/N]") Leia(C) FimEscolha LimpaTela Ate C = "N" EscrevaL("==============") EscrevaL("RESUTADO FINAL") EscrevaL("==============") Se (Idade > 18)então B <- B + 1 Escolha Sexo Caso "M" M <- "CASTANHOS" Escolha A Caso "4" EscrevaL("TOTAL DE HOMENS COM MAIS DE 18 ANOS DE CABELOS ",M," É ",B) FimEscolha FimEscolha FimSe Se (Idade >= 25) e (Idade <= 30)então B1 <- B1 + 1 Escolha Sexo Caso "F" F <- "LOIRIOS" Escolha A Caso "2" EscrevaL("TOTAL DE MULHERES ENTRE 25 E 30 ANOS DE CABELOS ",F," É ",B1) FimEscolha FimEscolha FimSe fimalgoritmo
  3. algoritmo "Times" var time: caractere inicio escreva ("Entre com o nome de um time de futebol: ") leia (time) escolha time caso "Flamengo", "Fluminense", "Vasco", "Botafogo" escreval ("É um time carioca.") caso "São Paulo", "Palmeiras", "Santos", "Corínthians" escreval ("É um time paulista.") outrocaso escreval ("É de outro estado.") fimescolha fimalgoritmo Oi, pessoal. Então, estou começando a aprender programação por agora e estou vendo alguns vídeos de lógica de programação. Em um vídeo estava estudando sobre controle de execução e quando fui fazer um exercício no visualg, tive problemas com o seguintes comandos: escolha>caso>escreval, mais especificamente com o tipo de dado "caractere". Quando executo o programa (por exemplo o algoritmo acima), após escrever na variável, sempre aparece a mensagem do comando de "outrocaso" ou, quando não tem esse comando, simplesmente finaliza a operação, ao contrário de aparecer a mensagem instruída pelo comando "escreval". Testei com vários códigos diferentes e o resultado é o mesmo, porém, quando mudo o tipo de dado para inteiro, por exemplo, e fazendo as devidas adaptações da linguagem, dá certo. Penso que o posso estar escrevendo algo fora da linguagem, mas não encontro respostas. Já desinstalei e instalei novamente o software, mas sem sucesso. Se alguém souber o que está acontecendo e me ajudar, ficaria muito grato!
  4. alguém consegue passar para o Visualg, não estou nem conseguindo começar. visualg Escrever um algoritmo que lê uma matriz A(15,5) e a escreva. Verifique, a seguir, quais os elementos de A que estão repetidos e quantas vezes cada um está repetido. Escrever cada elemento repetido com uma mensagem dizendo que o elemento aparece X vezes em A.
  5. Eae gente, bom? Eu estou com um problema para descobrir a média de filhos que as pessoas da cidade tem, já quebrei a cabeça e não vejo a solução, vou postar o código e se alguém puder ajudar agradeço. Mas basicamente eu quero ver a média de filhos que as pessoas dessa cidade tem, e mostrar essa média, eu tentei ir calculando enquanto fosse colocando os resultados mas a conta sempre da errado. Algoritmo "pequena_cidadde" Var Total_Pessoas, Cont: Inteiro Salario, Maior_Salario, Media_Filhos, Filhos: Real Pessoa, Pessoa_Rica: Caractere Inicio Escreva("Quantas pessoas existem na cidade: ") Leia(Total_Pessoas) Media_Filhos <- 0 Cont <- 1 Maior_Salario <- 0 Enquanto (Cont <= Total_Pessoas) faca Escreva("Nome da", Cont,"o. pessoa? ") Leia(Pessoa) Escreva(Cont,".o Qual seu salário? R$") Leia(Salario) Escreva(Cont,".o Numero de filhos? ") Leia(Filhos) Cont <- Cont + 1 Media_Filhos <- (Filhos + Filhos) / Cont -------------- OBS: essa linha aqui eu queria arrumar, a média de filhos das pessoas da cidade. Se (Salario > Maior_Salario) então Maior_Salario <- Salario Pessoa_Rica <- Pessoa FimSe FimEnquanto Escreval("A média de filhos é ", Media_Filhos) Escreval("O maior salario é R$", Maior_Salario," de ", Pessoa_Rica) Fimalgoritmo
  6. Meu código está somando mais do que devia e não consigo resolver, eu coloco o limite de 10 e ele conta até 11, se eu colocar 20 vai até 21, e assim sucessivamente. Talvez seja algo bobo mas se alguém puder me ajudar agradeço! OBS: Não consegui colocar a imagem para ajudar. Var Contador : Inteiro Inicio: Contador <- 0 Enquanto (Contador <= 10) faca contador <- contador + 1 Escreva(Contador) FimEnquanto Fimalgoritmo
  7. eu preciso implantar no algoritmo a exclusão e a reorganização da matriz sendo assim, por exemplo após a exclusão do 3º cadastrado o 4º cadastrado tem que assumir a posição do 3º e assim suscetivelmente. Algoritmo "Remover usuário da estrutura de arrays bidimensionais" procedimento menu () var op : caractere // Opções do menu fimproc : inteiro // Opção de sair do menu Inicio repita limpatela escreval ("********** Menu **********") escreval ("Digite o numero da opção desejada.") escreval ("") escreval ("1 - Cadastrar usuário") escreval ("2 - Listar") escreval ("3 - Buscar") escreval ("4 - Excluir") escreval ("5 - Sair") escreval ("") escreva ("Digite uma opção: ") leia(op) limpatela escolha(op) caso "1" cadastro() caso "2" listar() caso "3" buscar() caso "4" excluir() caso "5" fimproc <- 5 interrompa outrocaso Menu() fimescolha ate(fimproc = 5) fimprocedimento procedimento cadastro() var op: inteiro inicio limpatela escreval ("--------- Menu de cadastro ---------") escreva ("Nome: ") Leia (usuario[cont,contd]) contd := contd + 1 escreva ("Idade: ") leia (usuario[cont,contd]) cont := cont + 1 contd := contd - 1 fimprocedimento procedimento listar() var inicio para cont de 0 ate 4 faca escreva ("|Nome: ",Usuario[cont,0]) escreval (" - Idade: ",usuario[cont,1],"|") fimpara escreval("----------------------") escreva ("Digite qualquer tecla para sair.") leia (sr) fimprocedimento procedimento buscar(): caractere var nome : caractere encontrou : inteiro contador : inteiro inicio limpatela escreval ("----- Buscar Cadastrados -----") escreva ("Digite o nome para a busca: ") leia(nome) limpatela encontrou <- 0 para contador de 0 ate 4 faca se (usuario[contador]) = nome então escreval ("Nome: ", usuario[contador,0], "| Idade ", usuario[contador,1]) encontrou <-1 fimse fimpara se encontrou = 0 então escreval ("Usuário não encontrado") fimse leia (sr) fimprocedimento procedimento excluir() var nome : caractere encontra : inteiro contador : inteiro scont : inteiro scontd : inteiro aux : caracter inicio limpatela escreval ("----- Excluir Cadastrado -----") escreva ("Digite o nome para a Excluir; ") leia(nome) limpatela encontra <- 0 para contador de 0 ate 4 faca se (usuario[contador]) = nome então usuario[contador,0]:= "" usuario[contador,1]:= "" encontra <-1 escreval (" Usuario Excluido!") escreval ("Aperte qualquer tecla para voltar.") leia(sr) // A Reorganização acontece aqui se usuario[contador] = "" então para scont de contador+0 ate 4 faca para scontd de contador+0 ate 1 faca aux <- usuario[cont,contd] usuario[scont,scontd] <- usuario[scont+1,scontd+1] usuario[cont,contd+1] <- usuario[scont,scontd+1] usuario[cont+1,contd+1] <- aux fimpara fimpara fimse fimse fimpara
  8. Alguém pode me ajudar a resolver esse raciocínio lógico que eu não estou conseguindo resolver, que é a implantação de um menu onde eu cadastro, listo, busco e excluo o usuário. e além de excluir o usuário, os posteriores tem que assumir a posição do que foi apagado. Algoritmo "Remover usuário da estrutura de arrays bidimensionais" procedimento menu () var op : caractere // Opções do menu fimproc : inteiro // Opção de sair do menu Inicio repita limpatela escreval ("********** Menu **********") escreval ("Digite o numero da opção desejada.") escreval ("") escreval ("1 - Cadastrar usuário") escreval ("2 - Listar") escreval ("3 - Buscar") escreval ("4 - Excluir") escreval ("5 - Sair") escreval ("") escreva ("Digite uma opção: ") leia(op) limpatela escolha(op) caso "1" cadastro() caso "2" listar() caso "3" buscar() caso "4" excluir() caso "5" fimproc <- 5 interrompa outrocaso Menu() fimescolha ate(fimproc = 5) fimprocedimento procedimento cadastro() var op: inteiro inicio limpatela escreval ("--------- Menu de cadastro ---------") escreva ("Nome: ") Leia (usuario[cont,contd]) contd := contd + 1 escreva ("Idade: ") leia (usuario[cont,contd]) cont := cont + 1 contd := contd - 1 fimprocedimento procedimento listar() var inicio para cont de 0 ate 4 faca escreva ("|Nome: ",Usuario[cont,0]) escreval (" - Idade: ",usuario[cont,1],"|") fimpara escreval("----------------------") escreva ("Digite qualquer tecla para sair.") leia (sr) fimprocedimento procedimento buscar(): caractere var nome : caractere encontrou : inteiro contador : inteiro inicio limpatela escreval ("----- Buscar Cadastrados -----") escreva ("Digite o nome para a busca: ") leia(nome) limpatela encontrou <- 0 para contador de 0 ate 4 faca se (usuario[contador]) = nome então escreval ("Nome: ", usuario[contador,0], "| Idade ", usuario[contador,1]) encontrou <-1 fimse fimpara se encontrou = 0 então escreval ("Usuário não encontrado") fimse leia (sr) fimprocedimento procedimento excluir() var nome : caractere encontra : inteiro contador : inteiro scont : inteiro scontd : inteiro aux : caracter inicio limpatela escreval ("----- Excluir Cadastrado -----") escreva ("Digite o nome para a Excluir; ") leia(nome) limpatela encontra <- 0 para contador de 0 ate 4 faca se (usuario[contador]) = nome então usuario[contador,0]:= "" usuario[contador,1]:= "" encontra <-1 escreval (" Usuario Excluido!") escreval ("Aperte qualquer tecla para voltar.") leia(sr) // A Reorganização acontece aqui se usuario[contador] = "" então para scont de contador+0 ate 4 faca para scontd de contador+0 ate 1 faca aux <- usuario[cont,contd] usuario[scont,scontd] <- usuario[scont+1,scontd+1] usuario[cont,contd+1] <- usuario[scont,scontd+1] usuario[cont+1,contd+1] <- aux fimpara fimpara fimse fimse fimpara
  9. Olá pessoal Estou precisando de uma ajuda no código abaixo, estou fazendo exercício sobre a loteria, o que é para fazer, Dentro de um universo de numero no nosso caso eu escolhi 8 dezenas combinadas de 5 em 5, eu tenho que encontrar todas as sequencias de 3 ou seja 3 acerto iguais. exemplo, 123,124,125,126,127 até ultima 678. mais tem algum erro no código porque tem volantes se repetindo números a mais, veja no volantes 1 e volantes 3, ele repete 4 números iguais, o mesmo acontece para outro caso volantes 2=: 1 2 3 6 7 e volantes 5=: 1 2 5 6 7. segue o código abaixo para uma correção. Agradeço quem pode dar uma luz. obrigado. volantes 1=: 1 2 3 4 5 volantes 2=: 1 2 3 6 7 volantes 3=: 1 2 4 5 6 volantes 4=: 1 2 4 7 8 volantes 5=: 1 2 5 6 7 volantes 6=: 1 3 4 5 6 volantes 7=: 1 3 4 7 8 volantes 8=: 1 3 5 6 7 volantes 9=: 1 4 5 6 8 volantes 10=: 2 3 4 5 6 volantes 11=: 2 3 4 7 8 volantes 12=: 2 3 5 6 7 volantes 13=: 2 4 5 6 8 volantes 14=: 3 4 5 6 7 reduzidos: 14 total gerados: 56 algoritmo "loteria" var vetA: vetor[1..5]de inteiro vetB: vetor[1..5]de inteiro num,i,j,iguais,d,x,a,cont,total:inteiro n1,n2,n3,n4,n5:inteiro inicio // Seção de Comandos escreva("informe numero:") leia(num) para n1 de 1 ate num faca vetA[1]:= n1 para n2 de n1+1 ate num faca vetA[2]:= n2 para n3 de n2+1 ate num faca vetA[3]:= n3 para n4 de n3+1 ate num faca vetA[4]:= n4 para n5 de n4+1 ate num faca vetA[5]:= n5 total:= total + 1 para i de 1 ate 5 faca para j de 1 ate 5 faca se(vetA = vetB[j])então iguais:=iguais + 1 fimse fimpara fimpara se(iguais = 3)ou(iguais = 0)então para x de 1 ate 5 faca vetB[x]:= vetA[x] fimpara a:=a + 1 escrevaL("volantes",a,"=:",vetA[1],vetA[2],vetA[3],vetA[4],vetA[5]) cont:=cont + 1 fimse //************************************ x:=0 iguais:=0 fimpara fimpara fimpara fimpara fimpara escreval("reduzidos:", cont) escreval("total gerados:", total) fimalgoritmo
  10. Boa noite caros amigos, alguém poderia me ensinar o comando "escolha" em algoritimo no VisualG. Agradeço desde já.
  11. Oi pessoal, sou novo no site e estou em um curso técnico de informática e estou com um trabalho de fazer um programa no visualg usando as regras que aprendemos até agora e estou com dificuldade. Se pudessem me ajudar eu agradeceria muito :) OBS: As regras são: SE, PARA, ENQUANTO, ESCOLHA E FUNÇÃO DE TEXTO.
  12. Estou com dificuldade na logica de um exercício com vetor no visualg, o exercício é o seguinte: Faça um algoritmo que leia um vetor K[30]. Troque a seguir, todos os elementos de ordem ímpar do vetor com os elementos de ordem par imediatamente posteriores Se alguém poder ajudar na logica ajudaria muito, de preferencia não postar o algoritmo pronto e sim ajudar na logica em questão. Obrigado
  13. Olá, estou escrevendo para contar e compartilhar com um projeto que eu só percebi, é chamado de PSEUDOCODE, é uma aplicação Android, destinado a estudantes que frequentam os primeiros ciclos e fazer o curso de algoritmos e programação, eu ter tomado esse curso ea ele precisa fazer uma ferramenta para testar os nossos algoritmos, especialmente a partir do celular no momento em que é essencial para cada aluno, como nem todos andar com um laptop na mochila.I compartilhar o link do meu projeto: https://play.google.com/store/apps/details?id=pe.diegoveloper.pseudocodeEle é baseado no pseudocódigo ferramenta para PC: Visualg https : // visualg30.sourceforge.io/lembranças
  14. Olá. A minha intenção é escrever um algoritmo em que o usuário entre com vários números inteiros e positivos,e imprima o produto dos números ímpare sque o usuário digitou e a soma dos números para que o usuário digitou. Porém,da maneira que eu escrevi este algoritmo(segue a imagem anexada),se eu realizar as operaçõe sem digitar nenhum número impar,o resultado da váriável prod a ser printado na tela será 1(o valor que eu atribuí a ela entes d iniciar a estrutura enquanto,para que no final,o valor a ser printado na tela seja diferente de 0). Como eu faço para redefinir o valor da variável prod nessas condiçoes? Desde já,obrigado
  15. Escrevi um algoritmo para verificar se um número é primo ou não,de acordo com a 1ª imagem que eu anexei. O algoritmo roda tranquilo quando eu digito uns números pequenos(5,5,11),mas quando eu digito números grandes,o visualg trava,e eu sou obrigado a fechá-lo. Alguém sabe porque ocorre esse problema?(na segunda imagem eu digitei o número 123456789)
  16. Var nome:vetor [1..100] de caractere m,n,t,x,y,op:inteiro alt: vetor [1..100] de real imc: vetor [1..5,1..5] de real procedimento "cadastro" var imc: real p: real inicio escreval (" CADASTRO") escreval ("___________________________________") escreval ("digite o nome do paciente: ") leia (nome[t]) escreval ("digite a altura do paciente: ") leia (alt[t]) escreval ("digite o peso do paciente: ") leia (p) imc<- p/(alt[t]*alt[t]) escreval ("IMC: ", imc) se (imc<17) então escreval (" MUITO ABAIXO DO PESO.") fimse se (imc>17) e (imc< 18.49) então escreval ("ABAIXO DO PESO") fimse se (imc>18.50) e (imc<24.99) então escreval ("PESO NORMAL") fimse se (imc>25) e (imc<29.99)então escreval ("ACIMA DO PESO") fimse se (imc>30) e (imc<34.99)então escreval ("OBESIDADE 1") fimse se (imc>35) e (imc<39.99)então escreval ("OBESIDADE 2 (SEVERA)") fimse se (imc>40)então escreval ("OBESIDADE 3 (MÓRBIDA)") fimse escreval t<-t + 1 fimprocedimento procedimento "monitoramento" var p: real inicio escreval (" MONITORAMENTO") para n de 1 ate t-1 faca escreval ("_____________________________________") escreval ("NOME: ", nome[n]) escreval ("ALTURA: ", alt[n]) escreval ("O peso atual do paciente é: ") leia (p) escreval ("O imc atual é: ") imc[n,m]<- p/(alt[n]*alt[n]) escreval ("IMC: ", imc[n,m]) se (imc[n,m]<17) então escreval (" MUITO ABAIXO DO PESO.") fimse se (imc[n,m]>17) e (imc[n,m]< 18.49) então escreval ("ABAIXO DO PESO") fimse se (imc[n,m]>18.50) e (imc[n,m]<24.99) então escreval ("PESO NORMAL") fimse se (imc[n,m]>25) e (imc[n,m]<29.99)então escreval ("ACIMA DO PESO") fimse se (imc[n,m]>30) e (imc[n,m]<34.99)então escreval ("OBESIDADE 1") fimse se (imc[n,m]>35) e (imc[n,m]<39.99)então escreval ("OBESIDADE 2 (SEVERA)") fimse se (imc[n,m]>40)então escreval ("OBESIDADE 3 (MÓRBIDA)") fimse n<-n+1 m<-m+1 fimpara fimprocedimento procedimento "relatorio" var linha, g: inteiro inicio escreval (" RELATÒRIO") escreval ("_________________________") escreval (" TABELA DE MONITORAMENTO") para x de 1 ate 1 faca escreval (" ") para y de 1 ate t-1 faca escreval("PacienTe ",nome[y]," Com IMC = ",imc[y,1]:5:2) escreva (imc[n,m]:5:2) fimpara fimpara fimprocedimento procedimento "menu" inicio escreval ("___________________________") escreval ("1.CADASTRO DO PACIENTE") escreval ("2.MONITORAMENTO DO PACIENTE") escreval ("3.RELATÒRIO") escreval ("4.SAIR") escreval("____________________________") leia (op) se (op=1) então cadastro fimse se (op=2) então monitoramento fimse se (op=3) então relatorio fimse fimprocedimento Inicio // Seção de Comandos, procedimento, funções, operadores, etc... m<-1 t<-1 n<-1 enquanto (op<>4) faca menu fimenquanto se(op=4) então escreval ("FIM") fimse Fimalgoritmo Alguém poderia me ajudar com este programa ele já esta me dando dor de cabeça kkkk
  17. Bom dia pessoal, estou aprendendo a programar e me deparei com um exercício que começou a bugar minha cabeça. Gostaria que vocês pudessem me ajudar. Eu só aprendi a usar (se, senão, enquanto, repita) - Visualg O exercício é o seguinte: A tarefa consiste em receber um número como entrada e gerar o seu valor correspondente por extenso. O número n, fornecido na entrada, deverá ser tal que 0 < n < 1.000,00. Valores fora deste intervalo devem ser recusados, através de uma mensagem de erro. Como se trata de valores monetários, após a vírgula deverão existir exatamente 2 dígitos. Caso isto não ocorra, o sistema deve mostrar uma mensagem de erro. Ao escrever o valor por extenso deverão ser respeitadas as regras relacionadas a singular e plural. Na entrada do número é obrigatório o uso do ponto como marcador de milhagens. Os centavos devem ser separados por vírgula. Exemplo 1: Entrada: 1,32 Saída: Um real e trinta e dois centavos Não estou conseguindo faze-lo, alguém poderia clarear minha mente? Desde já agradeço a atenção de todos.
  18. Estava tentando fazer um jogo da velha porém quando o usuario escreve a linha e a coluna não marca na Matriz, alguém tem uma maneira facil de fazer isso?
  19. Bom dia, Estou iniciando o aprendizado no VisuAlg, mas estou com dúvida no seguinte exercício, por favor me deem uma luz: 45)Suponha que o conceito de um aluno seja determinado em função da sua nota. Suponha, também, que esta nota seja um valor inteiro na faixa de 0 a 100, conforme a seguinte tabela: NOTA CONCEITO 0 a 49 Insuficiente 50 a 64 Regular 65 a 84 Bom 85 a 100 Ótimo Crie um algoritmo leia a informação necessária e apresente o conceito e a nota do aluno var nota:inteiro conceito:caracter inicio escreval ("Digite a nota do aluno entre valores inteiros de 0 a 100") leia (nota) escolha nota caso (>=0) e (<49) conceito<-"Insuficiente" caso (>49)e (<=64) conceito<-"Regular" caso (>64) e (<=84) conceito<-"Bom" caso (>84) e (<=100) conceito<-"ótimo" outrocaso conceito<-"Nota inválida" fimescolha escreval ("Seu conceito é: " , conceito) fimalgoritmo
  20. Bom dia, Estou iniciando o aprendizado no VisuAlg, mas estou com dúvida no seguinte exercício: 45)Suponha que o conceito de um aluno seja determinado em função da sua nota. Suponha, também, que esta nota seja um valor inteiro na faixa de 0 a 100, conforme a seguinte tabela: NOTA CONCEITO 0 a 49 Insuficiente 50 a 64 Regular 65 a 84 Bom 85 a 100 Ótimo Crie um algoritmo leia a informação necessária e apresente o conceito e a nota do aluno var nota:inteiro conceito:caracter inicio escreval ("Digite a nota do aluno entre valores inteiros de 0 a 100") leia (nota) escolha nota caso (>=0) e (<49) conceito<-"Insuficiente" caso (>49)e (<=64) conceito<-"Regular" caso (>64) e (<=84) conceito<-"Bom" caso (>84) e (<=100) conceito<-"ótimo" outrocaso conceito<-"Nota inválida" fimescolha escreval ("Seu conceito é: " , conceito) fimalgoritmo
  21. Eu fiz, porém não sei qual o que fazer para ele contar quantas letras A possuem na frase que o usuário digitou. algoritmo "palavraoufrase" // Função : // Autor : // Data : 09/05/2016 // Seção de Declarações var palavrafrase: caracter a: caracter palavra: real inicio escreva ("Digite uma palavra ou uma frase.") leia (palavrafrase) se ( palavrafrase = a) então escreva (" Contém", compr(palavrafrase)) senao escreva ("não contém letras A") fimalgoritmo
  22. Eu preciso fazer um programa que faça com que o usuário digite o seu nome completo, portanto exiba apenas o primeiro nome e as boas vindas. algoritmo "NomeCompleto" // Função : // Autor : // Data : 07/05/2016 // Seção de Declarações var nomecompleto : caractere inicio escreval ("Entre com um nome completo.") leia (nomecompleto) escreval ("Olá " ,nomecompleto," .Desejamos boas vindas a você!") fimalgoritmo Estou no primeiro semestre de lógica de programação.
  23. Boa tarde, sou novo por aqui , comecei a fazer sistema da informação a pouco tempo . Na aula de ontem o professor pediu pra fazermos um exercício em portugol que recebe x números , e depois faz a media dos mesmos ( e quando quiser parar e receber a media a pessoa digita -1) Eu fiz praticamente todo , ta tudo correto , só não consigo fazer com q os valores que a pessoa coloca vão se somando... eu tentei colocar: valores <- valores+valores para ele pegar o valor q a pessoa colocou e somar com o valor novo ... mas não sei porque quando coloco isso ele entra em looping e quando digito -1 ele n para , continua pedindo pra digitar os valores... Não sei se entenderam oque quis dizer , mas preciso q o algoritmo receba um valor , guarde esse valor na variável "valores" depois quando for repetir o laço pela segunda vez ele pegue esse valor armazenado e some com o valor novo e assim sucessivamente , o problema e q eu não sei quantos valores a pessoa vai por é infinito ... por isso não posso por simplesmente n1+n2 , é um variável com outra variável... espero que possam me ajudar. meu código ficou assim : Algoritmo "Valores e Média" // Linguagem e Lógica de Programação // // Descrição : Recebe x valores e calcula a média // Autor(a) : Wellington Capoia // Data atual : 20/4/2016 Var // Seção de Declarações das variáveis media, valores, cont, resultado, valoressomados: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... cont <- 0 valores <- 0 escreval ("Algoritmo para receber um numero x de valores e calcular média") escreval ("Para para calcular a média digite -1 a qualquer momento") enquanto valores <> -1 faca escreval ("Digite os valores:") leia (valores) valores <- valores+valores cont <- cont+1 fimenquanto escreval ("valores somados", valoressomados) cont <- cont-1 escreval ("Valores digitados:", cont) resultado <- valoressomados/cont escreval ("A média dos valores é:", resultado) Fimalgoritmo
  24. Prezados estou iniciando um curso de programação e gostaria de saber com criar um algoritmo de horário de aula do meu curso. Alguém pode me informa como inicio? Var entrada: inteiro h,m,s: real inicio escreval(Entre com os segundos: ) leia(entrada) h: = entrada div 3600 // segundo referenciado por horas m: = (entrada mod 3600) /60 // resto da horas divida por 60 segundos s: = (entrada mod 3600) mod 60 // resto da horas em resto por segundos escreval(h, " : ", m, " : ", s) Portanto pessoal preciso de saber como agora inicio um horário de aula Agradeço muito aquele interessados.
  25. Olá a todos, sou novo aqui no fórum e na logica de programação. Gostaria de saber se existe a possibilidade de: Olhem o exemplo: Escreva ("Digite um conjunto de números: ") Leia (a, b, c, d) Quero que ao digitar: Ex: 1234 A <- 1 B <- 2 C <- 3 D <- 4 Desde já agradeço a força.
×
×
  • Create New...