Jump to content
Fórum Script Brasil

Search the Community

Showing results for tags 'visal'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Programação & Desenvolvimento
    • ASP
    • PHP
    • .NET
    • Java
    • C, C++
    • Delphi, Kylix
    • Lógica de Programação
    • Mobile
    • Visual Basic
    • Outras Linguagens de Programação
  • WEB
    • HTML, XHTML, CSS
    • Ajax, JavaScript, XML, DOM
    • Editores
  • Arte & Design
    • Corel Draw
    • Fireworks
    • Flash & ActionScript
    • Photoshop
    • Outros Programas de Arte e Design
  • Sistemas Operacionais
    • Microsoft Windows
    • GNU/Linux
    • Outros Sistemas Operacionais
  • Softwares, Hardwares e Redes
    • Microsoft Office
    • Softwares Livres
    • Outros Softwares
    • Hardware
    • Redes
  • Banco de Dados
    • Access
    • MySQL
    • PostgreSQL
    • SQL Server
    • Demais Bancos
  • Segurança e Malwares
    • Segurança
    • Remoção De Malwares
  • Empregos
    • Vagas Efetivas
    • Vagas para Estágios
    • Oportunidades para Freelances
  • Negócios & Oportunidades
    • Classificados & Serviços
    • Eventos
  • Geral
    • Avaliações de Trabalhos
    • Links
    • Outros Assuntos
    • Entretenimento
  • Script Brasil
    • Novidades e Anúncios Script Brasil
    • Mercado Livre / Mercado Sócios
    • Sugestões e Críticas
    • Apresentações

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Boa tarde, gostaria de uma ajuda com esse problema envolvendo laço de repetição no visualg. '' Foram coletados sobre salário de número de filhos em uma cidade. Deseja-se saber - A média do salário da população - A média do numero de filhos - o maior salário - e a percentagem de pessoas com salário até 150 * o final da leitura de dados se com a entrada de um salário negativo '' Eu fiz o seguinte : var sal, ms, maior, perc, mnf :real nf, c, cs : inteiro inicio c <- 1 , cs <-0 // contador do numero de pessoas com salário menor que 150 mnf <- 0 // média de numero de filhos ms <- 0 // média de salário maior <- 0 // maior salário Escreval ("Digite salário ou numero negativo para sair") // para entrar no laço de repetiçao leia(sal) enquanto sal > -1 faca c<-c+1 escreval ("digite numero de filhos") leia(nf) escreval ("Digite salário ou num neg. para sair ") leia (sal) ms <- ms + sal mnf <- mnf + nf se sal > maior então maior <- sal fimse se sal < 150.00 então cs<- cs+ 1 // contador de pessoas com salário maior que 150 perc <- cs * (100/c) fimse fimenquanto escreval ("Média de salário é: ", ms/c) escreval ("Média de filhos é: ", mnf/c) escreval ("maior salário é : ", maior) escreval ("Perc de pessoas com salario maior que 150 é : ", perc) fimalgoritmo Mas quando é digitado um numero negativo para encerrar, esse numero acaba entrando no valor salário e alterando a media de salário. E o primeiro salário ( fora do laço enquanto) não entra na contagem, então caso ele seja o maior salário digitado ele não aparecerá para o usuário e se ele for menor que 150 não entrará no calculo da percentegem. Se alguém puder me da uma dica para resolver isso eu agradeço.
×
×
  • Create New...