Search the Community

Showing results for tags 'def'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Programação & Desenvolvimento
    • ASP
    • PHP
    • .NET
    • Java
    • C, C++
    • Delphi, Kylix
    • Lógica de Programação
    • Mobile
    • Visual Basic
    • Outras Linguagens de Programação
  • WEB
    • HTML, XHTML, CSS
    • Ajax, JavaScript, XML, DOM
    • Editores
  • Arte & Design
    • Corel Draw
    • Fireworks
    • Flash & ActionScript
    • Photoshop
    • Outros Programas de Arte e Design
  • Sistemas Operacionais
    • Microsoft Windows
    • GNU/Linux
    • Outros Sistemas Operacionais
  • Softwares, Hardwares e Redes
    • Microsoft Office
    • Softwares Livres
    • Outros Softwares
    • Hardware
    • Redes
  • Banco de Dados
    • Access
    • MySQL
    • PostgreSQL
    • SQL Server
    • Demais Bancos
  • Segurança e Malwares
    • Segurança
    • Remoção De Malwares
  • Empregos
    • Vagas Efetivas
    • Vagas para Estágios
    • Oportunidades para Freelances
  • Negócios & Oportunidades
    • Classificados & Serviços
    • Eventos
  • Geral
    • Avaliações de Trabalhos
    • Links
    • Outros Assuntos
    • Entretenimento
  • Script Brasil
    • Novidades e Anúncios Script Brasil
    • Mercado Livre / Mercado Sócios
    • Sugestões e Críticas
    • Apresentações

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 4 results

  1. E ai gente, desculpa incomodar mas me ajudem, eu não sei como tirar o none do codico, n importa oque eu faça ele sempre fica ali!
  2. Olá, estou cursando o 2º período de Sistemas de Informação, e recentemente meu professor passou um atividade, porém, estou que quebro a cabeça e ainda não saiu nada. Se alguém puder me ajudar respondendo uma questão, poderei responder as demais seguindo a mesma logica. Desde já agradeço. 1 - Crie um programa que peça ao usuério digitar o nome de um arquivo e depois realize as seguintes operacoes a partir do conteúdo deste arquivo: lmprimir as maiores linhas: -Executa a função maiorLinha, apresentando na tela a maior linha (ou as maiores linhas) do arquivo (em quantidade de caracteres) -Afunção maiorLinha recebe como argumento o nome de um arquivo e retorna uma lista contento as maiores linhas do arquivo.(caso haja mais do que uma linha com o tamanho - em quantidade de caracteres da maior). 2 Corrige M e N antes de P e B: -E sabido que antes de P e B não se usa N e sim M. Esta opção vai passar a função corrigeMN a primeira frase do arquivo. A função retornará uma string contendo a frase corrigida. -A frase original e a frase corrigida deverão ser impressas, bem como a quantidade de correções realizadas. -Obs: Considere que poderá haver ocorréncias de nb ou np livremente, como nesta frase, e neste caso elas não deverao ser corrigidas pela função.
  3. "Os dados de uma turma de N alunos (nomes, sexos e notas em três disciplinas regulares) serão armazenados em vários vetores, sendo que para uma mesma posição i, acessando os diferentes vetores teremos os dados do aluno i. Construir um algoritmo que (cada opção dentro de um método): 1.Efetue a leitura destes dados. 2.Calcule e visualize a média das notas da turma (considerando as três disciplinas e todos os alunos). 3.Calcule e visualize a média das notas de cada aluno. 4.Visualize o nome, sexo e média das notas do aluno com a maior média. 5.Calcule e visualize a média das notas das mulheres da turma na segunda disciplina. 6.Visualize os nomes dos alunos reprovados na primeira disciplina (com nota menor que 6,0 pontos). 7.Visualize os alunos que ficaram abaixo da média da turma (na terceira disciplina). " Estou na duvida, como posso desenvolver esse código? Sou novata em python e nunca vi misturar vetor com metodo e.e Me ajudem, por favor. ALGORITMO DADO PELO ENUNCIADO (como tranformá-lo em python?): Algoritmo TurmaNotas real disc1[200], disc2[200], disc3[200]caractere nome[200] ,sexo[200]inteiro n início leituraDeDados() calcularMediaGeral() mediaDeCadaAluno() alunoComMaiorMedia() mediaDasMulheresNaSegundaDisciplina() ... fim void leituraDeDados() inteiro i início inteiro i escreva ("Digite a quantidade de alunos da turma: ") leia (n) para(i=0; i<n; i++) escreva ("Digite o nome do aluno " + (i+1) + ": " ) leia (nome[i]) escreva ("Digite o sexo deste aluno (m ou f): ") leia (sexo[i]) escreva ("Digite a nota na 1ª disciplina: ") leia (disc1[i]) escreva ("Digite a nota na 2ª disciplina: ") leia (disc2[i]) escreva ("Digite a nota na 3ª disciplina: ") leia (disc3[i]) fim_para fim void calcularMediaGeral() inteiro i real soma, media início soma = 0 para(i=0; i<n; i++) soma += disc1[i] + disc2[i] + disc3[i] fim_para media = soma / (3 * n) escreva ("A média geral das notas da turma é " + media) fim void mediaDeCadaAluno() inteiro i real media início para(i=0; i<n; i++) media = (disc1[i] + disc2[i] + disc3[i]) / 3 escreva ("O aluno " + nome[i] + " tem média: " + media) fim_para fim void alunoComMaiorMedia() inteiro i, pos real media, maior início maior = (disc1[0] + disc2[0] + disc3[0]) / 3 pos = 0 para(i=1; i<n; i++) media = (disc1[i] + disc2[i] + disc3[i]) / 3 se (media > maior) então maior = media pos = i fim_se fim_para escreva ("O aluno com maior média é " + nome[pos] + ", sexo: " + sexo[pos] + ", com média " + maior) fim void mediaDasMulheresNaSegundaDisciplina() inteiro i, quantMulh real soma, media início soma = 0 quantMulh = 0 para(i=0; i<n; i++) se (sexo[i] == "F" ou sexo[i] == "f") então soma += disc2[i] // nota na 2ª disc. quantMulh++ fim_se fim_para se (quantMulh >0) então media = soma / quantMulh escreva ("A média das notas das mulheres na 2ª disciplina é " + media) senão escreva ("Esta turma não tem mulheres!" ) fim_se fim
  4. Boa noite galera, sou iniciante em python, estou aprendendo seguindo o livro: Use a cabeça Python. Consegui manipular as listas, tudo tranquilo até aqui. Estou estudando a parte de funções, daí criei uma função que funcionou perfeitamente para uma lista, porém não consigo criar a opção dela funcionar para outra lista, idêntica em número de elementos. A função é essa: #!/usr/bin/env python # -*- coding: utf-8 -*- lista = [ "1", "2", [ "3", "4", [ "5", "6"]]] def printar(the_list): for x in lista: if isinstance(x, list): for y in x: if isinstance(y, list): for z in y: if isinstance(z, list): print(z) else: print(y) else: print(x) h =raw_input("Aperte x para exibir a função, e qualquer outra coisa para não fazer nada.") if h == ("x"): printar(lista) else: print("você digitou outra coisa, hihiih") Com os devidos recuos. Esta função funcionou para esta lista. Porém, quando acrescentei mais uma lista ao código e dei a opção dele escrever a segunda lista, ele acusa erro. O segundo programa é assim: #!/usr/bin/env python # -*- coding: utf-8 -*- lista1 = [ "1", "2", [ "3", "4", [ "5", "6"]]] lista2 = [ "0", "0", [ "0", "0", [ "0", "0"]]] def printar(lista1, lista2): for x in list: if isinstance(x, list): for y in x: if isinstance(y, list): for z in y: if isinstance(z, list): print(z) else: print(y) else: print(x) h =raw_input("Aperte x para exibir a função, e y para exibir outra função.") if h == ("x"): printar(lista1) if h == ("y"): printar(lista2) else: print("nada") Eu não sei se entendi muito bem a lógica das funções, ao meu ver uma função serve para que eu não necessite copiar todas as linhas para executar novamente, assim eu posso imprimir duas listas diferentes, usando quase que a mesma quantidade de linhas para imprimir uma lista. Portanto, eu acredito que eu fiz alguma coisa errada na maneira de chamar a lista, no entanto não sei o que. Ajuda aê galera? Valeu ^^