Jump to content
Fórum Script Brasil
  • 0

Problemas Na Instalação


Suca Gross
 Share

Question

Vou explicar o que aconteceu:

Me inscrevi ontem no Iped e fiz pedido do curso php+mysql, mas antes de ser liberada a conta fiz um TestDrive com o tal login demo. No inicio do curso é pedido pra instalar o Apache e o Php. Fiz tudo como ele pediu mas aparece um momento em que ele faz um teste pra ver se está instalado corretamente, e é aí que dá tudo errado, pois o que deveria ser mostrado no teste não aparece, a página em php que ele pede pra criar não abre no navegador, diz que a página não existe.

Por favor me ajudem

Edited by Suca Gross
Link to comment
Share on other sites

17 answers to this question

Recommended Posts

  • 0

Se dá erro 404 (página não encontrada), o erro não é no PHP; provavelmente você digitou a URL errada.

Crie um arquivo HTML comum e tente abri-lo. Se carregar, é porque o Apache está corretamente instalado. Em seguida execute este arquivo:

phpinfo.php

<?php
phpinfo();
?>

Diga-nos se aparece alguma coisa.

Abraços,

Beraldo

Link to comment
Share on other sites

  • 0

Esse código que você citou é exatamente o teste em que o curso fala pra fazer. O curso diz pra criar um arquivo com esse código, salvar com o nome de teste.php e digitar no navegador http://localhost/teste.php

Fiz isso tudo, mas agora me lembrei de uma coisa, quando eu instalei o apache, ele pediu uma espécie de email e mais duas coisas em que não soube o que eram, aí deixei em branco, isso interfere em alguma coisa?

Link to comment
Share on other sites

  • 0

Oi... (ontem fui dormir XD) eu fiz o que vocês recomendaram, criei um arquivo somente com códigos html, salvei na pasta htdocs e tentei abrir, mas nada aconteceu. Eu fiz até um mesmo arquivo com a extenção .htm mas nada também XD

SE o problema for no Apache pode ser o seguinte: quando ele é instalado, o curso pede pra colocar o seguinte código no arquivo httpd.conf

ScriptAlias /php/ "C:/php/"

AddType application/x-httpd-php .php

AddType application/x-httpd-php-source .phps

Action application/x-httpd-php "/php/php-cgi.exe"

Em que "C:/php/" é o local em que o php foi instalado. Mas esse ódigo tá certo? E foi pedido pra adicionar esse código no fim do arquivo, mas não precisava mudar mais nada?

Já estou amolando vocês mas preciso né? XD

Xau

Link to comment
Share on other sites

  • 0

Ok... vou seguir esse tutorial e depois digo o que apareceu. E obrigada de novo.

Só uma coisa: as versões que estou usando do php é 5.2.3 e a do Apache é 2.2.4 , tem algum problema? É que esse tutorial fala pra fazer com outras versões.

Edited by Suca Gross
Link to comment
Share on other sites

  • 0

Não haverá praticamente nenhuma diferença. O que eu faço de diferente é usar o php5apache2_2.dll em vez do php5apache2.dll com um outro pacote citado pelo Fabyo. O caminho desse arquivo dserá inserido no LoadModule, no httpd.conf, como descrito no artigo.

Link to comment
Share on other sites

  • 0

para usuarios de Windows XP em diante menos 98/ME

agora va no prompt do DOS dentro da pasta c:\bin\apache2\bin digite:

apache -n "apache2" -k start isso ira instalar o serviço do apache e já startar ele

se aparecer alguma mensagem de erro leia em qual linha é o erro e ache essa linha no http.conf e leia as recomendações do inicio do tutorial

Isso está escrito no tutorial, mas acontece que eu não sei mecher muito bem no Prompt do DOS XD

Cheguei até a pasta falada mas não sei o que fazer pra ele aceitar o que foi pedido pra digitar (apache -n "apache2" -k start). O que eu faço?

Link to comment
Share on other sites

  • 0

Então acesse o Apache por meio do menu Iniciar->Programas. Lá você encontrará o Apache Monitor.

Iniciar -> Programas -> Apache HTTP Server -> Control Apache Server -> Monitor Apache Servers

Abrirá uma janela com os botões para iniciar, parar e reiniciar o Apache. Se iniciar corretamente, ótimo, Apache funcionando! :)

Link to comment
Share on other sites

  • 0

Eu dei start no apache e diz que a operação faliu :blink:

Por que?

E a tal página com o código

<?php

phpinfo();

?>

também não abre.

O Mozilla abre páginas php. Eu poderia instalá-lo ao invés de fazer tudo isso?

Edited by Suca Gross
Link to comment
Share on other sites

  • 0
Eu dei start no apache e diz que a operação faliu :blink:

Por que?

E a tal página com o código

<?php

phpinfo();

?>

também não abre.

Você adicionaou estas linhas no httpd.conf?

LoadModule php5_module "C:\php\php5apache2_2.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:\php"

* Os caminhos podem variar, dependendo de onde você instalou o PHP.

Verifique se os caminhos estão corretos.

O Mozilla abre páginas php. Eu poderia instalá-lo ao invés de fazer tudo isso?

Se o Apache não iniciar, nenhum navegador abrirá páginas PHP, nem FireFox, nem IE, Opera.... ;)

Link to comment
Share on other sites

  • 0

Fiz de um jeito diferente, mas descobri outro problema XD

http://superdownloads.uol.com.br/download/33/xampp-lite/

Utilizei este programa, que baixa tudo de uma vez, e realmente deu certo, as páginas php que possuem dentro do programa abrem sem dificuldade. Mas o problema é quando EU crio as páginas. Reparei que as páginas php que estão no programa não encaradas pelo sistema como Arquivo PHP, mas as páginas que eu crio (usando o bloco de notas e salvando com a extenção php) continuam sendo encaradas como arquivo de texto e não abrem no navegador.

Por que isso acontece?

Link to comment
Share on other sites

  • 0

Objeto não encontrado!

A URL requisitada não foi encontrada neste servidor. Se você digitou o endereço (URL) manualmente, por favor verifique novamente a sintaxe do endereço.

Se você acredita ter encontrado um problema no servidor, por favor entre em contato com o webmaster.

Error 404

localhost

07/20/07 17:32:15

Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.0

É mostrado isso aí, mas esse localhost que tem quase no final da página é um link que vai direto pro index.php do localhost, aí abre normalmente, entendeu? o link linkaria pra http://localhost

Edited by Suca Gross
Link to comment
Share on other sites

  • 0
... mas as páginas que eu crio (usando o bloco de notas e salvando com a extenção php) continuam sendo encaradas como arquivo de texto e não abrem no navegador.

Por que isso acontece?

pode ser que seus arquivos estejam sendo salvos por exemplo como 'teste.php.txt'

para salvar como php mesmo pelo bloco de notas você tem que na hora de salvar colocar o nome do arquivo entre aspas duplas...

"teste.php" (com as aspas) e não apenas teste.php

Pode ser isso.

Use algum editor, o bloco de notas não contribui muito.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Forum Statistics

    • Total Topics
      149.8k
    • Total Posts
      646.6k
×
×
  • Create New...