Jump to content
Fórum Script Brasil
  • 0

Upload Não Funciona Em Um Servidor Com Php 5.21


Norivan Oliveira

Question

Galera venho usando este codigo pra upload

<?php
$opcao = $_GET["opt"];

switch ($opcao)
{
     case "1":
         echo "<form enctype=\"multipart/form-data\" method=\"post\" 

action=\"upload.php?opt=2&p=". $_GET["p"] ."\">\n";
         echo "<input type=\"hidden\" name=\"MAX_FILE_SIZE\" 

value=\"99999999\">\n";
         echo "Arquivo: <input type=\"file\" name=\"foto\"><br>\n";
         echo "<input type=\"submit\" name=\"submit\" 

value=\"Enviar\">\n";
         echo "</form>\n";

         break;

     case "2":
         if ($_POST["submit"])
         {
             $arquivo = isset($_FILES["foto"]) ? $_FILES["foto"] : 

FALSE;
            
            preg_match("/\.(gif|bmp|png|jpg|jpeg){1}$/i", 

$arquivo["name"], $ext);
            
            $config["tamanho"] = 99999;
            $config["largura"] = 2000;
            $config["altura"] = 2000;
            $imagem_dir = "fotos/" . $_FILES["foto"]["name"];

    if (move_uploaded_file($arquivo["tmp_name"], $imagem_dir))
{
             echo "<script type=\"text/javascript\">\n";
                 echo "window.opener.define_nome_foto('" . 

$_FILES["foto"]["name"] . "'," . $_GET["p"] . ");\n";
             echo "window.close();\n";
             echo "</script>\n";
}
else
{
   die("Ocorreu uma falha no upload do arquivo. Verifique as 

configurações de permisões do seu servidor.");
}

         }
         break;
}

?>

Ele esta funcionando em todos os meus sites mas mandei ele pra um amigo meu e no servidor dele não funcionou, tipo faz o upload mas não aparece na pasta, quando ele me descreveu achei que tava indo pra temp mas não gravando na pasta de destino por falta de permisao 777, mas ele disse que deu 777 e outra o mais intrigante e que o codigo não retorna erro algum, executa todo ate o windw opner funciona.... mas não upa

A unica coisa que notei de diferente no servidopr dele e nos que eu já ultizo este codigo é que o dele tem php 5.21 confira o phpinfo dele http://www.belohorizonteautos.com/phpinfo.php

alguém tem ideia de porque não tá funcionando, será que é a versão do php?

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      152.1k
    • Total Posts
      651.8k
×
×
  • Create New...