Jump to content
Fórum Script Brasil
  • 0

(Resolvido) Não sei por onde começar!


shadow007

Question

Usando a estrutura de repetição (enquanto...faça) elabore um algoritmo que leia o salário dos 50 funcionários de uma Empresa e aplique um aumento salarial a todos os funcionários, usando a seguinte regra: Pressupõem-se que nenhum salário seja menor que zero.

A cada reajuste concedido, mostre o funcionário que recebeu reajuste, o salário antigo e novo salário.

a) 35% de aumento para os funcionários com salário menor que 1.500,00 reais;

B) 15% de aumento para os funcionários com salário entre 1.500,00 e 3.000,00 reais;

c) 5% de aumento para os funcionários com salários acima de 3.0000,00 reais;

galera já rexei a kuca mais ta dificio!!!!

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0
Usando a estrutura de repetição (enquanto...faça) elabore um algoritmo que leia o salário dos 50 funcionários de uma Empresa e aplique um aumento salarial a todos os funcionários, usando a seguinte regra: Pressupõem-se que nenhum salário seja menor que zero.

A cada reajuste concedido, mostre o funcionário que recebeu reajuste, o salário antigo e novo salário.

a) 35% de aumento para os funcionários com salário menor que 1.500,00 reais;

15% de aumento para os funcionários com salário entre 1.500,00 e 3.000,00 reais;

c) 5% de aumento para os funcionários com salários acima de 3.0000,00 reais;

não é tão dificil resolver

programa Remuneracao;

uses crt;

var
   func :array[1..50] of string;
   salario :array[1..50] of real;
   salarioatual :array[1..50] of real;
   i : integer;
Begin

  // clrscr;

   writeln('  Digite o nome do funcionario e salario');

   while i <= 50 do
   begin
      readln(func[i]);
      readln(salario[i]);
                  i:=i+1; 
   end;

   while i <= 50 do
   begin
      if salario[i] <= 1500 then
         salarioatual[i] := salarioatual[i] * 1.35;

      if (salario[i] > 1500) and (salario[i] <= 3000) then
         salarioatual[i] := salarioatual[i] * 1.15;

      if salario[i] > 3000 then
         salarioatual[i] := salarioatual[i] * 1.05;

      writeln('Funcionario ', i,' = ', func[i]);
      writeln('Salario Anterior ', i,' = ', salario[i]);
      writeln('Salario Atual ', i,' = ', salarioatual[i]);
                  i:=i+1; 


   end;

End.

abraço

Link to comment
Share on other sites

  • 0

Jhonas

"eu acho q ele nem começou trabalhar com vetor ou matriz ainda, creio q ficarar muito dificil de ele entender em pascal"

shadow007

vou te da umas dicas e você vai tentando resouver nesse caso( eu respondi com 6 variavel mas também resouvir com apenas 3) vamos trabalhar com as 6 pra você entender melhor

você vai precisar

das seguintes variaves

var
sal, ContSal_35, ContSal_15, ContSal_5 , aux : real {sal é Salario abreviado ok}
cont: inteiro 
inicio
cont:= 1
enquanto cont <= 50 faca
aux: = 0
escreva ("Entre com o valo do salario:   ")
   leia (sal)
se (sal < 1500) então
 ContSal_35:= {aqui você multiplica o valor da Porcentagem pelo salario e divide por 100}
      aux := {aqui você soma o  salario + a variavel q calculando a porcentagem (ContSal_35)
      escreva (contSal_35,"  +  ", sal," = ", aux,"         ") {dai agora você continua}
senao
      se 
         
         
      escreva (contSal_15," + ", sal," = ", aux,"         ")   
      senao
         se 
            
            
            escreva (contSal_5," + ", sal," = ", aux,"         ")
         fimse
      fimse
   fimse
cont := cont + 1
fimenquanto
fimalgoritmo

mais uma coisa quando ele fala entre um determinado valor e outro

você tem q aninhar os se de forma q compreenda entre um e outro

entre 7 e 70

se (variavel >= 7) e (variavel < 70) então

ele so vai analisar entre esses valores de 7 ate 69

se não entender volte a postar

Edited by nego drama
Link to comment
Share on other sites

  • 0

bom eu tentei fazer do geito q você falou nego drama ficou fácio de entender mais deu erro numa parti aki... fiz umas mudanças tambem

algoritmo "salario"
// Função :
// Autor :
// Data : 20/2/2008
// Seção de Declarações
var
sal, ContSal_35, ContSal_15, ContSal_5, aux: real
cont: inteiro

inicio
// Seção de Comandos
cont <- 1
enquanto cont <= 50 faca
   aux <- 0
   escreva ("entre com o valor do salario: ")
   leia (sal)
   se (sal < 1500) então
      ContSal_35 <- (35 * sal / 100)
      aux: = (sal + ContSal_35)
      escreva (ContSal_35, " + ", sal " = ", aux "            ")   <<<<----- aki q da erro!!!!
   senao
      se (sal <=3000) e (sal >=1500) então
         ContSal_15 <- (15 * sal / 100)
         aux <- (sal + ContSal_15)
         escreva (ContSal_15, "+", sal "=", aux)
      senao
         se (sal > 3000) então
            ContSal_5 <- (5 * sal / 100)
            aux:= (sal + ContSal_5)
            escreva (CotSal_5, "+", sal "=", aux "           ")
         fimse
      fimse
   fimse
fimenquanto

fimalgoritmo

Link to comment
Share on other sites

  • 0

e programa copilou legal mai so deu um probleminha...

me parece q ele ficou infinito não para, o certo era so chegar até 50 não é? mais ele não para... como eu faço para corrigir?

eu fiz desse jeito oOOOOoooo!!!!

algoritmo "remuneração"
// Função :
// Autor :
// Data : 21/2/2008
// Seção de Declarações 
var
  sal,ContSal_35,ContSal_15,ContSal_5,aux: real
  cont: inteiro
inicio
// Seção de Comandos
cont <- 1
enquanto (cont < 50) faca
aux <- 0
escreva (" entre com o salario: ")
leia (sal)
se (sal < 1500) então
ContSal_35 <- (35 * sal / 100)
aux <- (sal + ContSal_35)
escreva (ContSal_35, "+", sal, "=", aux, "            ")
senao
se (sal <= 3000) e (>= 1500) então
ContSal_15 <- (15 * sal / 100)
aux <- (sal + ContSal_15)
escreva (ContSal_15, "+", sal, "=", aux, "            ")
senao
se (sal > 3000) então
ContSal_5 <- (5 * sal / 100)
aux <- (sal * ContSal_5)
escreva (ContSal_5, "+", sal, "=", aux, "             ")
fimse
fimse
fimse
fimenquanto
fimalgoritmo

o trêm não para não -.-"

Link to comment
Share on other sites

  • 0

deu no mesmo kara

eu fiz desse jeito oOOoo!!!

algoritmo "semnome"
// Função :
// Autor :
// Data : 22/2/2008
// Seção de Declarações 
var
    sal,ContSal_35,ContSal_15,ContSal_5,aux: real
  cont: inteiro

inicio
// Seção de Comandos
cont <- 1
enquanto (cont < 50) faca
aux <- 0
escreva (" entre com o salario: ")
leia (sal)
se (sal < 1500) então
ContSal_35 <- (35 * sal / 100)
aux <- (sal + ContSal_35)
escreva (ContSal_35, "+", sal, "=", aux, "            ")
senao
se (sal <= 3000) e (>= 1500) então
ContSal_15 <- (15 * sal / 100)
aux <- (sal + ContSal_15)
escreva (ContSal_15, "+", sal, "=", aux, "            ")
senao
se (sal > 3000) então
ContSal_5 <- (5 * sal / 100)
aux <- (sal * ContSal_5)
escreva (ContSal_5, "+", sal, "=", aux, "             ")
 cont <- + 1
fimse
fimse
fimse
fimenquanto

fimalgoritmo
você falou pra colokar
cont <- +1
fimse
fimse
fimse
fimenquanto
não é? mais eu vi um exemplo q era desse jeito oOOo
fimse
fimse
fimse 
cont <- +1
fimenquanto

abraçoOOOoo :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      152k
    • Total Posts
      651.6k
×
×
  • Create New...