• 0
Sign in to follow this  
crucifier

Zica Com Iframe

Question

vejam voces mesmos:

http://www.centropaulista.com.br/chavantes/teste.htm

a tabela q esta dentro do iframe é de 650px...o iframe é de 750px...e mesmo assim ta dando akela rolagem embaxo...tentei de tudo quanto é jeito mas não consigui...alguém tem alguma solucao pra isso ou sabe o motivo??(com certeza se tiver a solucao é bem melhor q ter o motivo=])

se der pra responder hoje eu agradeco porq esse negocio ta co prazo curto

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

não adianta=\\

já ta em todos isso...top left down e o otro q eu não lembro lá...

mesmo q eu coloke uma tabela de 100px não adianta!..fik com akela rolagem

Share this post


Link to post
Share on other sites
  • 0

Talvez não seja o iframe... olhando o codigo fonte das duas página. Na página teste.htm eu fiz assim:

<table width="100%" height="100%" border="1" cellpadding="0" cellspacing="0" >

  <tr>

    <td>

        <iframe src="inicial.htm" width="100%" height="100%"frameborder=0 ></iframe>

    </td>

  </tr>

</table>

e sem align na tabela.

mesmo assim ainda tem a barra... veja se alguma das figuras não está empurrando e deixando maior.

Share this post


Link to post
Share on other sites
  • 0

Bingoooo, eu acho rssss. Tira isso:

 <tr> 
    <td><p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p>
      <p>&nbsp;</p></td>
  </tr>

aqui saiu a barra depois de tirar isso

Share this post


Link to post
Share on other sites
  • 0

claro mais aih vai o conteudo não é?...precisa ter conteudo o site...aqueles <p> foi pra simular um conteudo grande saka?

ele só ta dando rolagem embaxo quando da rolagem do lado=\\

Share this post


Link to post
Share on other sites
  • 0

ue, porque não fez o q o brill disse?

testei e funcionou:

<IFRAME src="teste_arquivos/inicial.htm" frameBorder=0 width=765 
      height="100%" scrolling = "no">

Share this post


Link to post
Share on other sites
  • 0

O que ele quer é o seguinte: Uma barra de rolagem vertical sem horizontal, o scrolling que eu sugeri faz sumir todas as barras, mas ele quer que a vertical continue ali, por causa do conteúdo.

Tanta fazer assim... No arquivo inicial.htm (onde esta o topo e o conteúdo), excluir a primeira linha do código, é o (DOCTYPE). Algo parecido com <!DOCTYPE HTML PUBLIC "-//W3C//... Parece estranho mas aqui deu certo! E experimenta aumentar o width do iframe para 770 também.

Share this post


Link to post
Share on other sites
  • 0

puuutzzz brill...tu é um genio cara...eu nunca pensaria naquela linha de codigo...pra mim parecia inofensiva cara...

nossa muito obrigado mesmo...deu certinho... smile.gif

to ti devenu essa!

valewzao mesmo!...brigadao!

Share this post


Link to post
Share on other sites
  • 0

é isso ae!

estando bom para ambas as partes!

fechando ae!

qqer coisa manda pm que agente abre novamente!

abraços

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this