Jump to content
Fórum Script Brasil
  • 0

Dicas de programas


Prog

Question

10 answers to this question

Recommended Posts

  • 0

São ótimos compiladores de algorítmos, pra quem está começando a bela jornada da vida de programar, hehehe...

Resaltando só por curiosidade, o VISUalg, na versão 2.0, você pode programar em pascal também, você pode escolher a linguagem, que queira, em portugol, pascal, clipper e visual basic, :lol:

Programar é uma arte pessoal...

Edited by paulo_linux
Link to comment
Share on other sites

  • 0

Alguém poderia me ajudar na construção de um algoritmo ?

- Construa um algoritmo para entrar com um número de vezes que será repetido, encontre os números pares no intervalo de 1 até o número digitado, mostre os números pares.

Obs: ficarei muito grata se alguém conseguir me ajudar !
Meu Email : kerly.amrl.barros@hotmail.com

Link to comment
Share on other sites

  • 0

Sou novo aqui no fórum e não estou conseguindo resolver o seguinte algoritmo usando o VisuAlg. Alguém pode me ajudar!!! Socorro....

//Elabore um algoritmo para ler:

//O valor da mensalidade do curso;
//O turno do curso escolhido (M para manhã, T para tarde e N para noite);
//Categoria do aluno (B para baixa renda e N para renda normal);


//O algoritmo deve calcular e exibir:

//Valor total do curso durante 1 ano (valor da mensalidade do curso vezes 12);
//O valor da mensalidade do aluno. Essa mensalidade poderá sofrer alterações, dependendo do turno escolhido e da categoria do aluno, conforme descrito abaixo:
//- Caso o turno escolhido for M (manhã), não haverá nenhum desconto;

//- Caso o turno escolhido for T (tarde), será atribuído um desconto de 5%;

//- Caso o turno escolhido for N (noite), será atribuído um desconto de 10%;

//ATENÇÃO: Para alunos classificados na categoria de renda familiar baixa, será acrescido um desconto adicional de 10%.

 

//Tentei resolver assim... Mas não está calculando

var

mensalidade : real
Turno : literal
Categoria : literal
mensal : real
valortotal : real
inicio
// Seção de Comandos

escreva ("Valor da mensalidade:")
leia (mensalidade)
escreva (" Digite o turno, M (manhã), T (tarde) ou N (noite):")
leia (Turno)
escreva (" Categoria do aluno (B para baixa renda e N para renda normal):")
leia (categoria)


      se (Turno="M") e (Categoria = "N")então
      mensal :=  mensalidade
      escreval("mensalidade:", mensal)
      senao
   
         se (Turno="M") e (Categoria = "B") então
         mensal :=  0,90*mensalidade
         escreval("mensalidade:", mensal)
         senao
   
            se (Turno="T") e (Categoria = "N") então
            mensal :=  0,95*mensalidade
            escreval("mensalidade:", mensal)
            senao
   
                se (Turno="T") e (Categoria = "B") então
                mensal :=  0,85*mensalidade
                escreval("mensalidade:", mensal)
                senao
   
                   se (Turno="N") e (Categoria = "N") então
                   mensal :=  0,90*mensalidade
                   escreval("mensalidade:", mensal)
                   senao
   
                      se (Turno="N") e (Categoria = "B") então
                      mensal :=  0,80*mensalidade
                      escreval("mensalidade:", mensal)
                      senao
                      Escreva ("Digite uma infomção válida!!!")
                      fimse
                   fimse
                fimse
             fimse
          fimse
       fimse


valortotal := mensal*12
escreval("Custo Anual:", valortotal)

            

Link to comment
Share on other sites

  • 0

Alguém me ajuda, estou tentando fazer um programa que eu preencho uma matriz 6x6 e quero que o programa lei-a a última linha da matriz ou seja linha 5  e percorra as linhas anteriores 4,3,2, e pare quando achar o primeiro número que se que se repete na linha 5, segue o código que fiz:

#include "stdio.h"
#include "conio.h"
#define L 6
#define C 6

int main(void)
{
    int M[L][C];
    int i,j,n,repete,k;
    printf("Digite ELEMENTO da:\n");
    for(i=0;i<L;i++)
    {
        for(j=0;j<C;j++)
        {
            printf("linha %d, coluna %d da matriz: ",i,j);
            scanf("%d",&M[j]);
        }
    }
     for (k=0; k<6; k++)
{
   n = M[5][k];
   repete = 0;
   for (i  = L; i >=0; i--)
   for (j=0; j<6; j++)
   {
   
}
   
       if (repete ==1)
       
   printf("primeira dezena = %d",n);
   
   
   if (repete ==0)
 printf ("não tem dezena, ultimo lido %d", n);
return 0;
      }

Sem título6.png

Link to comment
Share on other sites

  • 0

Pessoal, 
Segue uma dica de APP Android para ajudar nos estudos.

https://play.google.com/store/apps/details?id=br.com.heverton.lepapp

Tem portugol e várias das principais linguagens.


Ele revoluciona a forma de aprender linguagens de programação, utilizando modelos modernos e comprovados no ensino de idiomas de forma simples, intuitiva e divertida.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      152.1k
    • Total Posts
      651.9k
×
×
  • Create New...