Search the Community

Showing results for tags 'apache'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Programação & Desenvolvimento
    • ASP
    • PHP
    • .NET
    • Java
    • C, C++
    • Delphi, Kylix
    • Lógica de Programação
    • Mobile
    • Visual Basic
    • Outras Linguagens de Programação
  • WEB
    • HTML, XHTML, CSS
    • Ajax, JavaScript, XML, DOM
    • Editores
  • Arte & Design
    • Corel Draw
    • Fireworks
    • Flash & ActionScript
    • Photoshop
    • Outros Programas de Arte e Design
  • Sistemas Operacionais
    • Microsoft Windows
    • GNU/Linux
    • Outros Sistemas Operacionais
  • Softwares, Hardwares e Redes
    • Microsoft Office
    • Softwares Livres
    • Outros Softwares
    • Hardware
    • Redes
  • Banco de Dados
    • Access
    • MySQL
    • PostgreSQL
    • SQL Server
    • Demais Bancos
  • Segurança e Malwares
    • Segurança
    • Remoção De Malwares
  • Empregos
    • Vagas Efetivas
    • Vagas para Estágios
    • Oportunidades para Freelances
  • Negócios & Oportunidades
    • Classificados & Serviços
    • Eventos
  • Geral
    • Avaliações de Trabalhos
    • Links
    • Outros Assuntos
    • Entretenimento
  • Script Brasil
    • Novidades e Anúncios Script Brasil
    • Mercado Livre / Mercado Sócios
    • Sugestões e Críticas
    • Apresentações

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 19 results

  1. Ao tentar baixar o arquivo com a extensão .EXE no site, os arquivos estão vindo como .GZ Ambiente Centos 7 64 Apache 2.4.6 Mudando o arquivo em /etc/httpd/conf/httpd.conf Eu já tentei usar cada um destes métodos abaixo, no entanto, sem sucesso (eu reiniciei o apache e deletei o cache do navegador em cada tentativa): 1: SetEnvIfNoCase Request_URI .exe $ no-gzip não varia 2: SetEnv não-gzip 1 3: SetEnv mod_deflate off 4: SetEnv no-gzip off 5: No arquivo /etc/httpd/conf.modules.d/00-base.conf eu comentei: LoadModule deflate_module modules / mod_deflate.so 6: Eu tentei apagar o arquivo, mas não funcionou. /usr/lib64/httpd/modules/mod_deflate.so Toda ajuda é bem vinda. Eu pesquisei muito, confiei em vários testes com soluções semelhantes, mas sem sucesso. Eu não sei mais o que tentar.
  2. Boa tarde Pessoal.. sou novo por aqui..!! Preciso configurar meu apache e php.ini para subir duas paginas em "produção" na web!! o que preciso alterar neste dois arquivos, para produção Estou usando Xampp v3.2.3 Alguém pode me ajudar?!!! Aguardo !! Bom trabalho!
  3. Boa noite pessoal, tudo bem? Eu estou rodando o Apache em um servidor Linux. A versão do meu PHP é a 5.3.3. Eu preciso criar uma conexão com um servidor externo, para buscar algumas colunas. Porém, o servidor externo é Windows com SQL Server. Quando eu tento efetuar a conexão, recebo a msg de "could not find driver". Segue o meu script: <?php try { $hostname = "myhost"; $port = 10060; $dbname = "tempdb"; $username = "dbuser"; $pw = "password"; $dbh = new PDO ("dblib:host=$hostname:$port;dbname=$dbname","$username","$pw"); } catch (PDOException $e) { echo "Failed to get DB handle: " . $e->getMessage() . "\n"; exit; } $stmt = $dbh->prepare("select name from master..sysdatabases where name = db_name()"); $stmt->execute(); while ($row = $stmt->fetch()) { print_r($row); } unset($dbh); unset($stmt); ?>
  4. Bons dias. Estou a desenvolver o website da minha banda de tributo ao reggae e estou a tentar ser o mais rigoroso possível no que diz respeito a SEO. Tenho utilizado (entre outros) o https://sitechecker.pro como uma das ferramentas para medir a otimização. Fiz vários testes, mas alguns não me permitiram entrar corretamente no website. Imaginem o seguinte cenário: www.aminhabanda.com - entro sem problemas na página inicial do website; www.aminhabanda.com/ - encaminha para www.aminhabanda.com - entro sem problemas na página inicial do website; Mas tenho problemas nas sub pastas do website. Passo a dar um exemplo: www.aminhabanda.com/pt/homepage - está ok www.aminhabanda.com/pt/homepage/ - não encaminha para www.aminhabanda.com/pt/homepage (sem a barra final) e dá o erro 500. No teste efectuado no site https://sitechecker.pro, todas as páginas existentes na subpasta "/pt/", dão 2 erros a vermelho. são eles: Vulnerabilidade da URL: Ending slash redirects not configurate correctly. Vulnerabilidade da URL: Injecting parameters in path is processed failed Como se resolve esta questão? Já pesquisei em dezenas de páginas, mas não estou a conseguir apanhar a lógica. Posso fornecer o htaccess que tenho desenvolvido caso queiram consultar. Obrigado pela ajuda e Bom Ano.
  5. Bom, acho que tive progresso: Tenho o .htaccess abaixo e parece estar funcionando bem: <ifModule mod_rewrite.c> # LIGA O MOTOR DE REESCRITA (Rewrite) RewriteEngine on # BUSCA PELA BASE /teste/ NO HOST ACESSADO RewriteBase /teste/ # FAZ UMA ESCESSÃO DE REDIRECIONAMENTO PARA A PÁGINA manutencao.php CASO O NAVEGADOR RECEBA ELA NA URL RewriteCond %{REQUEST_URI} !/manutencao.php$ [NC] # FAZ UMA ESCESSÃO E LIBERA IMAGENS NESTA PAGINA RewriteCond %{REQUEST_URI} !.(jpe?g?|png|gif) [NC] # REENVIA QUALQUER ACESSO AO SITE PARA A PÁGINA index.php NO HOST INDICADO LIBERANDO AS EXCESSÕES ACIMA DESCRITAS RewriteRule .* index.php #RewriteRule .* http://localhost/teste/index.php #RewriteRule .* http://localhost/teste/index.php [R=302,L] </ifModule> Porém, tenho algumas dúvidas: A ) Nenhuma das linhas abaixo funciona, ambas dá erro 500: #RewriteRule .* http://localhost/teste/index.php #RewriteRule .* http://localhost/teste/index.php [R=302,L] Ou seja, não consigo enviar para o endereço de host completo apenas redireciona corretamente para a página específica :index.php Neste caso, se eu acessar por exemplo: http://localhost/teste/outroteste/testando/index.php o redirecionamento se fará para http://localhost/teste/outroteste/testando/index.php ou seja, para o mesmo link e não para http://localhost/teste/index.php Como se era esperado. Como corrigir isso? B) A correção do item anterior deve resolver o problema deste item que é a lincagem dos arquivos css, js, imagens e tudo mais que compõem o arquivo a ser aberto. Quem poderá me ajudar? Arquivos envolvidos: .htaccess <ifModule mod_rewrite.c> # LIGA O MOTOR DE REESCRITA (Rewrite) RewriteEngine on # BUSCA PELA BASE /teste/ NO HOST ACESSADO RewriteBase /teste/ # FAZ UMA ESCESSÃO DE REDIRECIONAMENTO PARA A PÁGINA manutencao.php CASO O NAVEGADOR RECEBA ELA NA URL RewriteCond %{REQUEST_URI} !/manutencao.php$ [NC] # FAZ UMA ESCESSÃO E LIBERA IMAGENS NESTA PAGINA RewriteCond %{REQUEST_URI} !.(jpe?g?|png|gif) [NC] # REENVIA QUALQUER ACESSO AO SITE PARA A PÁGINA index.php NO HOST INDICADO LIBERANDO AS EXCESSÕES ACIMA DESCRITAS RewriteRule .* index.php #RewriteRule .* http://localhost/teste/index.php #RewriteRule .* http://localhost/teste/index.php [R=302,L] </ifModule> index.php INDEX <?php header ("Location: http://localhost/teste/manutencao.php"); ?> manutencao.php <?php echo "MANUTENÇÃO "; ?>
  6. Olá, vi uma matéria referindo-se à manutenção de sites na url http://desenvolvimentoparaweb.com/miscelanea/htaccess-redirecionamento-automatico-sites-em-manutencao/ e fiquei com uma dúvida e gostaria de saber se podem me ajudar a tirá-la. Seguinte: tenho um site e nele, redireciono, via .htacces todas as requisições para serem tratadas no index.php conforme abaixo: RewriteEngine On RewriteBase /crud/ RewriteRule .* index.php Porém, tenho uma classe que trata as entradas e tem um atributo static private $livre = true; Ela, se setada para false, envia, no construtor da classe , para a pagina mantencao.php. public function __construct($_util) { if (self::$livre == "false") header ("Location: manutencao.php"); Porém, como todas as requisições acabam indo para o index.php, quando chega na manutenção.php acaba voltando para index.php por cauda do .htacess e fica num loop infinito. Será que existe uma forma de fazer uma tratativa no .httaccess de forma tal que se a url que chega for manutencao.php, então o redirecionamento para index.php não ocorra? Grato se puder ajudar. Att, Carlos Rocha
  7. Bom dia, boa tarde ou boa noite, pessoal Preciso de um auxilio com um site montado em .jsp. Vou incluir mais uma página a ele, consequentemente, mais um menu. Kapcon Contabilidade é o site em questão. Tenho duas dúvidas: a primeira é em qual pasta montar a base de testes com um servidor local se há dois arquivos index.jsp em pastas diferentes na estrutura. A segunda dúvida é o erro que o servidor apresenta quando o botão "eventos sociais" no menu do site é clicado. É necessário modificar algum arquivo .class ou .java? Para melhor ilustração, anexei algumas imagens.
  8. Olá. Gostaria de uma ajudinha. O caso é o seguinte. Desenvolvi uma aplicação comercial em PHP com JEASYUI (https://www.jeasyui.com/index.php) ela já funciona localmente sem problemas. O que acontece as vezes, é que por algum motivo qualquer, o APACHE não inicializa com o Windows e a aplicação simplesmente não roda. (Obs. Eu sei que PHP não foi feito para esta finalidade, mas é a única linguagem que eu domino.) Enfim, as vezes isso acontece com algum usuário leigo e o mesmo não sabe como proceder, mesmo eu tendo colocado um atalho no Desktop para inicializar o Apache. Eu gostaria se possível, de que quando o usuário abrisse a aplicação ela carregasse primeiro um HTML com Javascript para tentar se comunicar com o servidor web, caso o servidor estiver online ela direciona para a aplicação, caso contrário ela abrisse uma mensagem informando quais os procedimentos seguir. Na verdade a dúvida é só quanto a comunicação com Javascript e o Server. Isso seria possível? Desculpem o texto ser tão extenso, mas tentei deixar bem explicado. Desde já, agradeço a atenção.
  9. Olá, Gostaria de saber porque minha aplicação em PHP não está funcionando. Estou usando Windows, Apache, PHP. Aplicação simples. Tem 1 formulário e uma página em PHP pra receber os dados desse formulário. Mas a aplicação não está funcionando. Quando clico no campo "Register" do formulário, o programa mostra o código do PHP e não funciona. Formulário: <form method='post' action='register.php'> Username: <input type="text" name="username"/> <br/> Password: <input type="password" name="password" /> <br/> Confirm Password: <input type="password" name="confirm" /> <input type="submit" value="Register" /> PHP: <?php if ($_POST) { $password = $_POST['password']; $confirm = $_POST['confirm']; if($password != $confirm) { ?> <span style="color:red"> Erro. As passwords não são iguais. </span> <?php } } ?> <?php // <form method='post' action='register.php'> ?> [Edit] O apache está funcionando. A página que mostra "It Work's" está funcionando. [Edit] A página "It Work's" é em HTML. Acho que o PHP não deve estar funcionando ou habilitado no Apache. Obrigado. (Resolvido) Instalei novamente o apache e agora está funcionando.
  10. jamiel

    Url Amigável PHP

    HTACCESS: RewriteEngine On RewriteCond %{SCRIPT_FILENAME} !-f RewriteCond %{SCRIPT_FILENAME} !-d RewriteRule ^(.*)$ index.php?url=$1 - Item de menu: <li><a href="<?php URL_BASE ?>contato">CONTATO</a></li> - Página de post (single-post): http://localhost/infrainfo-2016/post/website-audit/5 - Digamos que gostaria de ir para a página de contato (item de menu), o link para onde sou direcionado não funciona: http://localhost/infrainfo-2016/post/website-audit/contato O acesso tá funcionando normalmente. O problema é quando necessito voltar para outras páginas de um nível anterior. Agradeço desde já qualquer ajuda.
  11. Olá, eu baixai o xampp e configurei já está tudo pegando, mas ai eu vou executar meu projeto, a página do navegador fica em branco mesmo eu colocando "locahost". Eu salvei os projetos na pasta htdocs do xampp e antes de executar eu liguei o apache, já desinstalei tudo e fiz tudo de novo só que não funcionou, eu preciso urgente de ajuda pois tenho que dar continuidade ao meu TCC, alguém poderia me ajudar?
  12. Olá, sobre url's amigáveis, estou com dificuldade em redirecionar para uma página enviando um parâmetro. Fiz um teste simples na página teste.php (apenas um código echo da variável parametro): echo $_GET["parametro"] e meu .htaccess: RewriteEngine On RewriteRule ^teste/([a-z0-9-]+)/?$ /teste.php?parametro=$1 [NC] Acredito que a ER esteja correta, mas renderizando essa página, me retorna o erro: Notice: Undefined index: parametro Existe alguma outra configuração necessária para enviar com parâmetro? Obrigado pela atenção!
  13. Olá, estou com dificuldades em implementar url amigável em meu projeto. Primeiro: o .htaccess em localhost, fica no dir www/ ou www/projeto/ ? Segundo: consigo acessar a página normalmente sem .php (projeto.com.br/index), mas quando coloco uma /, ele quebra todos as referencias de CSS e JS (projeto.com.br/index/) Estou seguindo diversos tutoriais, e não está saindo. Já habilitei mod_rewrite do meu apache e adicionei comando abaixo no http.conf: <Directory "C:/wamp64/cgi-bin"> AllowOverride None Options None Require all granted </Directory> Meu .htaccess está assim: <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteRule ^index/(css|js|img)/(.*)?$ /$1/$2 RewriteRule ^index/?$ /index.php [NC,L] </IfModule> Alguém pode me auxiliar? Agradeço a atenção!
  14. Alguém me ajuda por favor! Instalei xampp para aprender coisas nova no magento mas mesmo instalando o MySQL e o apache corretamente o erro persiste.Quando vou aos primeiros passos de instalação do magento me deparo com essa mensagem : PHP extensão "sabão" deve ser carregado. já Procurei varias ajudas mas,só encontro sites para programadores php como não sei programar em php fico perdido
  15. Estou tentando fazer um wrapper para a API olho vivo, da SPtrans http://www.sptrans.com.br/desenvolvedores/APIOlhoVivo/Documentacao.aspx?1#docApi-autenticacao Estou usando a biblioteca apache commons para fazer as requisições POST. Por algum motivo estou recebendo Error 404, No HTTP resource was found that matches the request URI 'http://api.olhovivo.sptrans.com.br/v0/Login/Autenticar'. Pensei que talvez a API não estivesse funcionando, mas achei esse wrapper em python https://gist.github.com/jonathansp/7491340 e testei ele com a minha chave de liberação e tudo funcionou. Essa é a função que executa o POST. public static String executePost() { CloseableHttpClient client = HttpClientBuilder.create().build(); String targetURL = "http://api.olhovivo.sptrans.com.br/v0/Login/Autenticar"; List<NameValuePair> urlParameters = new ArrayList<>(); urlParameters.add(new BasicNameValuePair("token","3de5ce998806e0c0750b1434e17454b6490ccf0a595f3884795da34460a7e7b3")); try { HttpPost post = new HttpPost(targetURL); post.setEntity(new UrlEncodedFormEntity(urlParameters)); HttpResponse response = client.execute(post); System.out.println("Response Code : " + response.getStatusLine().getStatusCode()); BufferedReader rd = new BufferedReader( new InputStreamReader(response.getEntity().getContent())); StringBuffer result = new StringBuffer(); String line = ""; while ((line = rd.readLine()) != null) result.append(line); System.out.println(result.toString()); return result.toString(); } catch (Exception e) { e.printStackTrace(); return null; } } Isso é o que é printado: Response Code : 404 {"Message":"No HTTP resource was found that matches the request URI 'http://api.olhovivo.sptrans.com.br/v0/Login/Autenticar'."}
  16. Estou tentando fazer um wrapper para a API olho vivo, da SPtrans http://www.sptrans.com.br/desenvolvedores/APIOlhoVivo/Documentacao.aspx?1#docApi-autenticacao Estou usando a biblioteca apache commons para fazer as requisições POST. Por algum motivo estou recebendo Error 404, No HTTP resource was found that matches the request URI 'http://api.olhovivo.sptrans.com.br/v0/Login/Autenticar'. Pensei que talvez a API não estivesse funcionando, mas achei esse wrapper em python https://gist.github.com/jonathansp/7491340 e testei ele com a minha chave de liberação e tudo funcionou. Essa é a função que executa o POST. public static String executePost() { CloseableHttpClient client = HttpClientBuilder.create().build(); String targetURL = "http://api.olhovivo.sptrans.com.br/v0/Login/Autenticar"; List<NameValuePair> urlParameters = new ArrayList<>(); urlParameters.add(new BasicNameValuePair("token","3de5ce998806e0c0750b1434e17454b6490ccf0a595f3884795da34460a7e7b3")); try { HttpPost post = new HttpPost(targetURL); post.setEntity(new UrlEncodedFormEntity(urlParameters)); HttpResponse response = client.execute(post); System.out.println("Response Code : " + response.getStatusLine().getStatusCode()); BufferedReader rd = new BufferedReader( new InputStreamReader(response.getEntity().getContent())); StringBuffer result = new StringBuffer(); String line = ""; while ((line = rd.readLine()) != null) result.append(line); System.out.println(result.toString()); return result.toString(); } catch (Exception e) { e.printStackTrace(); return null; } } Isso é o que é printado: Response Code : 404 {"Message":"No HTTP resource was found that matches the request URI 'http://api.olhovivo.sptrans.com.br/v0/Login/Autenticar'."}
  17. Gente, tenho que fazer o upload de uma aplicação que contem arquivos .war, já li algumas coisas mais não consegui nada então como faço para rodar esta aplicação? qual programa devo usar ?
  18. Olá pessoal, tudo bem? Sou novo em php e estou instalando o wampserver mas na hora de abrir o BD phpMyAdmin , ta dando o seguinte erro: #1045 - Access denied for user 'root'@'localhost' (using password: NO). phpMyAdmin tentou se conectar no servidor MySQL e a conxão foi recusada. Você deve checar o servidor, nome de usuário e senha no config.inc.php e se certificar que correspondam com as informações fornecidas pelo administrador do servidor MySQL. Pessoal, já tentei de tudo o que falavam em site a respeito de senha e do campo http.config.php. Já não sei mais o que fazer. Se alguém conhece bem isso me ajuda, até se puder enviar várias opções para mim ir por eliminatória eu agradeço muito. grato Luiz Carlos